Soundcard HD Intel (ALC268 Analog) stopped working after upd

After downloading a whole bunch of updates I no longer have working sound, quite nasty since I can’t stand not having music.

Using KDE 4.2 and openSUSE 11.1 x86_64.
After logging in I get a message

The audio playback device HD Intel (ALC268 Analog) does not work. Falling back to.

Since I had some problems previously with Amarok and sound I figured reinstalling would be faster than fiddling around with the packages and went ahead and did that… after the install sound works, update everything and the sound stops working.
Tried hooking up my USB soundcard as well (which is buggy with 44800KHz audio, but it too no longer produces any sound but just an error message that it does not work.
Tried running alsaconf as well, but to no avail.

Worth to note, I can no longer start kmix… it simply refuses to start.

I saw your post, but I will be staying out of this thread. With KDE-4.2. you have a non-nominal configuration, and so a user who had also installed KDE-4.2 (and knows the audio quirks associated with that) will need help you.

There could be all sorts of reasons for your sound (and kmix) problem, … from kernel update problem, to a KDE-4.2 related problems. The KDE-4.2 install introduces enough unknowns that I will not venture an opinion nor a recommended solution.

Hopefully someone else will chime in.

Good luck.

Suspect it’s the kernel update as I think after replacing it with the default instead of the kernel that comes with the wireless-tools is what caused my issues in the first place.

But the wireless-tools kernel was preventing me from updating the NVIDIA drivers, so I chose to replace the kernel that came with the wireless-tools with the default.
( Just use wired instead as my laptop is in one place when I’m at home and my router has been kicking off the network while transferring large files lately, when I’m not at home I’m forced to use windows… so need for wireless tools (and its kernel) )

Then again it was ~148 packages that were updated so it could be something entirely else…

Any way to downgrade the kernel without doing a manual install of the NVIDIA drivers?
Kinda need both hardware acceleration and audio to watch HD movies.

Seems like the bug sneaked in, in kernel

Which I guess makes sense as YaST offers me the option to downgrade it to which is what I assume to be what I’ve been using up till now.
Strange a mere ‘regression’ would survive all the way up to though…

Installing an older version of the kernel, kernel-source and manually installing the latest nvidia drivers goes fine and gets me what I want.
Working hardware acceleration along with audio, now I can enjoy my movies again instead of having to choose between choppy or mute playback.

Wonder why YaST wouldn’t let me install the latest nvidia drivers without updating the kernel as apparently it isn’t needed and made me waste some precious time.

And one reboot later it stopped working again…
Kernel is still .9 but for some reason it refuses to give me any sound again.

Updated to KDE 4.3, no luck either.

When I start a program as root from my normal profile it has working sound, if I log in as root there isn’t any sound.
(Yeah I know… shoot me… I just want working audio)

If anyone has a solution I’d love to hear it as I’m not really comfortable with running a browser/flash as root just to be able to hear something. Amarok shouldn’t be able to do too much harm… but flash :frowning: