Soundblaster X-Fi Titanium and not good sound


I just reinstalled openSUSE to version 42.1 and sound is terrible for me now. Till version 13.2 I always configured the soundcard via Yast2 Sound and then set up 5.1 in system setup. But now when I do tests on all speakers I can’t almost hear bass speaker. When I play some songs, they sound strange. The sound quality isn’t as good as in previous versions of openSUSE and I did the same setup as always. Does anybody occurred with this problem? I don’t know, how to figure it out. If it can’t then I’ll probably reinstall 13.2 back.

Thanks for any response

You say “when you do tests on all speakers” …

When I read that I asked … ‘tests with what applications’ ? How many speakers are we talking about ? Is this a 2.1 system ? 4.0? 4.1 ? 5.0 ? 5.1 ? 7.1 ?

Assuming you have pulse audio enabled, then install ‘pavucontrol’ and advise us what you have selected in the ‘configuration’ tab. And what are the selections in that tab that you could have selected that you did not select ? Does your selecting any of those other settings help ? Note that if you select a different setting in that configuration tab, you may then need to go to your multimedia app and change its settings.

Also, what desktop ? KDE ? Gnome ? If KDE, what backend are you using ? vlc ? gstreamer ?

I forgot to mention. It is 5.1 system. I tested the speakers with this as always (I have it in czech language so I don’t know how it is named in english):

Setting is Analog Surround 5.1 Output. I have I think all possible settings available, but because I have 5.1 speakers, then I always choose this as the only suitable option there. I have already tried different settings but nothing helped. I did the same setup on every distribution of openSUSE, so I don’t understand why now the sound is not as always. And I am using KDE and Gstreamer backend.

as always’ does not mean anything to me.

I have a 5.1 system. Sometimes I find 4.1 works better, dependant on the build of the multimedia application that I am using. Sometimes 5.1 works better. For my hardware it depends on the multimedia app. You did not say which multimedia app . … vlc ? smplayer ? mplayer ? Did you try aplay ? I find they all have different behaviour with a 5.1 system with my hardware which, by the way, is completely different from the hardware on your PC.

How about we use a common baseline ? Try this test from a terminal/konsole:

speaker-test -c6 -t wav -l1

How is the volume there from the different channels ?

Try also downloading this file:

then unzip the file, navigate to the directory where the file is unzipped and play it with different applications:

vlc chan-id.wav


mplayer chan-id.wav

and maybe:

smplayer chan-id.wav

and also try:

aplay chan-id.wav

Use those tests to deterimine if this is an application specific behaviour or something else.

I am flying to Asia for just under 3 weeks tomorrow, and will likely have little to no internet. Plus I won’t have access to my 5.1 system when travelling. So after early afternoon tomorrow I likely will not be visiting the forum very much and when I do, I won’t be able to check ideas with my 5.1 system. Good luck with your efforts.

Wrt moving back to openSUSE-13.2 - my typical view is it is better to raise a bug report and work with the SuSE-GmbH openSUSE packagers (where one and maybe two of them are alsa sound driver developers for all of GNU/Linux) as opposed to rolling back a release. At least that way I benefit the community and I also get my system working with the latest openSUSE version. I am a firm believer that that approach makes openSUSE and indeed GNU/Linux stronger.

But that’s just me. Do here what is best for you, given your tolerance levels.

All the very best of luck with your efforts here.


I forgot to confirm … did you try pavucontrol like I suggested ?

Thanks for the information. I will try it tommorow, then I also will be off for a few days so I won’t have much time. I have tried Pavucontrol but I didn’t find out anything else. And I always had the same behaviour with all apps I was using (VLC, SMPlayer and Amarok), so that is the reason why I didn’t write what I am using because I thought that problem were somewhere else.

Hi, I am sorry for my late response. I didn’t have time to try it earlier. But I tried it now. When I do the test with the chan-id.wav and speaker-test then everything is working except bass speaker. Sound seems allright from the phones but the bass speaker is not working. It tries to sound some sounds when playing from other speakers but it is very weak sound and nothing special when testing LFE which should also play some test sound as in earlier versions of openSUSE.

I also tried uncommenting enable-lfe-remixing = yes in /etc/pulse/daemon.conf but it didn’t help.

I have no further suggestions. Sorry.

Should I try to report it is as bug then?

Thats a good idea. Do you need guidance how to do this ?

I should be able to make it. Thanks