I was having trouble with my sound being really choppy. I found a suggestion on this forum that said to try uninstalling Pulse Audio. So I tried this and it worked like a charm for playing my mp3s on Amarok, but it had the unfortunate side affect of disabling all sound in firefox (e.g. Youtube,, etc).

Is there a system setting somewhere that needs to be redirected to a different sound engine?


SDB:AudioTroubleshooting - openSUSE

The audio troubleshooting guide assumes one KEEPS their pulse audio. It provides some work arounds for choppy sound with Pulse Audio kept in place.