Sound: yes it works; no it doesn't; yes it does....

I’m following the SDB Audio Troubleshooting Guide to figure out why I don’t hear anything via Amarok on my newly built 11.1/KDE 4 system.

The SDB guide speaker test works fine. Step 1 in the guide also directs me to the ALSA-project website sound-card testing page. Their first test (playback) using aplay works fine - I hear CD quality sound from a WAV file I made years ago with Audacity/Windows.

But if I play this same file in Amarok I see the ‘histogram’ moving and notice the play-time changing, but hear nothing.

If I follow the SDB Guide Step 2 and try to test sound in Yast I hear nothing. If I delete the card and add it back in with YAST I hear nothing.

In fact I can to the end of the SDB guide and hear nothing, but aplay still works fine. I can’t see any channel muted in alsamixer. (for some reason I don’t seem to have Kmix on my system).

Can somebody suggest an explanation for the lack of sound in some applications, but excellent sound in aplay?

are you sure you don’t have kmix? It is installed by default. Hit ALT+F2 and type kmix in there

also which sound card do you have, give a bit more details please :wink:

you may also need to check the settings in KDE4 control center -> multimedia

Super !

Then your basic sound works.

This is likely either a codec issuse or its a amarok configuration issue, or an amarok packaging issue.

First off, I recommend you set up your software repositories with 4 and only 4 repos: OSS, Non-OSS, Update and Packman. There is guidance here: Repositories - openSUSE-Community Again, ONLY those 4. ONLY add others after you have advanced knowledge and fully aware how to identify problems from conflicts between other repositories, and also know how to resolve such problems. So for now, only OSS, Non-OSS, Update and Packman. Changes are the 1st 3 are already added and you only have to add packman.

Now note you can tell packman packaged apps by the “pm” in their version number.

So then go to YaST > Software > Software Management and change the “filter” to “search” and search for and install the Packman packaged versions (NOT the Novell packaged versions) of amarok, amarok-xine, amarok-packman, libxine1, xine-ui. Then close YaST. Start amarok. Change the sound engine to “xine” and try again.

I’m not off to a good start - having breached your guidance to have only those 4 repositories to strat with…

Which Packman url should I use? I have one at and one at - or is one a mirror of the other? Which is the master (if any)? I have the impression ( supported by a long track record of no facts whatsoever) that these two repositories are not identical).

Is it OK to merely disable the other repositories which I have added - rather than deleting them?

For reasons which I don’t understand, the install DVD (which I burned from the download image of OS 11.1) is alo in my list of repositories. I have now deleted this - with the reasoning that the packages/code on that DVD will progressively fall behind that which is to be found in the on-line repositories. Is that reasoning correct?

Those should be both mirrors of the official packman PackMan :: home

As for correct in regards to newer than disk no that isn’t true afaik there has been very few instances of the disk being remastered so it will generally be the same as OSS/Non-Oss. If you have download limits then it can be beneficial to use the CD/DVD, but if the CD then it will not be as complete as OSS. It is also highly likely you’ll have OSS as a repo not to mention the pain of making sure the disk is in the draw. So IMO unless download limits it isn’t really worth keeping it, though it can be useful for repair by using it as the only source.

You can just disable it but I think many have repos with no reason and beyond adding to the few Oldcpu recommended with a few like wireless specific, graphics card(I could never be bothered with all that manual stuff after a kernel upgrade when IMO the repo works fine I don’t care for the latest) and perhaps webcam. I question why people have the need disabled or enabled for them?

42 of course if kde is your taste, as for gnome…

the main concern I would have here, is other than libdvdcss, did you install any multimedia apps/codecs from videolan respository? If you did, IMHO you need to replace them packages packaged by Packman packagers on the Packman repositories. The reason being Videolan packagers do not put their codecs in the same places as Packman Packages, and hence their multimedia applications tend to not to function well with each other.

Both are good repositories. Their content should beh the same. Since I use Smart Software package manager (instead of Zypper) I’m able to enter both repositories (a nice feature of Smart), where if one does not download, the other will. I do not know how to do that in zypper. But I do not think you can go wrong by selecting either with zypper/yast.

Yes, disable is ok.

Sort of correct, but not precise.

The installation DVD should be identical to the content of OSS repository. Hence either deleting or disabling the installation DVD is good. If you leave the installation DVD enabled, it will keep prompting you to insert the DVD in a difficult to dicipher request, which will become an annoyance after a while.

Yes, the Alt-F2 apptroach works and kmix is there. Thanks.

The sound card is an old Creative Labs PCI 4.1 Channel card, using the Ensoniq ES1371 codec. It is listed as Ensoniq AudioPCI.

Actually this raises aquestion: I have on-board AC’97 capability on the ASUS A8V motherboard. I have disabled this in BIOS, but OS still sees and lists a VIA8237 codec (which is what supplied the on-board sound, I suppose). Why is this device identified?

I kind of doubt I’m wrong… it’s always a possibility… but does he really need codecs to play a wav file? I mean, seriously?

Okay, I’m suspecting that you have both sound devices enabled. The reason you hear sound in aplay is that it’s using the right device - the one your speakers are attached to. However, the others might think they’re supposed to use the other one.

Wait… you did say you tested it in yast, and you probably made sure you checked the right one. And it seemed from the way you talked about it that you only saw one listed in the sound configuration.

Still, it’s simple to check. Just plug your speakers into the onboard sound outlet and see if you hear sound with amarok then. It’s worth a try. If that’s what it is, then the reason you check the mixer and see nothing muted is that the mixer is listing the card. Most mixers allow you to switch between sound devices.

So anyway, if I was right, I would suggest going into the BIOS (if you’re comfortable with that) and disabling the onboard sound.

If this helps at all, I’ll be surprised.

edit Oops… just noticed the last thing you said in that post. Disregard, please. I haven’t slept in over a day and a half.

! step forward, 2 back. The title of this thread should now read “Sound: no it doesn’t”

I’ve changed the sound engine to Xine and selected ALSA as the output plug-in.

There is no sound, but the histogram shows the wav file is being read. This file is in a directory that I created because I could not find out how to connect Amarok to the wav file on my CD. Xine has an Audio CD configuration panel which lists the default device as /dev/cdrom - but I don’t think this is my optical device, which is a SATA device - but I do not know what its correct device name is.

Speaker test no longer works.

Aplay no longer works.

Amarok seems to be the KDE3 version, even though I downloaded it from the Packman repository.

I have not knowingly installed any multimedia packages or codecs from the videolan repo. because that is not in my list of configured repos.

Please note that OS has detected the on-board AC’97 capability on my ASUS A8V motherboard even though it is disabled in BIOS. Could it be that Amarok is trying to play through this disabled device?

If you want the KDE4 version of amarok instead of the KDE3 version, don’t download it from packman. In the old version, amarok had its own builtin way of handling different codecs, which is why packman has a different version. The newer version uses… um… whatsitcalled… Anyway, for that, you need to download the xine on packman. It’s named differently from the default one. Choose all of those packman xine packages except for the debug and it should be good. Though that’s not the problem with your sound right now.

A little more information:

Having deleted both sound configurations in Yast (SB card and on-baord sound) and then only edited the configuration for the Creative ES1371 card, I find that the speaker test now works, but aplay still does not, with an error message that I do not understand:

aplay -vv ‘Track 05.wav’
ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused

aplay: main:590: audio open error: Connection refused

Is this info. pointing to a potential reason for no-sound from Amarok?

I think it’s like I suggested at first - aplay is trying to use the onboard sound (even though it’s not configured) while everything else does. Have you tried amarok yet with the new settings?

My apologies for asking a basic question ,… but could you please show us the output of your mixer?

amixer > amixer.txt

open amixer.txt with a text editor, and the paste that on a paste bin site such as pastebin - Type, paste, share.
and then post here the URL you are provided.

I haven’t posted the output to pastebin, because the text file is empty; here’s the terminal dialog:

LINEAR-1:/home/tony/scratch # amixer > amixerout.txt
ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused

amixer: Mixer attach default error: Connection refused

So, amixer cannot seem to operate.

That should not be. Do you get the same if you run it with root permissions?

OK, some progress: I’ve reconfigured Amarok/KDE3 to use the xine engine with ‘autodetect’ set for the output plug-in. Now I can play a test wav file. I cannot hear any output if I use ‘alsa’ as the output plug-in and I get an error message (“xine was unable to initialize any audio drivers”) if I try to use pulse audio. This suggests to me that there is a problem with pulse audio.

I found a similar situation about a year ago when attempting to get sound to work in Audacity in my first install of OS (10.3). I think it took about 6 weeks to solve the problem then and it finally worked only when I disabled every use of pulseaudio by any application.

Should I remove pulseaudio again?

BUT… somethings are still not quite right:

  • the ‘test’ function within Yast->Hardware->Sound does not produce any output with or without PulseAudio enabled

  • aplay cannot be used - with error message previously shown

  • amixer and alsamixer similarly cannot be used - giving a similar error message about pulseaudio connection refused.

Yes, I am sunning as root for that test

Can you provide the output of running the following diagnostic script twice? The first time as root (selecting YES to update the script) and the second time as a regular user (posting here the resultant URL AFTER the script finishes):
/usr/sbin/alsa-info.shJust post here the resultant URL (from the 2nd time you run it). Nothing else.

And also provide here the output of running:
rpm -qa | grep alsa
rpm -qa | grep pulse
uname -a
cat /etc/modprobe.d/sound
That might give me a hint as to what is wrong.

And also provide here the output of running:
rpm -qa | grep alsa


rpm -qa | grep pulse


uname -a

Linux LINEAR-1 #1 SMP 2009-05-26 17:02:05 -0400 i686 athlon i386 GNU/Linux

cat /etc/modprobe.d/sound

options snd slots=snd-ens1371

qnJ_.G7IF1hXn700:Sound Blaster 16PCI 4.1ch

alias snd-card-0 snd-ens1371

Ok, I noted 1.0.20 driver and 1.0.18 utilities. You could try updating your utilities to see if that helps (commands below). I also note an out from amixer. So amixer does work !! It has me puzzled why you noted it did not work for you when you ran it directly.

The structure of the repositories for rpms for updates to alsa has recently been changed, and I do NOT yet have a good handle on it.

Lets try an update. Please run the following six commands with root permissions:

zypper ar multimedia
zypper install alsa alsa-docs libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

Then restart your PC and test your sound.

If that does not work, there is now a daily snapshot repos we can try instead.