Sound works for videos and music but not for anything else..

Hello,

I have finally managed to figure out how to get sound on my Acer 5920G, but it seems that it only works when I play music, videos, or watching stream videos on the internet. I am a noob in using linux and I have tried a lot of things and can’t think of how I can make it so that the os sounds would also work.

Edit Actually I got no controll over sound, it plays and all that as stated above but I can’t turn down the sound unless it’s through the program itself, my laptop volume control doesn’t seem to be working either…

Edit 2 Now all of a sudden my speakers keep crackling and it’s quite anoying I then have to turn off my sound altogether :frowning:

How familiar are you with Linix? Did you try adjusting your audio mixer?

What openSUSE version are you using? What desktop? (ie KDE-4.0.4 ? KDE-4.1.3 ? KDE-3.5.9 ? KDE-3.5.10 ? some Gnome version) ?

Also, more information than that is needed if you wish help. To provide more information, with your PC connected to the internet copy and paste the following into a gnome-terminal or konsole:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh 

When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal or konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

I am a real noob using linux, but I don’t want to go back to windows and I really like openSUSE. Atm I’m using the GNOME desktop though I have kde4 and kd3 installed aswell which I do not use often.

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh 

Here is my url for that code:http://www.alsa-project.org/db/?f=f3cac38d75ef8470396b7c3b830a08cda3137abd

Here’s the information on rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound[/QUOTE]

user@user:~> rpm -qa | grep alsa
FA_clalsadrv-1.2.2-0.pm.3
alsamodular-debugsource-1.8.7-0.pm.2
tsalsa-20080914-0.pm.1
alsa-tools-gui-1.0.16-47.1
alsa-plugins-samplerate-1.0.16-57.1
alsa-docs-1.0.16-39.1
alsa-tools-devel-1.0.16-47.1
alsa-oss-1.0.15-48.1
alsa-devel-1.0.16-39.1
alsa-plugins-pulse-1.0.16-57.1
kalsatools-1.5.0-544.1
alsa-firmware-1.0.16-24.1
gmerlin-alsamixer-0.3.8-0.pm.1
alsamixergui-0.9.0rc1-705.1
java-1_6_0-sun-alsa-1.6.0.u10-2.1
alsa-plugins-maemo-1.0.16-57.1
gmerlin-alsa-0.3.8-0.pm.1
alsaplayer-0.99.80-1.pm.1
alsa-patch-bay-debugsource-1.0.0-0.pm.2
alsa-utils-1.0.16-35.1
alsamodular-1.8.7-0.pm.2
alsa-1.0.16-39.1
alsa-plugins-jack-1.0.16-57.1
alsamodular-debuginfo-1.8.7-0.pm.2
tritonus-alsa-0.3.7-1.pm.cvs20080107
alsa-tools-1.0.16-47.1
alsa-plugins-1.0.16-57.1
alsa-patch-bay-debuginfo-1.0.0-0.pm.2
alsa-patch-bay-1.0.0-0.pm.2
user@user:~> rpm -qa | grep pulse
pulseaudio-module-lirc-0.9.11-27.1
libpulse0-0.9.11-27.1
gstreamer-0_10-pulse-0.9.7-42.pm.1
pulseaudio-esound-compat-0.9.11-27.1
alsa-plugins-pulse-1.0.16-57.1
libpulsecore4-0.9.11-27.1
pulseaudio-module-gconf-0.9.11-27.1
libpulse-browse0-0.9.11-27.1
pulseaudio-module-bluetooth-0.9.11-27.1
pulseaudio-module-x11-0.9.11-27.1
libpulse-mainloop-glib0-0.9.11-27.1
audacious-plugins-output-pulse-1.5.1-0.pm.9
pulseaudio-module-zeroconf-0.9.11-27.1
pulseaudio-utils-0.9.11-27.1
pulseaudio-0.9.11-27.1
gmerlin-pulseaudio-0.3.8-0.pm.1
user@user:~> rpm -q libasound2
libasound2-1.0.16-39.1
user@user:~> uname -a
Linux linux-o7v5 2.6.25.18-0.2-pae #1 SMP 2008-10-21 16:30:26 +0200 i686 i686 i386 GNU/Linux
user@user:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel
# u1Nb.6t3NVH6gP_8:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

I do not use Gnome. Its quite possible you have a problem with your Gnome mixer, in which case I can not help.

Thanks for that. I see you have an ALC888 and 1.0.16 of alsa.

Searching for the alc888 on the alsa project web site I get this: Search results for 1.0.16 - AlsaProject
which indicates there are a number of updates to alsa available since 1.0.16 of alsa.

But before jumping to recommend an update, I also note that you have WAY TOO MANY pulse and alsa apps installed. Surely those were not installed by default ?

Linux is not like Windows. In general, in Linux, installing extra apps is not a good idea, especially if one does not know what one is doing. AND if one decides to go ahead anyway and install extra apps, it is good idea to make note of what one installed, so one can remove it later if it does no good. I have no idea why you installed the various apps, nor what is needed for what, so I can not help you clean that app. But its messy. Very messy. And that can lead to problems.

Anway, it is possible you “might” be able to clear up your problem by assigning a model option that will be recognized by your 1.0.16 alsa version driver. I noted this for the ALSA-Configuration.txt file for 1.0.16 of alsa for the ALC888 (which you have on your PC):

	ALC883/888
	  3stack-dig	3-jack with SPDIF I/O
	  6stack-dig	6-jack digital with SPDIF I/O
	  3stack-6ch    3-jack 6-channel
	  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
	  6stack-dig-demo  6-jack digital for Intel demo board
	  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
	  acer-aspire	Acer Aspire 9810
	  medion	Medion Laptops
	  medion-md2	Medion MD2
	  targa-dig	Targa/MSI
	  targa-2ch-dig	Targs/MSI with 2-channel
	  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
	  lenovo-101e	Lenovo 101E
	  lenovo-nb0763	Lenovo NB0763
	  lenovo-ms7195-dig Lenovo MS7195
	  haier-w66	Haier W66
	  6stack-hp	HP machines with 6stack (Nettle boards)
	  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
	  6stack-dell	Dell machines with 6stack (Inspiron 530)
	  mitac		Mitac 8252D
	  auto		auto-config reading BIOS (default) 

So for your acer5920G, you could try to edit your /etc/modprobe.d/sound file, and add an extra line at the end and change it to:

options snd slots=snd-hda-intel
# u1Nb.6t3NVH6gP_8:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=acer 

and the restart your alsa sound driver with: su -c ‘rcalsasound restart’ and enter root password when prompted. Then start your mixer again and check your ability to control your sound volume.

If that does not work, you could try acer-aspire instead. Restart alsa … test … etc … or try any one of the many other models until you find one that works.

Failing that, you could try to update your alsa, and if you get to that stage, let me know and I can point you to a guide on installing some already compiled rpms of the latest alsa version (for openSUSE).

I believe it to be the GNOME mixer because oddly enough I went on kde4 and sound works perfect if not better then windows. I also tried kde3 and it works on there too… I’m starting to like KDE a lot better now anyways, I’ll just continue using KDE instead of GNOME for now. Thanks a lot for your help as that helped because I have sound in KDE now :smiley: And from now on I’ll be more careful with packages and not excessively install what I think is important lol.

Thanks again.