Sound won't work, need help.

Hello, I’m new to opensuse and linux all together, I’ve been useing it for a few week’s now, but I restarted my computer today and now youtube and such won’t work, I still get the start up sound’s.
Please help me figure this out.

I would like to help.

Note when asking for help, it is useful to mention what openSUSE version you are using? What desktop are you using? What browser are you unsuccesfully using to try play youtube? And advise if sound works in any other application and if it is ONLY startup and youtube that don’t work for you.

I know that is ALL intuitively obvious to you , but with us not being in front of your PC it is not obvious to us.

If sound works everywhere but startup and youtube under firefox, then its possible to fix the youtube problem you may need to remove libflashsupport rpm (but keep flash-player). But given the lack of information provided that is a very wild, speculative and uninformed guess.

If your sound works no where, then more information is needed. In which case please provide the information recommended to be given, from the 2nd half of our multimedia stickie: Welcome to multimedia sub-area - openSUSE Forums

Do you have Flash Player installed? You have to add the None OSS repository in order to install flash player.
Yast - Software Repositories - Add - Community Repository - None OSS.
After that you can use Software Manager to search for flash-player and install it. Also search for Pulseaudio and uninstall it. It will suggest unintalling some other pulse packages, which you should accept. I guess it’s what fcuking up your sound.
Everything should work after that;)

I’m usenig opensuse 11.2, it’s the KDE desktop, and sound work’s when I turn it on, I get the start up noise, but if I try to watch youtube or listen to something in amarok it doesn’t work, I still get the video with youtube though.
The I’m useing Opera web browser,but it doesn’t work in firefox either.
I have flash player installed, it was working before.

You may need to remove libflashsupport rpm (but keep flash-player).

What is the output of:

rpm -qa '*flash*'

Please ensure you go to your Mixer and move UP the PCM volume.

Thank you for the help, my sound is working now.

It would be nice to share the solution. What was the problem? What did you do to make it work?