Sound wont configure?

http://img81.imageshack.us/img81/2903/44035284.png](http://www.imagehosting.com/)

My sound was-int working with vlc.
went to my sound config and it not even configuring?

I’m using openSUSE 11.1
KDE 4.1

/usr/sbin/alsaconf run it as root

Still no? /usr/sbin/alsa-info.sh and post the url it spits out at the end.

The first one was


No legacy drivers are available

\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\

So…

!!################################
!!ALSA Information Script v 0.4.56
!!################################

!!Script ran on: Wed Jun 10 08:09:37 UTC 2009

!!Linux Distribution
!!------------------

Welcome to openSUSE 11.1 - Kernel \r (\l). openSUSE 11.1 (i586) LSB_VERSION=“core-2.0-noarch:core-3.2-noarch:core-2.0-ia32:core-3.2-ia32”

!!DMI Information
!!---------------

Manufacturer: MICRO-STAR INTERNATIONAL CO.,LTD
Product Name: MS-7501

!!Kernel Information
!!------------------

Kernel release: 2.6.27.21-0.1-pae
Operating System: GNU/Linux
Architecture: i686
Processor: athlon
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version:
Library version:
Utilities version: 1.0.18

!!Loaded ALSA modules
!!-------------------

!!Sound Servers on this system
!!----------------------------

Pulseaudio:
Installed - Yes (/usr/bin/pulseaudio)
Running - No

ESound Daemon:
Installed - Yes (/usr/bin/esd)
Running - No

!!Soundcards recognised by ALSA
!!-----------------------------

!!PCI Soundcards installed in the system
!!--------------------------------------

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)

!!Advanced information - PCI Vendor/Device/Susbsystem ID’s
!!--------------------------------------------------------

00:14.2 0403: 1002:4383
Subsystem: 1462:7501

!!Modprobe options (Sound related)
!!--------------------------------

snd-hda-intel: single_cmd=1

!!Loaded sound module options
!!--------------------------

!!ALSA Device nodes
!!-----------------

!!Aplay/Arecord output
!!------------

APLAY

aplay: device_list:217: no soundcards found…

ARECORD

arecord: device_list:217: no soundcards found…

!!Amixer output
!!-------------

!!Alsactl output
!!-------------

–startcollapse–
–endcollapse–

!!All Loaded Modules
!!------------------

Module
nls_iso8859_1
nls_cp437
vfat
fat
ip6t_LOG
xt_tcpudp
xt_pkttype
ipt_LOG
xt_limit
xt_physdev
ppdev
vmnet
parport_pc
parport
vmblock
vmci
vmmon
vboxdrv
af_packet
bridge
stp
ip6t_REJECT
nf_conntrack_ipv6
ip6table_raw
xt_NOTRACK
ipt_REJECT
xt_state
iptable_raw
iptable_filter
ip6table_mangle
nf_conntrack_netbios_ns
nf_conntrack_ipv4
nf_conntrack
ip_tables
ip6table_filter
ip6_tables
x_tables
ipv6
binfmt_misc
fuse
loop
nvidia
usb_storage
r8169
i2c_piix4
ohci1394
soundcore
rtc_cmos
agpgart
mii
pcspkr
k8temp
rtc_core
ieee1394
serio_raw
sr_mod
button
rtc_lib
cdrom
i2c_core
sg
usbhid
hid
ff_memless
ohci_hcd
ehci_hcd
usbcore
sd_mod
crc_t10dif
dm_snapshot
dm_mod
edd
ext3
mbcache
jbd
fan
ide_pci_generic
atiixp
ide_core
ata_generic
ahci
pata_atiixp
libata
scsi_mod
dock
thermal
processor
thermal_sys
hwmon

Did your sound ever work?

Clearly your sound driver is not loading and you have no sound cards found.

What is the output of typing the following:
rpm -qa | grep alsa
rpm -qa | grep pulse
uname -a
cat /etc/modprobe.d/sound

It did work. I went to the YaST sound config
and clicked test. there was no sound ?

No i try and fail to fix it and now noo sound words :frowning:


Output

linux-lnon:/home/Gizmo # rpm -qa | grep alsa

alsa-oss-1.0.17-1.37
alsa-utils-1.0.18-6.4
alsa-1.0.18-8.7
alsa-plugins-1.0.18-6.12
alsa-plugins-pulse-1.0.18-6.12
linux-lnon:/home/Gizmo # rpm -qa | grep pulse
libpulse0-0.9.14-2.2.1
pulseaudio-0.9.14-2.2.1
pulseaudio-module-x11-0.9.14-2.2.1
pulseaudio-module-zeroconf-0.9.14-2.2.1
libpulse-browse0-0.9.14-2.2.1
pulseaudio-module-jack-0.9.14-2.2.1
pulseaudio-module-bluetooth-0.9.14-2.2.1
pulseaudio-esound-compat-0.9.14-2.2.1
pulseaudio-lang-0.9.14-2.2.1
libxine1-pulse-1.1.15-23.3.3
alsa-plugins-pulse-1.0.18-6.12
pulseaudio-module-lirc-0.9.14-2.2.1
libpulse-mainloop-glib0-0.9.14-2.2.1
pulseaudio-utils-0.9.14-2.2.1
linux-lnon:/home/Gizmo # uname -a
Linux linux-lnon 2.6.27.21-0.1-pae #1 SMP 2009-03-31 14:50:44 +0200 i686 athlon i386 GNU/Linux
linux-lnon:/home/Gizmo # cat /etc/modprobe.d/sound

options snd-hda-intel single_cmd=1

5Dex.F7XeoXe1Bu9:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel
linux-lnon:/home/Gizmo #

The sound test in YaST is buggy and it does not work for many sound cards.

A better test for sound, are the 3 tests here (2 speaker-tests and one test on the alsa web site): SDB:AudioTroubleshooting - openSUSE - how to test your sound … note it is very common for only one of those tests to work.

Why do you have the line: “options snd-hda-intel single_cmd=1” in your /etc/modprobe.d/sound file? What happens if you remove that line and reboot ?

What happens if you run (with root permissions) “alsaconf” to configure your sound device?

You could also try installing “alsa-firmware” to see if installation of that helps (you need to reboot after installing that).

Ok I changed it.

Gizmo@linux-lnon:~> rpm -qa | grep alsa

alsa-oss-1.0.17-1.37
alsa-utils-1.0.18-6.4
alsa-1.0.18-8.7
alsa-plugins-1.0.18-6.12
alsa-plugins-pulse-1.0.18-6.12
Gizmo@linux-lnon:~> rpm -qa | grep pulse
libpulse0-0.9.14-2.2.1
pulseaudio-0.9.14-2.2.1
pulseaudio-module-x11-0.9.14-2.2.1
pulseaudio-module-zeroconf-0.9.14-2.2.1
libpulse-browse0-0.9.14-2.2.1
pulseaudio-module-jack-0.9.14-2.2.1
pulseaudio-module-bluetooth-0.9.14-2.2.1
pulseaudio-esound-compat-0.9.14-2.2.1
pulseaudio-lang-0.9.14-2.2.1
libxine1-pulse-1.1.15-23.3.3
alsa-plugins-pulse-1.0.18-6.12
pulseaudio-module-lirc-0.9.14-2.2.1
libpulse-mainloop-glib0-0.9.14-2.2.1
pulseaudio-utils-0.9.14-2.2.1
Gizmo@linux-lnon:~> uname -a
Linux linux-lnon 2.6.27.23-0.1-pae #1 SMP 2009-05-26 17:02:05 -0400 i686 athlon i386GNU/Linux
Gizmo@linux-lnon:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

5Dex.F7XeoXe1Bu9:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel
Gizmo@linux-lnon:~>

When i boot up the start up sound plays.

But then nothing els after that :confused:

Ok, then this could be a mere codec and multimedia issue. Please read this post #4: sound problems - setting up your multimedia

Follow the advise there, and if you have still problems, please post here.

OK i just ran (with root permissions) “alsaconf”
and My sound working again XD. And my VLC sound works.

Thanks m8 You’re help a lot :slight_smile: