Sound VT1708 codec problem

I am having problems helping a friend with a VT1708 sound card.

I’ve been reading this thread which seemed to have a similar problem. However I’ve followed all the steps and keep experiencing a weird behavior.

The problem is that when the sound system is restarted via

rcalsa restart

it sometimes recognises the sound card right and sounds the different audio channels in kmix, but most of the times it shows wrong channels (only 3 of them with names such as Digout and so on), when the system is working right it shows “HDA VIA VT82XX” in Kmix, when not working it shows “VT1708”.

The workaround at this moment is restarting the sound system until it is recognised succesfully. However, obviously, this is not a real solution.

I have run alsa-info.sh and the result is posted here. This was execute while the sound system is working.

Hope someone can help with this issue. Thanks in advance

I note from the script that you have a mismatch between your alsa drivers and your alsa utilities. This may be part of the problem:

Driver version:     1.0.16rc2
Library version:    
Utilities version:  1.0.18rc2 

It looks like you tried to update the alsa driver and were only partially successful. Note the driver is KERNEL SPECIFIC and you must select the driver that is specific to your kernel version.

This kernel specificity is a Linux characteristic that frustrates many, and it something that one should be aware of when trying to update drivers.

Can you provide the output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

If you updated via a custom compile, please advise.

Also, I am “on the road” travelling, and my replies may be days apart. Good luck.

Hi oldcpu,

this is the output you are asking for:

Pocha:~ # rpm -qa | grep alsa
alsa-plugins-jack-1.0.17.git20080927-1.5
alsa-utils-1.0.17.git20080820-1.1
alsa-oss-1.0.17.git20080715-2.12
alsa-firmware-1.0.17.git20080617-2.1
alsa-tools-1.0.17.git20080715-1.10
alsa-plugins-pulse-1.0.17.git20080927-1.5
alsa-plugins-1.0.17.git20080927-1.5
alsa-1.0.17.git20081008-1.1
Pocha:~ # rpm -qa | grep pulse
libpulse0-0.9.11-2.10
libpulsecore4-0.9.11-2.10
libpulse0-32bit-0.9.11-2.10
alsa-plugins-pulse-1.0.17.git20080927-1.5
pulseaudio-0.9.11-2.10
Pocha:~ # rpm -q libasound2
libasound2-1.0.17.git20081008-1.1
Pocha:~ # uname -a
Linux Pocha 2.6.25.16-0.1-default #1 SMP 2008-08-21 00:34:25 +0200 x86_64 x86_64 x86_64 GNU/Linux
Pocha:~ # cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel enable=yes index=0 model=8stack

I’ve tried different values for de “model” value in /etc/modprobe.d/sound and this seems to be the one working.

I installed the packages from Yast, after adding this repository:

Index of /repositories/multimedia:/audio/openSUSE_11.0

I wasn’t aware about the kernel specifity of the driver version. Where can I find which driver version is suitable for the Kernel 2.6.25.16-0.1-default?

Please, do tell me if you need more info.
Thanks for your help,

which one? Do you mean model=8stack?

The script conforms your PC has a VT1708, but when I check the ALSA-Configuration.txt file for various versions of alsa (1.0.16, 1.0.17, 1.0.18RC3) I see no mention of a VT1708, nor does any hardware audio codec use “8stack”. Hence I am surprised that works for you, as from what I can see from research, there is no such model definition for a hardware audio codec.

Searching the alsa site, I do see there is support for the vt1708 Search results for vt1708 - AlsaProject but I can find no reference to a model = 8stack.

OK, that repos has most of the alsa apps you need, but not all.

This is true for many devices and not just audio. Many times users will find an update to the kernel “may” break the functionality of their graphic device, or their webcam, or their wireless, or in this example, their audio. Not always. But often.

In this case, you have installed custom rpms from a repos where you should also install a kernel specific driver. My reference for this is here:
Alsa-update - openSUSE

and you need to install “alsa-driver-kmp-default” from the repos:

http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.0_Update/ 

then reboot afterward and test your audio.

I think you may need to remove the line with “8stack” in the /etc/modprobe.d/sound file (unless you have found a reference otherwise to show that I am not up to date here).