Sound volume is far too low Sony Vaio VGN-G11XN

Hi,

Just installed a new copy of openSuse in my Sony Vaio VGN-G11XN and all seems too work nicely!

However the sound is still far too low, I’ve check all the sliders and they are all set up to the max hbut that doesn’t seem to be enough as I need to put my ear next to the speaker to be able to hear.

My sound card is a 82801G Intel High Definition Audio ICH7 family, Does anyone have any suggestions?

For testing your audio, I recommend you copy and paste the following into a gnome-terminal / konsole:
speaker-test -Dplug:front -c2 -l5 -twav

The obvious check is to go to YAST > Hardware > Sound > Other > Volume and ensure that slider bar is far to the right (80% or so).

Failing that, can you provide some more information. …

Please, with your PC connected to the internet copy and paste the following into a gnome-terminal / konsole:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal/konsole and post the output here.
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Thanks oldcpu,

Yes, I double-checked again that all the sliders are qt 100% and they are, so following your instructions here are the relevant outcomes:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c ‘bash ./tsalsa’

tsalsa.txt - nopaste.com (beta)

rpm -qa | grep alsa

alsa-firmware-1.0.16-24.1
alsa-oss-1.0.15-48.1
alsa-utils-1.0.16-35.1
alsa-plugins-1.0.16-57.1
alsa-1.0.16-39.1

rpm -qa | grep pulse

Nothing gets output here

rpm -q libasound2

libasound2-1.0.16-39.1

uname -a

Linux linux-eoc2 2.6.25.11-0.1-default #1 SMP 2008-07-13 20:48:28 +0200 i686i686 i386 GNU/Linux

cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.1vrQ9SsoBKE:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

I appreciate you are helping me with this, Thanks a lot! any advice would be welcome.

OK, thanks for that. That indicates you have a Sonia VGN-G11XN, running a 32-bit openSUSE-11.0 with the 2.6.25.11 default kernel with 1.0.16 of alsa. Hardware codec is an ALC262 on IRQ19.

I checked the mixer settings. Nothing really obvious strikes me as being wrong from that.

I note from the ALSA-Configuration.txt file, that came with the alsa 1.0.16 tarball the following for the ALC262:

	ALC262
	  fujitsu	Fujitsu Laptop
	  hp-bpc	HP xw4400/6400/8400/9400 laptops
	  hp-bpc-d7000	HP BPC D7000
	  hp-tc-t5735	HP Thin Client T5735
	  hp-rp5700	HP RP5700
	  benq		Benq ED8
	  benq-t31	Benq T31
	  hippo		Hippo (ATI) with jack detection, Sony UX-90s
	  hippo_1	Hippo (Benq) with jack detection
	  sony-assamd	Sony ASSAMD
	  ultra		Samsung Q1 Ultra Vista model
	  basic		fixed pin assignment w/o SPDIF
	  auto		auto-config reading BIOS (default) 

And I note your /etc/modprobe.d/sound file:

You could try some entries in your /etc/modprobe.d/sound file, to see if it makes a difference. ie try change the file to:

options snd slots=snd-hda-intel
options snd-hda-intel model=auto
# u1Nb.1vrQ9SsoBKE:82801G (ICH7 Family) High Definition Audio Controller
alias snd-card-0 snd-hda-intel 

Then restart alsa with rcalsasound restart and test your volume. Note once you hand edit your /etc/modprobe.d/sound file, do NOT go into YaST > Hardware > Sound, nor run alsaconf, as those will wipe your /etc/modprobe.d/sound custom settings

If “auto” does not work, then try one of the other parameters from the ALSA-Configuration.txt file for your ALC262, … ie try fujitsu, hp-bpc, hp-bpc-d7000, hp-tc-t5735, hp-rp5700, benq, benq-t31, hippo, hippo_1, sony-assamd, ultra, basic, … restarting your alsa after each change with rcalsasound restart and test your volume.

I also searched the alsa web site for a possible alsa update for the alc262. I obtained this: Search results fro ALC262 - AlsaProject

… which does not obviously indicated a “volume fix” for the alc262, although there are some alc262 updates. Hence you could try updating your alsa to 1.0.17. To do such an update, open a gnome-terminal / konsole (with your PC connected to the internet) and type ‘su’ (no quotes) to get root password (enter root password when prompted) then copy and paste the following in sequence, executing one at a time:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/ multimedia
 zypper install alsa alsa-utils alsa-oss alsa-plugins alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.0_Update/ multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

then restart your PC to unload the old alsa modules and reload the new.

Then test your volume again, going thru all the tests/steps in all the posts above (including this one). I also note the 1.0.17 ALSA-Configuration.txt has an additional module for the ALC262 (for the Leonovo):

	  lenovo-3000	Lenovo 3000 y410 

which likely is not relevant to you, although you could also try that “lenovo-3000” model in your /etc/modprobe.d/sound after retrying all the other models with 1.0.17 of alsa.

Good luck.

Don’t forget the obvious, which is to look for a hardware dial volume adjustment on the chassis of the laptop. Many laptops have such a volume control.

Hi oldcpu,

Thanks for a thorough description on what I have to do, I tried changing the sound file but when I type ¨rcalsasound restart¨ in the terminal I get a ¨command not found¨ message.

Equally I tried to update the Alsa modules but nothing seems to change and again when I do a ¨rcalsasound restart¨ the same happens again, (I copied and pasted literally as you wrote it).


Don’t forget the obvious, which is to look for a hardware dial volume adjustment on the chassis of the laptop. Many laptops have such a volume control.

Yep, I check this and I don´t actually have a volume control in the laptop, in fact I am running Windows in another partitions and the sound works good there.

< sigh > this is rather fundamental. But its my fault for misjudging your level.

When you are reloading a kernel module, this is serious business in an os, and you do not want any old user being able to do this.

Hence one must use administrator (ie root) permissions.

So either type “su” first (and enter root password), or simply type:
su -c 'rcalsasound restart’

Apologies I did not mention this, but I find this so basic/fundamental, it never occurred to me you would miss this … alas … sometimes the gap between users can be very hard to bridge and it can be difficult going both ways to communicate properly … and in this case it is my communications failing.

Hi oldcpu,

Thanks for all the guidance and apologies for taking so long to come back to you on this but had the Internet connection down at home and couldn´t try anything until yesterday.

I have gone through all the steps you suggested; added the line to specify the model to the sound file and tried all the models on the Alsa configuration file restarting the Alsa module each time and then downloaded the new Alsa drivers following exactly the same order you advised but nothing have really changed at all.

Did noticed though that when using model=auto there is sound but is still too low even when the sliders are all set to the maximum and when I try the rest of the models there is no sound at all? Maybe this is telling us a clue on where the problem live?

Regarding using SU privileges, thanks for that! I do know some basics on Linux but yes you guessed it I am more on the ńewbe side to be honest, although had about four months experience using Ubuntu before and the way you become root was slightly different.

Thanks

This might be promising. Can you try that model=auto again in your /etc/modprobe.d/sound as noted above (don’t forget to restart alsa with su -c rcalsasound restart ) ? And then go into your mixer and adjust your mixer settings? If no success, then with the model=auto try running the diagnostic script again (with your laptop connected to the internet):

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa' 

enter root password when prompted for a password, and when upon completion it gives you a URL please post that here.

That will give me a good summary of your mixer settings and I can do a functionality/quality check on that.

… also, as a quality check against what you installed, could you copy and paste the following into a gnome-terminal / konsole, execute the line(s), and post here the output.
rpm -qa | grep alsa
rpm -q libasound2

Also, out of curiosity, also try these tests with a headset pluged in one of your audio jacks, … does that have sound?

Thank you for this info. It fixed my problem. I looked and looked and I didn’t see this before.

btw I have an ASUS F8 laptop, if anyone cares or runs into the same problem.

hi, I have a Sony vaio vgn-c2s, the audio is too low, all the levels of the volume is in 100% and yet its not even 50% of what a campaq laptop audio can do, as if my laptop is whispering something. I hope you can help me with this

Another problem of mine is the audio recording issue of vaio vista, I have friends which is also a vista user but theirs have the recording features already, while i get stock in a build in mic, of the laptop

last thing is what is a YAST - HARDWARE - … i was trying to solve it myself but i dont know what is a yast

hope someone can help me, many thanks

Go to YaST > Hardware > Sound > Other > Volume and move the PCM and Master volume up to 95%. Close YaST. Then go to your mixer (kmix in kde or alsamixer in gnome) and move up both your Master and PCM volume high.

I do not understand what you are trying to say.

YaST ? You can read up on YaST here: Yet another Setup Tool - Wikipedia, the free encyclopedia

YaST stands for Yet another Setup Tool and it is a setup tool for openSUSE Linux that lets you configure all sorts of things. Look for it in your menu that you use to launch applications. It will be there, possibly called "Administrator Settings - YaST ".