Sound used to work, now it doesn't work at all

My sound used to work just fine. Now it doesn’t work at all. I’ve been through the SDB:AudioTroubleshooting guide as well as the SDB:Intel-HDA sound problems guide. No luck there.

When I run alsamixer, I get the following:

susestar:/home/jim # alsamixer
No mixer elems found

no volume control sliders are displayed.

I’ve collected all the command outputs:

susestar:/home/jim # rpm -qa | grep alsa

susestar:/home/jim # rpm -qa | grep pulse

susestar:/home/jim # rpm -q libasound2

susestar:/home/jim # uname -a
Linux susestar #1 SMP 2008-06-09 13:53:20 +0200 x86_64 x86_64 x86_64 GNU/Linux

susestar:/home/jim # cat /etc/modprobe.d/sound
options snd-hda-intel enable=1 index=0 model=3stack

The output of the script is here:

The output of the tsalsa script is here:
tsalsa.txt - (beta)

Any suggestions would be greatly appreciated.



In Yast - Hardware - Sound
what is happening in there?

I agree with caf4926.

Go into YaST > Hardware > Sound and try to configure your sound card. (That will remove any custom settings from /etc/modprobe.d/sound). If you can not here the test sound there, then close that, and run: su -c alsaconf

… and test your audio afterward.

Your sound cards are not being detected properly by alsa, and you need to determine why. I noted the tsalsa script had model=3stack in your /etc/modprobe.d/sound file, and the script had model=dell-3stack in the /etc/modprobe.d/sound file. Having a changing configuration when running those scripts, can make it difficult to understand what is happening on your PC.

This is clearly wrong. IMHO that inappropriate edit to an /etc/modprobe.d/sound file alone is enough to break your audio. You removed all the other lines that should be there.

Use the /etc/modprobe.d/sound file created by YaST, or by “alsconf” and add to the entries in that file with an appropriate edit. Don’t delete the previous/existing entries created by YaST or created by “alsaconf”.

I have a similar issue. Sound is working after-all, I can say this when I see the test sound playing ( I selected “open system” instead of “default” in sound -> hardware ). But real player and amarok play the files without any issue, but I don hear anything even if volume is set as max. No, I checked, I din mute the laptop nor the player. Please let me know.

Often, what is perceived by a user as a “similar” issue has a solution that is anything BUT similar.

So please, open a konsole or gnome-terminal and copy and paste the following into it and advise if it gives you any sound. speaker-test -Dplug:front -c2 -l5 -twavYou should hear a female voice saying “Left Front”, “Left Right” 5-times.

I did wat you told… I get the following as response but no one speaks anything :frowning:

arch@linux-rs11:~> speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.16

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 32 to 8192
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
0 - Front Left
1 - Front Right
Time per period = 2.746904
0 - Front Left
1 - Front Right
Time per period = 2.986843
0 - Front Left
1 - Front Right
Time per period = 2.986648
0 - Front Left
1 - Front Right
Time per period = 3.156888
0 - Front Left
1 - Front Right
Time per period = 2.901371

The speaker-test text output looks ok. This could be a mixer misconfiguration. Please provide more information by copy and pasting the following diagnostic script into a gnome-terminal or konsole with your PC connected to the internet:

wget && su -c 'bash ./tsalsa' 

and when prompted for a password enter your root password. Please try to accurately estimate the number of jacks/plug you have when asked (for example, I have 3 i/o sound jacks on my PC), and when the script is complete it will give you a URL. Please post that URL on this thread.

Also, in addition to the above, please copy and paste the following commands one line at a time into a gnome-terminal / konsole and paste here the output of these commands:rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound
Are you using gnome or kde? and if openSUSE-11, which kde version?

I am using KDE 3.5

O/p URL:

paste this url in #alsa: tsalsa.txt - (beta)

O/p of other commands:

arch@linux-rs11:~> rpm -qa | grep alsa
arch@linux-rs11:~> rpm -qa | grep pulse
arch@linux-rs11:~> rpm -q libasound2
arch@linux-rs11:~> uname -a
Linux linux-rs11 #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux
arch@linux-rs11:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.dMH6nFzhrH7:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

When I go to YaST-Hardware-Sound, I see that the sound card is there and I can configure it just as before when sound was working. Now, however, when I select the “Volume” pull down, there are no slider bars to be adjusted. There is only a button labeled “Test” and two sets of text: “Master Volume” and “Other Channels”

I’ve run alsaconf before. It doesn’t fix the problem. After running alsaconf, I run alsamixer and get the “no mixer elems found” error. As for the difference in the /etc/modprobe.d/sound files - that was a cut and paste error on my part. I lost track of which file I was recording all my results in and copied from the wrong file. The /etc/modprobe.d/sound file contains the “model=dell-3stack” option, not the “model=3stack” option.

Should I have a codec#0 file in the directory /proc/asound/card0?

There is a codec#1 file:

susestar:/proc/asound/card0 # more codec#1
Codec: Conexant ID 2c06
Address: 1
Vendor Id: 0x14f12c06
Subsystem Id: 0x14f1000f
Revision Id: 0x100000
Modem Function Group: 0x2

but the “Codec:” entry in that file doesn’t match the codec listed in the /usr/src/linux/Documentation/sound/alsa/ALSA-Configuration.txt file for the sound card chip set (from the ALSA-Configuration.txt file):

Module snd-hda-intel

Module for Intel HD Audio (ICH6, ICH6M, ESB2, ICH7, ICH8),
            ATI SB450, SB600, RS600,
            VIA VT8251/VT8237A,
            SIS966, ULI M5461

Model name Description
---------- -----------

ref Reference board
3stack D965 3stack
5stack D965 5stack + SPDIF

archu, thanks, looking at that script I see the following:amixer set ‘Master’,0 100%,100% on
amixer set ‘PCM’,0 0% 0%
amixer set ‘IEC958’,0 on
amixer set ‘IEC958 Default PCM’,0 on
amixer set ‘Capture’,0 Capture 0 0%,Capture 0 0% on
amixer set ‘Capture Mux’,0 0% 0%
amixer set ‘Input Source’,0 Items: ‘Mic’ Item0: ‘Mic’ With PCM set at 0% you will get no audio. You need to move that up to 75% or so and then test your audio. There is no point in my making further recommendations, until we confirm there is sound, or there is no sound, with PCM at 75%.

txbikerider, ok … but then you need to give me a valid file content, and a valid script output.

The /etc/modprobe.d/sound file you gave me is bad. The script outputs you gave me also are questionable.

I need to see a valid file before I can make a recommendation. I also need to see a valid script output before I can make a recommendation, and as far as I can tell, you had a wrong /etc/modprobe.d/sound file when you ran both of those scripts, which means both of their output are useless to me. I need that script run when you have a good /etc/modprobe.d/sound file, not a file with a cut and paste error.

How do I set PCM ? I don’t see it anywhere in any menu…

I need to see what your mixer looks like. How about a screen print?

Picasa Web Albums - Archu - snapshots

tats the only window i change things for sound… :-S

Okay. I’ve deleted the sound card configuration via YaST-Hardware-Sound and added it back in using the Advanced Configuration option so I could put the “model=dell-3stack” option in the file. I know this is necessary from my previous experience when the sound was working.

Here is what the /etc/modprobe.d/sound file looks like now:

susestar:/home/jim # cat /etc/modprobe.d/sound
options snd-hda-intel enable=1 index=0 model=dell-3stack

u1Nb.NlnQcJzoe90:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

I reran the tsalsa script. The new file is posted to:

tsalsa.txt - (beta)


That does not look like a mixer.

Are you running gnome or kde? If kde, you should have kmix. If gnome, you should have alsamixer.

oldcpu… u rock… i jus opened it and set the pcm to something… and sound jus comes up… thanks a lot… for following my rant :smiley:

This looks ok for an openSUSE-10.3, except there should be no blank line. You could try removing the blank line and then restart your alsa.

Your mixer is not being seen.

I am suspicious of a hardware problem. Do you have another OS (other Linux distribution or Windows) on your PC? Does sound work there? Or alternatively, do you have a liveCD such as Sidux, or Kanotix, or Knoppix from which you can boot and test your sound. Does sound work there?

Can you check your BIOS and ensure sound is not disabled there?

Finally, immediately after a fresh restart, please type:dmesg > dmesg.txtand open up dmesg.txt with a text editor and post that into general pastebin - simplified internet collaboration , submit it, and post the output URL here.