sound turns automatically on while starting the pc

hi everybody,
i run opensuse 11.2 with kdebase4-4.3.5-0.1.1.x86_64 on a hp elitebook 8530w.
when i start opensuse and the sound is initially turned off, it will be turned on while starting. if i turn it of manually (by pushing the appropriate button) it will be turned on again.
I assume that there is a script like .bashrc for bash scripts which tells the system to turn on the sound. Does anyone knows whether there is such a script and if yes, where can i find it and edit it?
Thanks for your help

Your PC sound should be switched ON automatically upon booting to KDE, as long as it was ON when you shutdown. If it was OFF when you shut down, then I believe it may be OFF when you switch ON.

If one is using Gnome, then pulse audio handles the switch OFF/ON. In the case of KDE (where pulse audio is nominally disabled) I am not certain what function handles the OFF/ON upon desktop start … it may be the alsa driver or it may be a KDE4 multimedia function (such as the mixer) that also controls this function …

If you close a session with the sound muted
When you (I) startup the sound is OFF and should not come on

I had difficulty understanding this:* if i turn it of manually (by pushing the appropriate button) it will be turned on again.*

thanks for the answer, next time i’ll try to state the problem more intuitive.

the sound setting is indeed related to the state while closing the session; never the less it is not convenient that the sound setting is changed while starting a session.

i would prefer the ultimate possibility to set the sound on or off before the first noise is emitted. for example muting the sound after booting [but before logging in] should remain regardless of the closing state of the previous session.

thanks anyways for the help

This is a bit difficult to achieve because every user that can login may have its own ideas about this.

E.g. when I left it on when loging out and then the system was rebooted by somebody, who then switched sound off uring boot (using a hardware button) and I then loged in again I would expect sound to be on because I left it on on logging out.

In other words, never forget that Linux is a multi user system (even if in daily life you are the only user) and that all user environment settings are up to every individual user. And that a user can only do any changes to them when (s)he is logged in. Not during boot.

I suspect that the OP is using some keyboard key to turn the sound off and on. I suggest that he/she use the mute in the volume control widget to set the state they want. Rather then using the keyboard state which gets reset no reboots.