Sound system (still) mutes when headphones are plugged

I have an old problem with my laptop, reported here:

up to now, the workaround was to add

options snd-hda-intel model=3stack

to the beginning of


and then run

su -c 'rcalsasound restart'

I just installed 12.2: the problem persists, but the workaround is not working! When issuing the command, I obtain

redirecting to systemctl

and nothing happens. I tried restarting the system but nothing change. Any hint? Thanks!

Entering alsaconf I tried setting “Auto-Mute” to “Disabled”: this way sound come from speakers even if headphones are plugged… but there is still no sound from the headphones.

And yes, I checked the headphones on other devices and they are working :slight_smile:

I mean “alsamixer”

On the bug report, Takashi Iwai found a solution: to disable EAPD. For the first time on several years, headphones work as intended. YES!!

Thats good news. IMHO we are very fortunate to have Takashi Iwai helping us in openSUSE - and he has IMHO helped many who have raised bug reports on sound on openSUSE.