Sound system issue.(11.4 KDE) Pulse Audio removed. Everything worked perfectly until roommate.

Installed from DVD. Deselected Pulse Audio from installation. Worked perfectly. I wake up and the computer has frozen up. My roommate tells me he tried to run some game and that is why it froze. He also installed a Windows game (I’ll be changing wine permissions soon).

All things worked excepting sound from Firefox.
Edit things to repair.

Now, only system sounds work. No sound from any Multimedia application.

Also, at some point Pulse Audio got reinstalled. Which was nothing I did, unless it snuck in an update.

Audigy2 IEC958.

If pulse rpms were actually removed before, then it is a simple matter to check when they were re-installed. Simply type:

rpm -qa --last 

and that will list every rpm on your openSUSE-11.4, in chronological order of the date in which they were last installed. Now that will likely scroll by too fast to read, so you can redirect the output to a text file instead of the screen by typing as a regular user:

rpm -qa --last > myrpmlist.txt 

and open up the file myrpmlist.txt with a text editor. Check out the installation date/time. That should tell you who re-installed pulse based on the time of use (if you can remember who was using the PC at what time).

For your ‘roommate’ to install anything suggests that they had root permissions. You may wish to rethink your policy of giving someone else the root password.

Yeah. He doesn’t have root. Though for Wine programs you don’t need root. I would like to just reset the sound stuff to what it was when I installed, when everything worked perfectly. If thats possible. I tried reinstalling the alsa stuff to see if that might force it to do that, but no it didn’t. I don’t want to have to reinstall 11.4 if I don’t have to.

Just checked. It doesn’t indicate it was reinstalled. Though I know fully well it was.

It will only indicate the LAST installation, not every installation/re-installation. Just the last. So look at the date of the installation and that is where it was re-installed last. It will ONLY have the wrong date/time if your PC clock is wrong. If your PC clock is correct, then its likely your memory is on par with my memory , where my memory is notorious for not being so good (as my wife notes to me various times). :frowning:

If you removed pulse and did not keep track of what you removed, then this could be difficult to ensure you have the proper pulse apps re-installed. Did you make notes, writing down exactly what you removed in pulse before it was installed again ?

No. I think I will start keeping changelogs. I reinstalled pulse, plus some utilities. I have gotten sound back to my music player and caffeine. Sound is still not coming from firefox. Once I have that I shall be basically content. LMMS doesn’t make sound either. Can I just roll back to whatever it was when it was first installed?

I’m about to just reinstall the whole thing.

On 04/17/2011 01:06 AM, Shadowolf7 wrote:
> Yeah. He doesn’t have root.

he also should not have access to your user account…

and, without root it would not be possible to install pulseAudio–so,
you can’t blame that on him…you wrote “unless it snuck in an update”
which could happen if you don’t check every line of every list of
dependency packages offered as part of every update that comes along…

that is why the lists are available, prior to install…

[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]
Q: Why do you upgrade?
A: Because the Gecko is always greener on the other side!
So said k428 in

I recommend you also install the pulse volume control application ‘pavucontrol’. Once that is installed, if you try to play a video with sound (say from youtube) with firefox and then while it is playing launch ‘pavucontrol’ you should be able to tune your settings such that pulse audio will work. Here is a sample of some things to look at with pavucontrol (in my example I am using smplayer, but the same is true for firefox).

ie ensure you have an appropriate audio device selected and that sound is not muted for this device:](
[click on image for larger version of image]

and ensure you have pulse audio tuned for this application with sound not muted and an appropriate audio device selected:](
[click on image for larger version of image]

I downloaded pavucontrol and other utilities. I haven’t seen an entry in clients for firefox, or other applications that don’t have working sound. i’m going to do some more reading on pulse audio to see i I can get a better feel for it.

I read about jack2 as well. Why aren’t we using that? It seems superior.

Ha! I installed updates last night, and most were xine related. I thought to myself “hmm, maybe this will fix whatever plugin I accidentally removed.” I walk out of my room and hear an odd noise, and youtube is working fine in firefox again… granted with Pulse Audio. I don’t mind Pulse if it works. But for some odd reason the sound won’t work hardly at all when it is from the LiveCD, but the DVD install forces it to work just fine.

Kmix integration with Pulse isn’t very good yet is it?

Please look again. I can’t help but be suspicious the setting was there, but you might have been fixated looking for the EXACT words ‘firefox’ and you won’t see that. Firefox uses system sound, so the words will likely be more general.

For example, here is a screen print from my sandbox PC with a video with audio (from youtube) playing in firefox.](
[click on image for a larger view]

I read about jack2 as well. Why aren’t we using that? It seems superior.

Jack2 has its purposes, but its more complex than pulse. If users have problems with pulse, then IMHO Jack will give them far more problems.

Good point. Thats a useful screen shot. Have any good sources for documentation or something of the sort so I can learn all about pulse? Alot of people seem to have trouble with it.