Sound suddenly doesn't work anymore

When I tried to watch a Youtube video today, I noticed that I suddenly didn’t have sound anymore :open_mouth: Just yesterday, it still worked fine.
Changing the video volume didn’t do anything, so I looked at the mixer icon in the taskbar - and noticed to my surprise that it was suddenly set to mute, without me ever having touched it! :silly:

I set it back to full volume, but still nothing. I then tried to play ordinary videos in nmy video player, but also there - no sound! So it’s not limited to Flash videos.

The sound test in Yast doesn’t play any sound, either, it produced just a very short popping sound, that’s all. I tried turning off Pulse Audio there, but that didn’t change anything, so I turned it on again (I use Pulse Audio for sound).

Next, I tried the Kde Control Panel, but got no test sound either, just again the very short popping sound on htting the test button and nothing else.
I’ve even tried switching the preference from xine (which I normally use) to gstreamer, but that didn’t change anything either.

Then I did a reboot and tried things again, but no change.
Finally, I checked my headphones. They were plugged in properly, and plugging them out and back in again didn’t do anything either.

So I’m out of Ideas what I could still try. Sound hardware is Realtek HD onboard sound, which is identified as “hda ati sb alc889a analog”. Kde is 4.4 RC3, which I’ve been using already since over a week without problems, so I doubt that’s the problem.

any of these thing my have resulted in the symptoms you write:

did you apply any updates? new KDE maybe?
install new programs? especially any which use sound?
did you run any windows programs which use sound?
did you run any programs in a VM which use sound?
did you log into KDE, Gnome or other DE as root?
did you log out of KDE and into Gnome or other DE?

if you use YaST to add a new user, then log out and back in as the new
user: does the sound work then?


  1. No new Kde, only the usual updates. I’ll see if installing Kde 4.4 final fixes it.
  2. no and no
  3. I haven’t used Windows in quite a while now.
  4. I don’t have any VM installed.
  5. No sound as root either, just the short popping noise - all the same. Obviously no rights conflict.
  6. I don’t have Gnome installed and really don’t want it either.
  7. I’ll try that and get back at you again.

Ok, I tried some more things:

  • Windoze: After the player crashed and then complained about a few other files (how I missed that :sick: ), I finally found a file it would play, and it played normally with sound. I then tried Flash video, and it played normally as well.

  • User groups: Using Yast, I checked the groups my user account was in and found it was only in the “video” group. I then added it to the “audio”, “pulse” and “pulse-access” groups and rebooted, but sound still doesn’t work.

  • New user account: Created new user account and rebooted. Still no sound, not even the popping noise. Added new user to groups as above and rebooted, also nothing.

i am sorry that you misunderstood my questions and took them as
directions/hints for possible solutions or places to look for more info…

i have experienced system problems caused by adding new
applications, updates, conflicting desktop environments, root mangling
files and etc–it was therefore i was asking to try to determine if
any of those things occurred between working and ‘suddenly’ not working…

that is, in no way did i want you to use windows/wine nor log into KDE
as root, or do any of the other things i asked about…

do not log into KDE as root! that is never a step to happiness, and is
often a step to unhappiness…read more on that here:

the only thing i asked you to do was try adding a new user…
and, since that failed we now know that the problem doesn’t exist in
the hidden setup files within your /home

and, we know that the only things that changed between a working
system and a broken system is adding “the usual updates”

had you just answered the questions i would have recommended to back
level the updates and that would probably fix it, as ‘suddenly’ as it
broke it…but, as you have now wiggled so many different group
things, i don’t have a clue…



Tokugawa-san, one of the updates would have been the 2.6.31-12 kernel…AFAICS that’s where the trouble is. Looks like you suffer from the “default muted PCM channel”.

Please post output of:

zypper lr


rpm -qa | grep alsa

I didn’t login as root (I’m not as dumb), I just used “kdesu” to run programs as root and try out if they work there.

I did just install kernel, so that could be the cause. Sounds like that “default muted PCM channel” is a common problem, what can you do against it?

Coming right up.

zypper lr

#  | Alias                                                                  | Name                                                                   | Enabled | Refresh  
1  | Ati_drivers                                                            | Ati drivers                                                            | Yes     | Yes      
2  | Compiz_-_xgl                                                           | Compiz - xgl                                                           | Yes     | Yes      
3  | Kde4_Factory                                                           | Kde4 Factory                                                           | Yes     | Yes      
4  | Kde4_Factory_Community                                                 | Kde4 Factory Community                                                 | Yes     | Yes      
5  |                                        | openSUSE BuildService - KDE:Backports                                  | Yes     | Yes      
6  |                                        | openSUSE BuildService - KDE:KDE4:Community                             | Yes     | Yes      
7  |                                           | openSUSE BuildService -                                 | Yes     | Yes      
8  |                                          | openSUSE BuildService - Mozilla                                        | Yes     | Yes
9  |                                         | Main Repository (Contrib)                                              | Yes     | Yes
10 |                                             | VideoLan Repository                                                    | Yes     | Yes
11 |                                                     | Packman Repository                                                     | Yes     | Yes
12 | | | Yes     | Yes
13 | libdvdcss                                                              | libdvdcss                                                              | Yes     | Yes
14 | openSUSE 11.2-0                                                        | openSUSE 11.2-0                                                        | No      | No
15 | openSuse_XOrg                                                          | openSuse XOrg                                                          | Yes     | Yes
16 | openSuse_Yast                                                          | openSuse Yast                                                          | Yes     | Yes
17 | repo-debug                                                             | openSUSE-11.2-Debug                                                    | No      | Yes
18 | repo-non-oss                                                           | openSUSE-11.2-Non-Oss                                                  | Yes     | Yes
19 | repo-oss                                                               | openSUSE-11.2-Oss                                                      | Yes     | Yes
20 | repo-source                                                            | openSUSE-11.2-Source                                                   | No      | Yes
21 | repo-update                                                            | openSUSE-11.2-Update                                                   | Yes     | Yes

rpm -qa | grep alsa


I went and reinstalled the kernel using Yast, telling it to downgrade.
After rebooting however, I found no improvement: as before, as soon as I hit the “Test” button under Kde systemsettings > Multimedia, I just get a short popping noise, and the speaker in the system tray instantly changes into a “mute” symbol >:(
Unmuting doesn’t do anything to fix it.

It seems that whatever the kernel messed up, couldn’t be fixed by simply reinstalling the kernel :frowning:

I just got back after a 10 day business trip/vacation …

To help us to better understand the problem on your PC, please provide the information requested here from the multimedia stickie: Welcome to multimedia sub-area - openSUSE Forums I can take a look at that, and I might be able to either diagnose the problem, or provide possible solutions you can try. The specific part of that stickie to follow is:

… please post in this “multimedia” sub-forum, providing in your post the following information:

  • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
    SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script /usr/sbin/ and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL. Just the URL. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.2 or later, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

Please provide that information in a reply post.

Hi oldcpu,

I have the same problem. Can you analyse my outputs and tell me where to fix it?


Output of

rpm -qa ‘alsa

rpm -qa ‘pulse

rpm -q libasound2

uname -a
Linux mystic_IX #1 SMP PREEMPT 2010-01-27 08:20:11 +0100 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/50-sound.conf
options snd slots=snd-via82xx

Ssy1.KzJ6TO9PmfB:A7V600/K8V-X/K8V Deluxe motherboard (ADI AD1980 codec [SoundMAX])

alias snd-card-0 snd-via82xx

Sure, but please, this is a long thread with changing information. Can you instead just describe what your problem symptoms are? I find it difficult to figure out what you mean by the “same problem”. Does that mean no sound in any application? Or only no sound in some applications?

In my case it means no sound in any application I use.

Have you tried the 3 different sound tests from the audio troubleshooting guide (speaker-test x2 and aplay) : SDB:AudioTroubleshooting - openSUSE - step-1 how t test your sound Do you get sound from any of those tests?

Does sound work with any other Operating System currently (to prove this is not a hardware problem)?

In the meantime, I’ve reinstalled the kernel, since going back to did nothing to fix my problem.

Then, I searched for “alsa” in Yast and reinstalled any alsa packages I had installed.
After reboot, my problem had curiously changed into this:

If I right away run an app with audio output as root (using “kdesu”), it now plays audio just fine. If I however run an app with audio output as ordinary user, I again just get the short popping noise and no sound at all, and the speaker symbol in the system tray instantly changes into a “Mute” icon. Opening KMix and unchecking “Mute” apparently does nothing to un-mute the sound, as I still don’t get any sound. Once the sound has been muted once like that, I don’t even get sound anymore if it run an app with audio output as root! :open_mouth:
I have to reboot to be able to get sound (as root only) again.
I already added myself to the “audio” group (as well as “pulse” and “pulse-access” for PulseAudio), but that didn’t change anything.

Here’s the output you asked for:


rpm -qa ‘alsa

rpm -qa ‘pulse

rpm -q libasound2

uname -a
Linux edo-bakufu #1 SMP PREEMPT 2010-01-27 08:20:11 +0100 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/50-sound.conf
options snd slots=snd-hda-intel,snd-hda-intel

5Dex.iJFyZm0FWpB:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel

2Oa+.HSwEnS_iQOB:HD48x0 audio

alias snd-card-1 snd-hda-intel

Try to avoid using root.

What are you using for a speaker sound test? Have you tried the 3 different sound tests from the audio troubleshooting guide (speaker-test x2 and aplay) : SDB:AudioTroubleshooting - openSUSE - step-1 how t test your sound Do you get sound from any of those tests?

Does sound work with any other Operating System currently (to prove this is not a hardware problem)?

When your sound does not work (as a regular user) have you tried restarting alsa sound driver to see if that restores sound to a regular user? You can do that by typing:

su -c 'rcalsasound restart'

… again, other than the occasional test, try to avoid using root as much as possible.

As long as they’re run as root (from a root konsole, or using kdesu) and I haven’t run any sound-enabled apps as ordinary user yet, sound with all sound tests and sound-enabled apps works fine:

speaker-test -Dplug:front -c2 -l5 twav
Yast > Sound > Other > Play Test Sound
Kde systemsettings > Multimedia > Test sound

However, if any of the above tests or apps, or any sound-enabled app at all (like Firefox, which can play Flash videos with sound) is run as ordinary user, all I get is a short popping noise and then only silence. The speaker icon in the system tray instantly turns into a “Mute” icon, indicating that sound has been muted. Even if I open KMix and remove the checkmark from “Mute”, I cannot get any sound anymore in any app.
At that point, even if I run any sound test or app as root, I cannot get any sound there anymore either.
I have to reboot to be able to get sound again (when running the apps as root).

Sound on Windowze works without problems. It’s not a hardware problem, otherwise it wouldn’t work either when running apps as root.

I tried that, and while it did say that it stopped and restarted it successfully (both times green OK), I still don’t get any sound after that once it’s been muted, neither as root, nor as ordinary user. I still have to reboot.

Please try all 3 speaker tests in the audio troubleshooting guide. Based on your posts, I can NOT tell if you tried all 3.

Typically only 1 or 2 of the 3 will work. If you do not try all 3 you are not giving this a proper test.

I think when you are testing the sound with root permissions, different mixer settings may be applied.

Is this a 5.1 surround sound setup ?

Did you try moving up the 5.1. surround sound controls?

One possible way to check if this may be a users specific configuration problem, is to create a new temporary user. Say user ‘temp’. Then log in as user ‘temp’ and see if they have the same problem with sound.

If they do, then you could try updating alsa. There is some guidance here for that: Alsa-update - openSUSE … however my experience is the zypper commands in that URL do not work well, so you may need instead to update via YaST , being very careful to add and them remove the repository after installing each set of rpms, and also be careful to ensure you update, and do NOT accept a notification that you already have the updates when you do not.

Here are the results of running all three methods from a root konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Works fine.

speaker-test -c2 -l5 -twav
throws error messages, no sound:

speaker-test 1.0.21

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib pulse.c:229:(pulse_connect) PulseAudio: Unable to connect: Connection refused

Playback open error: -111,Connection refused
ALSA lib pulse.c:229:(pulse_connect) PulseAudio: Unable to connect: Connection refused

Playback open error: -111,Connection refused

The last two error messages are repeated until I break off.

aplay --vv file.wav
throws error messages, no sound:

ALSA lib pulse.c:229:(pulse_connect) PulseAudio: Unable to connect: Connection refused

aplay: main:608: audio open error: Connection refused

It’s worth mentioning though that the latter two tests don’t mute the sound. I can still get sound in other apps after running them (as long as they’re run with root rights).

If I run any of the three sound tests as ordinary user, I get only the short popping noise, and sound is instantly muted.
Again worth mentioning with the latter two is that I don’t get any error messages. They now behave like the first test, as if sound would be playing (which it isn’t, as it’s muted).

No, I only ever have ordinary stereo headphones connected.

Already tried that and created a new user, but all the same problems there.

Alsa is already at the most recent versions avaiable from Yast (versions see above), but I will still try this.

Ok, it said that it installed one new package. Rebooting now to see if it helped.