Sound stutters / skips in opensuse 12.3 snd-hda-intel

I’ve had issues with mp3 files stuttering, and otherwise skipping, scratching, popping, and playing choppy on my 586 opensuse 12.3 laptop. Sound worked in about the Ubuntu 9.04 time frame, but in some upgrade pulseaudio or alsa must have changed and broke the configuration. That gave me the excuse to move distributions, but I had the same problem in Fedora and now opensuse. Sound has worked fine on this same laptop in windows xp (32 bit) and 7 (64 bit).

I’ve done quite a bit of troubleshooting but haven’t hit the magic combination yet. Modifying /etc/pulse/ to have tsched=0 makes sound in flash sound like a machine gun, and doesn’t stop the regular mp3 stuttering.

load-module module-udev-detect tsched=0

Regular speaker tests like “speaker-test -c2 -l5 -twav” run fine.

I’ve tried many options in /etc/modprobe.d/50-sound.conf, both with options at the top and the bottom of the file. (I’m not sure if that matters.) These are a few I’ve tried one at a time, with reboots:

options snd-hda-intel enable_msi=1 bdl_pos_adj=0,48
options snd-hda-intel position_fix=2
options snd-hda-intel position_fix=1
options snd-hda-intel model=auto enable_msi=0
options snd-hda-intel model=auto enable_msi=0

I’ve gone through the steps in SDB:Intel-HDA sound problems - openSUSE and SDB:Audio troubleshooting - openSUSE. Previously I’ve tried various “remove all of pulseaudio” steps but that didn’t work, either. I did try setting in /etc/pulse/daemon.conf

default_sample_rate = 48000

but that didn’t help.

From I found the hint in /etc/pulse/daemon.conf to uncomment the default-fragments and default-fragment-size-msec, and change values from the default 4 and 25 to 16 and 21, but that didn’t fix it.

head -n 1 /proc/asound/card0/codec#*
==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC268

==> /proc/asound/card0/codec#1 <==
Codec: Motorola Si3054

“sudo lspci -v | grep -A 10 Audio” tells me I have an Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03). As I type this MSI: is Enable-, but I’ve had it Enable+ before, too. (That flips depending on enable_msi.)

The laptop itself is a Compal JFL92 I got from system76 as a SERP4 (serval performance). describes an archlinux problem that looks the same as mine, but the “enable_msi=0” workaround didn’t fix me.

I’m out of ideas. If anyone has any ideas to try or needs more specific information I’d love the help.

Try turning pulse off in Yast-sound

It still skips playing mp3s. I opened up yast, Went to sound > Other > PulseAudio Configuration… > and unchecked Enable PulseAudio Support, then rebooted. KDE noticed I had controllers missing (the pulseaudio bits), but I had it leave them in place.

I have a blog on using PulseAudio you can find here: PulseAudio and Selecting the Proper Sound Card Configuration - Blogs - openSUSE Forums

Thank You,

Thanks for the tip. I’ve now installed pavucontrol (and re-enabled pulseaudio since disabling it didn’t help) but it doesn’t fix the choppy stuttering skipping problem.

And did you follow our Multimedia codec guide?

Normally, that Intel chipset should work OK I would think.

Thank You,

I used that (or an earlier version) when I installed so I could get all the right codecs. I suspect it’s non-destructive so I’ll try it again later.

I’ve downloaded the drivers direct from realtek, but I’m hesitant to install it in case I can’t back it out if it makes the problem worse.

It looks like I hadn’t, since I had to add the repos and install a bunch of packages. I wonder if I’d followed a similar Ubuntu method that had similar names. Aside: The 12.3 version is at

In any event, I installed all the kde packages, rebooted, and still have the skipping.

Have I suggested a new kernel upgrade? Have a look here: openSUSE and Installing New Linux Kernel Versions - Blogs - openSUSE Forums

The kernel is where the base hardware driver is stored.

Thank You,