Sound stuttering in movie playback...


I have some videos on my harddrive. In most of them the sound just stutters for a short while and then they work fine. But others the stuttering seems to go on. I must admit I didn’t have the guts to check the whole videos…Its kind of torture to watch a full length music video with stuttering sound…:stuck_out_tongue:

Man…I’m asking so many questions here I’m starting to get ashamed of myself !! :shame:rotfl!


I assume this is not SuSE-9.3. … :expressionless: Can you tell us what SuSE version? What desktop? What multimedia application? What output audio mode is selected in the multimedia application? What format/codec of the videos? What CPU has your PC? What graphics card? What graphical driver?

Did you try disabling special desktop effects to see if that helps?

If you have a new version of openSUSE (11.0, 11.1, 11.2) and if pulse audio is enabled, you could try one of the suggestions here from step #7 : SDB:AudioTroubleshooting - openSUSE - step7 pulse audio problems

Sorry, my bad…

OpenSUSE 11.1 64 bit

GNOME Desktop,


Audio output is set to ‘Default’

Audio codec is ‘a52’, video is ‘Div3’

The file is called .avi (I’m not sure if this is the kind of ‘format’ you need to help me)

CPU is INTEL Core2 Duo P8400 @ 2.26 GHz
Nvidia Geforce 9600M GT

YaST → Hardware Information identifies the driver as ‘nvidia’.

I tried using the solution you link to, I right-click, open it with gedit and make the change. When I want to save it claims I don’t have permission to do that. So I open the terminal and put in this:

sudo gedit

I put my root password and then this error happens:

(gedit:12738): Gtk-WARNING **: cannot open display: 


Hmm…mplayer performs without any stuttering in neither sound nor image…Maybe I should use that instead.


Please follow this carefully
Multi-media and Restricted Format Installation Guide - openSUSE Forums

smplayer is a good front to mplayer try it.

If mplayer plays normally and properly, and VLC does not, then the problem is with the settings in VLC.

I don’t normally use VLC (not my style), but I just set it up, and have no stuttering. But then I went mostly with defaults. So it must be VLC settings.

I had a similar situation, although it was rare, on opensuse 11.1. Upgrading to opensuse 11.2 solved the problem.