Sound stops working randomly under GNU/Linux


I have this very annoying problem:

Laptop i3 4 GB RAM Lenovo, about 2 years old.

Under Windows 7 and 10 sound works well.

Under GNU/Linux sound stops working randomly, after 30 seconds or after 1 hour. The microphone continues to run, but I cannot hear sounds anymore.

Also, I tried “speaker-test” - it does not write errors, seems to work, just sound is not audible.

I tried installing fresh openSuse 41.2 Leap, Tumbleweed, with Xfce and KDE, Xubuntu, Linux Mint Cinnamon, with/without updates. The same behavior.

Until 10 days ago it worked correctly.

I am getting desperate. I searched the internet and tried all possible workouts from the forums.

I attach the sudo from my computer, when sound is not working (after it worked for about 1 hour).…2a2d7fa6f1fc3c

Update: when the sound works, if I plug in the headphones, sound is audible in the headphones. Also, after the sound stops working in the internal speakers, the headphones still work if I plug them in.

Update: it seems that the problem is also present in Windows.

Hmm, Windows seems to run fine (more than 3 hours now and OK).

As nobody has offered better suggestion, here’s mine, worth what you paid for it :slight_smile:

Open YaST, Sound Setup. Under the “Other” button choose “PulseAudio support…” and unmark checkbox “Enable Pulseaudio Support”.

I haven’t had problem with PulseAudio in Leap 42.1, but in 13.1 it sometimes failed in mysterious ways. Sound worked much more reliably without Pulseaudio.