Sound stopped working

Hello, I’m running Tumbleweed with kernel 5.14.14-2-default with the KDE spin. My problem is that sound stopped working. As far as I can tell it stopped when recovering from a problematic pipewire update. I dual boot other linux systems and spimd works on them.

When I initially had the problem, yast showed that there was no driver for the sound card. I used yast to fix that and now it is showing devices with drivers.

The KDE sound applet shows an error message of “No output or input devices found.”

Looking at other forum entries, I see the following:

bopper:/home/jc # zypper se -si pulse pipe
Loading repository data...
Reading installed packages...



S  | Name                       | Type    | Version                           | Arch   | Repository
---+----------------------------+---------+-----------------------------------+--------+-----------------------------
i  | alsa-plugins-pulse-32bit   | package | 1.2.5-1.2                         | x86_64 | Main Repository (OSS)
i  | alsa-plugins-pulse-32bit   | package | 1.2.5-1.2                         | x86_64 | openSUSE:Tumbleweed
i  | gstreamer-plugin-pipewire  | package | 0.3.39-2.3                        | x86_64 | packman
i  | gstreamer-plugin-pipewire  | package | 0.3.39-2.3                        | x86_64 | Packman Repository
i+ | libpipeline1               | package | 1.5.3-1.5                         | x86_64 | Main Repository (OSS)
i+ | libpipeline1               | package | 1.5.3-1.5                         | x86_64 | openSUSE:Tumbleweed
i+ | libpipewire-0_3-0          | package | 0.3.39-2.3                        | x86_64 | packman
i+ | libpipewire-0_3-0          | package | 0.3.39-2.3                        | x86_64 | Packman Repository
i  | libpipewire-0_3-0-32bit    | package | 0.3.39-2.3                        | x86_64 | packman
i  | libpipewire-0_3-0-32bit    | package | 0.3.39-2.3                        | x86_64 | Packman Repository
i+ | libpulse-mainloop-glib0    | package | 15.0-4.1                          | x86_64 | Main Repository (OSS)
i+ | libpulse-mainloop-glib0    | package | 15.0-4.1                          | x86_64 | openSUSE:Tumbleweed
i+ | libpulse0                  | package | 15.0-4.1                          | x86_64 | Main Repository (OSS)
i+ | libpulse0                  | package | 15.0-4.1                          | x86_64 | openSUSE:Tumbleweed
i  | libpulse0-32bit            | package | 15.0-4.1                          | x86_64 | Main Repository (OSS)
i  | libpulse0-32bit            | package | 15.0-4.1                          | x86_64 | openSUSE:Tumbleweed
i+ | pipewire                   | package | 0.3.39-2.3                        | x86_64 | packman
i+ | pipewire                   | package | 0.3.39-2.3                        | x86_64 | Packman Repository
i  | pipewire-alsa              | package | 0.3.39-2.3                        | x86_64 | packman
i  | pipewire-alsa              | package | 0.3.39-2.3                        | x86_64 | Packman Repository
i  | pipewire-libjack-0_3-32bit | package | 0.3.39-2.3                        | x86_64 | packman
i  | pipewire-libjack-0_3-32bit | package | 0.3.39-2.3                        | x86_64 | Packman Repository
i+ | pipewire-media-session     | package | 0.4.1+4~git20211111.e4b49a306-2.1 | x86_64 | home:X0F:branches:multimedia
i+ | pipewire-modules           | package | 0.3.39-2.3                        | x86_64 | packman
i+ | pipewire-modules           | package | 0.3.39-2.3                        | x86_64 | Packman Repository
i  | pipewire-pulseaudio        | package | 0.3.39-2.3                        | x86_64 | packman
i  | pipewire-pulseaudio        | package | 0.3.39-2.3                        | x86_64 | Packman Repository
i+ | pipewire-spa-plugins-0_2   | package | 0.3.39-2.3                        | x86_64 | packman
i+ | pipewire-spa-plugins-0_2   | package | 0.3.39-2.3                        | x86_64 | Packman Repository
i+ | pipewire-spa-tools         | package | 0.3.39-2.3                        | x86_64 | packman
i+ | pipewire-spa-tools         | package | 0.3.39-2.3                        | x86_64 | Packman Repository
i+ | pipewire-tools             | package | 0.3.39-2.3                        | x86_64 | packman
i+ | pipewire-tools             | package | 0.3.39-2.3                        | x86_64 | Packman Repository
i+ | pulseaudio-bash-completion | package | 15.0-4.1                          | x86_64 | Main Repository (OSS)
i+ | pulseaudio-bash-completion | package | 15.0-4.1                          | x86_64 | openSUSE:Tumbleweed
i+ | pulseaudio-utils           | package | 15.0-4.1                          | x86_64 | Main Repository (OSS)
i+ | pulseaudio-utils           | package | 15.0-4.1                          | x86_64 | openSUSE:Tumbleweed
i  | pulseaudio-utils-32bit     | package | 15.0-4.1                          | x86_64 | Main Repository (OSS)
i  | pulseaudio-utils-32bit     | package | 15.0-4.1                          | x86_64 | openSUSE:Tumbleweed
bopper:/home/jc # 

systemctl --user list-unit-files | grep -i "pipe|pulse"
returns nothing



pactl info | grep -i server
returns
Server String: /run/user/1000/pulse/native
Server Protocol Version: 35
Server Name: PulseAudio (on PipeWire 0.3.39)
Server Version: 15.0.0



jc@bopper:~> systemctl --machine=bopper@localhost --user list-unit-files | grep -i "pipe|pulse" 
Failed to connect to bus: Host is down
Failed to list unit files: Transport endpoint is not connected

pavucontrol shows no input or output devices.

I’m fairly experienced with linux but have very limited current experience with opensuse and have no ideas on how to proceed. Please advise/

Run the command like this (with egrep)…

systemctl --user list-unit-files | egrep -i "pipe|pulse"

I’m fairly experienced with linux but have very limited current experience with opensuse and have no ideas on how to proceed. Please advise/

I have seen similar issues reported (other distros) due to some apparent regression with pipewire-media-session, but not sure if they relate specifically to your situation.

What does the following command return?

systemctl --user status pipewire

BTW, follow the sound troubleshooting advice outlined here…
https://en.opensuse.org/SDB:Audio_troubleshooting

Run the alsa-info.sh diagnostic script as described in the guide as well, let it upload the output to an online server, and share the URL that it provides here.

https://forums.opensuse.org/showthread.php/561830-Updated-recently-Soundblaster-card-no-longer-available-in-GUI

https://forums.opensuse.org/showthread.php/562232-audio-gone-after-update-to-tumbleweed-20211107

…it’s a mess. No solution found yet…

jc@bopper:~> systemctl --user list-unit-files | egrep -i "pipe|pulse"
**pipe**wire-media-session.service                                 enabled   enabled
**pipe**wire-**pulse**.service                                         disabled  disabled
**pipe**wire.service                                               disabled  disabled
**pipe**wire-**pulse**.socket                                          enabled   enabled
**pipe**wire.socket                                                enabled   enabled
jc@bopper:~>  



That checks out as expected… and the other commands/output?

bopper:/home/jc # cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k5.14.14-3-default.
bopper:/home/jc # cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel
2 snd_usb_audio

**bopper:/home/jc #** cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf6080000 irq 76
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xf6700000 irq 78
 2 [Camera         ]: USB-Audio - USB 2.0 Camera
                      Sonix Technology Co., Ltd. USB 2.0 Camera at usb-0000:07:00.3-1, high speed
**bopper:/home/jc #** 

**bopper:/home/jc #** lspci | grep -i audio
06:00.1 **Audio** device: NVIDIA Corporation GP107GL High Definition **Audio** Controller (rev a1)
08:00.3 **Audio** device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) HD **Audio** Controller
**bopper:/home/jc #** 


That’s not what was requested. From post #2

systemctl --user status pipewire

and the alsa-info.sh diagnostic utility (refer troubleshooting guide post #3).

j

c@bopper:~> systemctl --user status pipewire
**●** pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor preset: disabled)
     Active: **active (running)** since Wed 2021-11-17 18:04:38 EST; 1h 15min ago
TriggeredBy: **●** pipewire.socket
   Main PID: 4955 (pipewire)
      Tasks: 2 (limit: 4915)
     Memory: 2.4M
        CPU: 20ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─4955 /usr/bin/pipewire

Nov 17 18:04:38 bopper systemd[4418]: Started PipeWire Multimedia Service.
jc@bopper:~> 

The ALSA info output is at

http://alsa-project.org/db/?f=15dba988cbb8561221c66cf3a28a6f67cbfc1375


The alsa-info.sh output suggests no obvious issues.

FWIW, I did find this reddit thread discussing similar audio device issues as you report. It might relate to the recent “alsa-ucm-conf” regression (version 1.2.5) perhaps. Bug report…
https://bugzilla.opensuse.org/show_bug.cgi?id=1187079
You can check the installed version with…

rpm -qi alsa-ucm-conf

This is running 1.2.5.1. I would assume he thought he had fixed the problem that happened in 1.2.5.

**bopper:/home/jc #** rpm -qi alsa-ucm-conf
Name        : alsa-ucm-conf
Version     : 1.2.5.1
Release     : 1.2
Architecture: noarch
Install Date: Wed Sep 22 20:50:31 2021
Group       : Unspecified
Size        : 184186
License     : BSD-3-Clause
Signature   : RSA/SHA256, Sat Sep 18 07:23:11 2021, Key ID b88b2fd43dbdc284
Source RPM  : alsa-ucm-conf-1.2.5.1-1.2.src.rpm
Build Date  : Sat Sep 18 07:23:05 2021
Build Host  : goat05
Packager    : https://bugs.opensuse.org
Vendor      : openSUSE
URL         : https://www.alsa-project.org
Summary     : ALSA UCM Profiles
Description :
This package contains the profiles files for ALSA UCM (Use Case Manager).
Distribution: openSUSE Tumbleweed
**bopper:/home/jc #**  




I would hope so too, but can’t be sure (and I’m not using TW).

I also note that you’re using pipewire from packman (rather than OSS)…not sure if that might be impacting here?

i+ | pipewire                   | package | 0.3.39-2.3                        | x86_64 | packman

See Malcom’s comments in this thread…
https://forums.opensuse.org/showthread.php/562232-audio-gone-after-update-to-tumbleweed-20211107?p=3082436#post3082436

](https://forums.opensuse.org/showthread.php/562232-audio-gone-after-update-to-tumbleweed-20211107?p=3082436#post3082436)

I’m not using any version intentionally. If you want me to switch, tell me what to do.

https://en.opensuse.org/SDB:Vendor_change_update#Using_zypper

Show your current defined repos…

zypper lr -d

One minor thing to consider … Note that your PC currently has HDMI as card-0 and your analog audio as card-1.

By default openSUSE will send audio from a multimedia application to card-0. So if you are using analogue audio and you have not made the effort to redirect audio to card-1, then you won’t hear any audio.

When there was just alsa + pulse audio, in cases where analog audio was on card-1, typically one would install pavucontrol (pulse audio volume control) and redirect the audio on a per application basis to sound card-1 (for analogue audio). In this day and age of pulse audio, I assume the same is true, albeit I am not certain.

This is a very basic observation, and my apologies if you considered this, tested, this, and this is not the issue. I just wanted to ensure this was considered.

Yes, pavucontrol still works for configuring audio when using pipewire.

What about pipewire?. My experience: No Sound Server, no issues:

karl@erlangen:~> inxi -zaA 
**Audio:     Device-1:** Intel 100 Series/C230 Series Family HD Audio **vendor:** ASRock **driver:** snd_hda_intel **v:** kernel 
           **bus-ID:** 00:1f.3 **chip-ID:** 8086:a170 **class-ID:** 0403 
           **Device-2:** AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X] **vendor:** Sapphire Limited 
           **driver:** snd_hda_intel **v:** kernel **bus-ID:** 01:00.1 **chip-ID:** 1002:aae0 **class-ID:** 0403 
           **Sound Server-1:** ALSA **v:** k5.14.14-3-default **running:** yes 
           **Sound Server-2:** PulseAudio **v:** 15.0 **running:** yes 
           **Sound Server-3:** PipeWire **v:** 0.3.39 **running:** no 
karl@erlangen:~> 

Not sure what you’re trying to convey here. You’re using PulseAudio (as a sound server).

Sound Server-3: PipeWire v: 0.3.39 running: **no

**

[FONT=monospace]**erlangen:~ #** ps -ax|grep pulse 
 5213 ?        S<sl   0:13 /usr/bin/**pulse**audio --daemonize=no --log-target=journal 
 5883 ?        Sl     0:00 /usr/libexec/**pulse**/gsettings-helper 
16111 ?        S<sl   0:03 /usr/bin/**pulse**audio --daemonize=no --log-target=journal 
16303 ?        Sl     0:00 /usr/libexec/**pulse**/gsettings-helper 
21048 pts/1    S+     0:00 grep --color=auto **pulse** 
**erlangen:~ #** ps -ax|grep pipe 
21052 pts/1    S+     0:00 grep --color=auto **pipe** 
**erlangen:~ #** [/FONT]

So, you’re using pulseaudio, and the OP is using pipewire. I’m also using pipewire (successfully), but none of this is relevant to the OP’s situation.