Sound stopped working

Everything was working fine … then not. Perhaps a package update caused this??

I have a Dell USB Soundbar and an internal Intel sound device. Both appear in YAST under the Sound entry. The USB sound bar is the default (0) and plays the test sound fine from within YAST.

In Phonon audio setup the usb soundbar and the Intel device appear but are greyed out. The “Dummy output” is the only one that can be selected.

Running /usr/sbin/ gives me the following entries:
!!Loaded ALSA modules

!!Soundcards recognised by ALSA
0 [SoundBar ]: USB-Audio - Dell AC511 USB SoundBar
Dell Dell AC511 USB SoundBar at usb-0000:00:1d.7-3.4, full speed
1 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xfe9fc000 irq 44

!!Aplay/Arecord output
aplay: device_list:268: no soundcards found…

arecord: device_list:268: no soundcards found…

!!Amixer output
!!-------Mixer controls for card 0 [SoundBar]
Invalid card number.

!!-------Mixer controls for card 1 [Intel]
Invalid card number.

I have tried forced re-installation of alsa and components without any success. I also tried reverting to pulseaudio 5 without success.

Any suggestions on how I fix this?



I am running opensuse 13.2 KDE : 3.16.7-21-desktop #1 SMP PREEMPT Tue Apr 14 07:11:37 UTC 2015 (93c1539) x86_64 x86_64 x86_64 GNU/Linux
alsa 1.0.29 222.1
pulseaudio 6.0-5.2

It is now all back working again. The problem appears to have been with the user permissions. See this other thread:

I too had the sound working for another user and after updating my user permissions the sound returned.


Glad to read its working now . :slight_smile:

Reading the 1st post and looking at the script output :

Its most interesting that the snd_usb_audio and snd_hda_intel kernel modules (for sound) loaded, but the applications aplay and amixer could not find the sound device. Ergo for other users when they have a problem, this ‘could’ (but not necessary) be a symptom of user permissions.

For my own edification, what did you do to fix the user permissions ? Did you add your user to group audio ?