Sound stopped working randomly

So, my sound (like the title says) stopped working randomly. I had it working fine previously with alsa. This morning I know it was working, but then now it is not.

The only change I can think of was a security update this afternoon… since then though I have remove/reinstalled alsa and updated it completely.

Anyone know of something I can check/do to help?

SDB:AudioTroubleshooting - openSUSE

If the audio troubleshooting guide SDB:AudioTroubleshooting - openSUSE does not work, then consider the following:

Do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot. In KDE your mixer is “kmix” (the small speaker in right hand corner). In Gnome your mixer is “alsamixer”.

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:

aplay -vv somefile.wav

With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole


Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a recommendation.

Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.

Thanks for the posts. I’ve been through the troubleshooting twiceover and no change. One thing to note is that during the speaker test, it goes through as if it’s working it just isn’t…

But here’s the URL and here’s the outputs

rpm -qa | grep alsa:


rpm -qa | grep pulse:


rpm -q libasound2:


uname -a:

Linux linux-2bp6 #1 SMP 2009-08-15 17:53:59 +0200 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/sound:

NXNs.1ziNQm07nt7:RV635 Audio device [Radeon HD 3600 Series]

alias snd-card-0 snd-hda-intel

Thanks for taking the time. I know you say don’t spend too much time on it, but I dislike asking for help on the forums often, especially with all the resources out there already… but I just can’t seem to do it.

One thing more - what should be listed/enabled in YaST > Sound? I’ve tried with one or both enabled (it has a generic HD audio controller [0] and the specific Radeon HD 3600 Series controller [1]) with no change. Also, when I run the command to list my audio devices in console (can’t remember the command atm) it doesn’t have my specific one at all.

Thanks again

Have you checked the mixer in the panel?

You need the correct settings there to match with Yast as well as the correct Master channel.

Thanks! We can fix this! I note a Dell Studio 1737 laptop. I have the 1537 which has the identical hardware audio codec, and the solution to fix the sound is the same for your laptop and my laptop.

OK, this is a problem. You have installed two drivers, which most the time will break your sound. This is likely the problem.

Please, can you HELP ME ? If the guide, which you state you followed, infers you should install alsa-driver-unstable-kmp-default- , … can you show me where? Because I want to fix the guide, and I find it frustrating that users keep making that mistake that you just made. DON’T INSTALL the unstable ! I want to understand where I WENT WRONG in writing the guide.

You need to remove alsa-driver-unstable-kmp-default- And you should then re-install alsa-driver-kmp-default- and some other alsa apps.

To do that, after removing alsa-driver-unstable-kmp-default, then with your pc connected to the internet, in a terminal with root permissions, re-install the alsa apps by just sending the following six zypper commands (and if told it is already install, just continue):

zypper ar multimedia
zypper install alsa alsa-utils alsa-tools alsa-firmware alsa-oss alsa-plugins alsa-plugins-pulse libasound2
zypper rr multimedia
zypper ar multimedia

zypper install alsa-driver-kmp-default
 zypper rr multimedia

then restart your pc and test the sound. Ensure you send all six commands. And move up to 95% volume levels for PCM, Master, and speaker. Do NOT forget to move up speaker

Thanks for your help in telling me where I went astray in the guide.

Thanks! This worked, and in retrospect was very obvious :-p

I just went through your guide again and I think that what happened is I used zypper remove alsa to remove it, and that didn’t remove both drivers so when I reinstalled they were both there. If not that, I don’t know what :frowning:

Again, I appreciate the help.

Great !!

I like the Dell Studio 1537 laptop that I have, which is very similar to your Dell Studio 1737, but has a smaller screen. I have tested everything thus far except for bluetooth, and all appears to be working. Someday I need to test the bluetooth.

It took me a while to figure out how to use the internal microphones. :slight_smile:

Hmmm … reading this again, I’m a bit puzzled. Do you mean you still have both alsa-driver-unstable-kmp-default and alsa-driver-kmp-default rpms installed and sound works? Or that was the state when sound did not work, and now that you have only the one driver, sound works. :slight_smile:

Anyway, one way to remove alsa-driver-unstable-kmp-default when installed is to just go to yast > software > software management, and remove it.

maybe your file is corrupted try to install new updated software.