Sound slowly fades out when connecting phones or speakers


That’s what happens. It’s trully weird. Hope you can give me a hand.

openSUSE 11.0 x64
Inspiron 1525
1,83 GHz Core 2 Duo
169 GB HD

Can you describe that a bit better? Sound from speakers are supposed to stop when you connect headphones. I presume you mean something else.

Can you provide information specific to your sound hardware/configuration?

To do that, with your PC connected to the internet, can you also run (copy and paste) the following two scripts in an xterm/konsole and post the URL that they provide:

wget -O && bash 

for the next script when prompted for a password enter your root password, and type “NO” for every question that you don’t undertand

su -c 'wget -O tsalsa wget && bash tsalsa' 

and paste here the URL that these scripts will provide.

Sorry I didn’t gave mor detail. When I connect the phones, the laptop speakers immediately turns off, and the sound goes to the phones. There’s when the phones sound starts to slowly fade out, until i can hear no sound, with all the KMIX levels up. At that moment,if I disconnect the phones the laptop speakers wouldn’t give me sound either. I’ve seen that if I disconnect the phone when the sound is fading out the laptop speakers work, but at the same volume the phones were working at the time of the disconnection.

ALSA information: general pastebin - rodrigo - post number 1070545

TSALSA info : tsalsa.txt - (beta)

I note the following

Amixer contents for card 0 [Intel] _____________________________________
amixer set ‘Master’,0 24% on
amixer set ‘Headphone’,0 100%,100% on
amixer set ‘Headphone as Line Out’,0 off
amixer set ‘PCM’,0 100% 100%
amixer set ‘Digital Input Source’,0 Items: ‘Analog Inputs’ Item0: ‘Analog Inputs’
Should your headphone line out be OFF?

In addition to those scripts, can you also provide the output of:
cat /etc/modprobe.d/sound

I want that, in case it is necessary to propose a change to that file.

Here it is

options snd slots=snd-hda-intel

u1Nb.VhUtPypIg0D:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel


Concerning to the phones output levels there’s a screenshot.

Amarok is playing music but I cant hear anything in the laptop speakers nor the phones.

OK, thanks. Your Dell Inspiron 1525 is a bit of a tough nut to crack because it is fairly new, and its hardware audio codec conexant 2c06 is not well documented and possibly not well supported.

I noted a Ubuntu user had to get a Dell/Ubuntu specific built “backport” package from Dell to get full functionality:
Running Ubuntu 7.10 (Gutsy Gibbon) on a Dell Inspiron 1525 | Welcome at nain
I would avoid that approach for now.

I noted an openSUSE-10.3 user obtained partial functionality by using (custom compiling) very cutting edge tarballs from openSUSE alsa developer tiwai:
GNU/Linux on a Dell Inspiron 1525 -
… thats another approach that is viable, but best not followed just yet.

Instead, I recommend you edit your /etc/modprobe.d/sound file with this:

options snd slots=snd-hda-intel
# u1Nb.VhUtPypIg0D:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel auto 

and restart your alsa with rcalsasound restart and test your audio. Does that help?

If that doesn’t work, in the /etc/modprobe.d/sound file replace “auto” with “3stack”. Restart your alsa with rcalsasound restart and test your audio. Does that help?

If that doesn’t work, then you could update your alsa to the latest rpms. But I am not confident of that approach, as there is no mention in the alsa web site of any update to the conexant alsa driver since 1.0.16. Anyway, you can update alsa by copying and pasting and executing the following from an xterm/konsole with root permissions, one line at a time:

zypper ar multimedia
zypper install alsa alsa-utils alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

Note - if any of the above fail, jump to the last command (removing the repos) and stop.

Then restart your pc and test your audio. And again try the different model options in your /etc/modprobe.d/sound file

And finally if that doesn’t work, you could try a custom compile of the cutting edge tarballs mentioned here:
GNU/Linux on a Dell Inspiron 1525 -
where the tarballs are here:
Index of /pub/linux/kernel/people/tiwai/snapshot
If you go that route, you are very much on your own as to which tarball you select and build. I have no knowledge of that site.

I was reading the openSUSE-10.3 user’s post, and he claims his Dell Inspiron 1525 has a stac9228. I am thinking yours does not. … Hence that may not work. But if by chance it IS a stac9228 that has been inappropriately identified, then in addition to trying the model options “auto” and “3stack”, you could also try “5stack” and “dell-3stack” as those are valid stac9228 options. Don’t forget to retart alsa after each attempt.

Good Luck.

From ALSA-Configuration.txt file:

	  ref		Reference board
	  3stack	D965 3stack
	  5stack	D965 5stack + SPDIF
	  dell-3stack	Dell Dimension E520 

Your conexant 2c06 on a Dell was reminding me of something I could not remember/place, … so I did a search and found a post in the archives where a user applied the “dell-3stack” model option to their /etc/modprobe.d/sound file and it worked:
Dell Vostro1400 ; Hda Intel; … No Sound - openSUSE Forums

So definitely give that some consideration.

Dear friends it finally worked!!!1

The line had to be “options snd-hda-intel **model=**3stack”. When trying without the “model=” sound wont work at all.

Thank you so much for your help. This thing of having my laptop fully working with linux has got me thrilled.

Thanks a million.

Great! Congratulations.

Thank you for sharing your solution.