Sound Randomness with ALC889 on Gigabyte 890fxa

Evening Forums,

I just installed a fresh 64 bit opensuse and my sound is one mystery. I try to get my sound working over the toslink, if possible 5.1. I have an ALC 889 Chip on the gigabyte 890fxa board.
I chose various models in the alsa config tab of the installer. But nothing really worked to get a test sound.
(I tried to make it work before on a Livecd, but nothing really worked, though a week ago on a test install of Ubuntu i had at least stereo sound, but after a while it went mute.)
Then I completed the install, leaving model on “auto”. I logged in using gnome, went into audio config, tried the test sound, it worked. I opened pavucontrol and it magically stopped working without changing any setting.
Then after I thought that gnome in default skin is really ugly, I relogged into KDE. Tried again to get the test sound, worked. Then I started Amarok and played a music file, worked… for 2 minutes, then silence.
The driver works, but somewhere near pulseaudio and the speaker config appears to lie the problem.
For my experience: I am fairly new to the linux world, I understand config files but not know enough of the general substructure of the system and the related commands to find what I am searching for.
Can you help me?

Typically its one’s newness to this that causes problems, as GNU/Linux sound is not always very straight forward (and its VERY VERY different from Macs and also from MS-Windows).

When you had Amarok playing sound which sound engine was it using ? Dependant on the sound engine you had configured its possible Amarok was not setup to share the sound device.

Were you surfing at the same time with a browser, and maybe a page that you opened started to use the sound device ? Dependant on what you had setup in KDE (phonon) it may not have been setup to share the sound device. Trying to run the two apps at the same time not configured to share the sound device could cause audio to stop.

Audio transitioned SIGNIFICANTLY in openSUSE between openSUSE-10.x and 11.x and now 12.x . It also changed a lot in KDE between KDE-3.x or KDE-4.x. So without knowing more detail, I won’t venture any more … although given you mentioned using pavucontrol in gnome suggests your openSUSE could be version 11.1, or 11.2, or 11.3 or 11.4 . But even there that’s too big a difference to venture a guess as to what this is about.

or to put this more short … please, what openSUSE version ? what desktop versions ? and what were you doing on the PC when Amarok stopped playing ?

uum sorry forgot that, its 11.4 updated with default update sources
I did only have Amarok open, no firefox, no hickup login sound (as that worked)

EDIT: After a reboot it works again, but I think just when I open another config its dying again.

^ Cant edit ^
Ok now I have Phonon open and found the working setting “Analog Stereo Duplex”, but when I change it I cant change it back until the system is restarted.

…after trying back and forth with 3 restarts it works even with multiple players in the background… hell

now ive got to know why and how I get 5.1

If we assume that the alsa sound driver is automatically configured properly, then simply configure for 5.1 surround sound with pulse audio volume control (pavucontrol) , where this was not a nominal option for openSUSE’s KDE prior to verson 11.4. For example from my PC at home which has 5.1 this is my selection in the pavucontrol ‘configuration’ tab (note your setting my be different):](

… and I chose that from these possible selections:](

and this is what I see in the ‘output’ (note be sure to select SHOW all output devices) :](

and this is what I see in the ‘input’ (note be sure to select SHOW all input devices) :](

and when playing sound from an application go to the PLAYBACK tab and be sure to select SHOW all streams, and select the 5.1 device (for cases where one might have more than one audio device on the PC).

How do I do it over toslink output?

… are you using a translator ? What is ‘toslink’ ??