Sound quality problem.

Hi! :slight_smile:

I have problem with the sound quality.
Sound quality is very poor and sound volume is very low. :eek:

My (onboard) sound card is a Realtek one.
I tried (with video (eg. avi, mpeg atc.) and audio files (eg. mp3, flac etc.)) the media players that comes with KDE 3 and also I installed and tried VideoLAN media player.
I setup sound with KDE Mixer.

As I said, the sound is very worst that Windows.
I tried also some other KDE 3 (live CD) distributions (eg. Kubuntu), with exactly the same programs and Mixer’s settings, and with all of them, sound quality was very high (and by far superior than Windows).

Any ideas what’s going wrong? :confused:
A driver problem maybe?

Most likely a mixer problem. Go to YAST > HARDWARE > SOUND and move your volume up there. Then move it lower in your mixer and your apps.

If that doesn’t work, we need more information about your hardware/software sound configuration. You can provide that by opening a konsole, and with your PC connected to the internet copy and paste the following diagnostic script:

wget && su -c 'bash ./tsalsa' 

when prompted for a password, enter your root password. Try to accurately provide the # of jacks/plugs when asked … for example my pc has 3 i/o plugs/jacks. That diagnostic script will give you a URL when it is complete. Post the URL here.

Also, please provide the output of the following in a konsole:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

you may need to install wget for that script to run (if not already installed). To do so, simply paste into a konsole:
su -c 'zypper install wget’

THANKS oldcpu for your help!!! :slight_smile:

Here it is:
tsalsa.txt - (beta)

Here’s the output:

giorgos@linux-h2pi:~> rpm -qa | grep alsa
giorgos@linux-h2pi:~> rpm -qa | grep pulse
giorgos@linux-h2pi:~> rpm -q libasound2
giorgos@linux-h2pi:~> uname -a
Linux linux-h2pi #1 SMP 2008-07-13 20:48:28 +0200 i686 i686 i386 GNU/Linux
giorgos@linux-h2pi:~> cat /etc/modprobe.d/sound

options snd slots=snd-intel8x0
# 1sCg.KncXPNvlx99:AC'97 Sound Controller
alias snd-card-0 snd-intel8x0

For testing your sound, I recommend you copy and paste the following into a konsole:
speaker-test -Dplug:front -c2 -l5 -twav

Thanks for the script output. It shows a 32-bit openSUSE-11 with the latest (for openSUSE-11) kernel (pae) with a hardware audio codec Silicon Integrated Systems [SiS] S17012 with an ALC200.

I did a search on the alsa site, and I see no updates for this audio codec.

I recommend you alsa install alsa-firmware and alsa-tools. Then reboot and test your sound again. And if that doesn’t work, leave those apps installed, and move on to the following …

This looks like an /etc/modprobe.d/sound file created by alsaconf. Try YAST > HARDWARE > SOUND > VOLUME and check the slider bar there. Move it far to the right. Test your sound.

Also, please check again your mixer.

Amixer contents for card 0 [SI7012] _____________________________________        
amixer set 'Master',0 100%,100% on        
amixer set 'Master Mono',0 100% on        
amixer set 'Headphone',0 100%,100% on        
amixer set '3D Control - Center',0 Mono: 0 0%        
amixer set '3D Control - Depth',0 Mono: 0 0%        
amixer set '3D Control - Switch',0 off        
amixer set 'PCM',0 68%,68% on        
amixer set 'Line',0 0% off 0% off Capture off        
amixer set 'CD',0 68%,68% on Capture off        
amixer set 'Mic',0 0% off Capture on        
amixer set 'Mic Boost (+20dB)',0 off        
amixer set 'Mic Select',0 Items: 'Mic1' 'Mic2' Item0: 'Mic1'        
amixer set 'Video',0 0% off 0% off Capture off        
amixer set 'Phone',0 0% off Capture off        
amixer set 'IEC958',0 on        
amixer set 'IEC958 Playback AC97-SPSA',0 Mono: 1 33%        
amixer set 'PC Speaker',0 53% off        
amixer set 'Aux',0 0% off 0% off Capture off        
amixer set 'Mono Output Select',0 Items: 'Mix' 'Mic' Item0: 'Mix'        
amixer set 'Capture',0 Capture 0 0%,Capture 0 0% on        
amixer set 'Mix',0 Capture off        
amixer set 'Mix Mono',0 Capture off        
amixer set 'External Amplifier',0 on  

Note PCM affects the analog sound levels.

Also, you have IEC958 ON, but only at 33%. Are you using digital audio? and if so, what happens if you move that up to a higher level? You could also try switch digital audio OFF (ie IEC958 OFF).

You could also try switching your external amp OFF.

THANKS oldcpu!!! :wink:

I’ll check them again!

My mistake. This looks like a file created by YaST. Still, it doesn’t hurt to test this again.

OK! I’ll do it! :slight_smile: