Sound Problems

Hi there !

I installed opensuse 11 to get this fantastic sax 2 options cause us using two tfts and stuff.

But i have an Problem wich in cant solve: my sound is the baddest ive ever heard.
It sounds like there is an microphone installed, but there is none.
Sometimes i cant hear the singing voices, its just the music and the music sounds like played through an drier.

I dont check this strange Pulse audio stuff - whats that ?
I just want to listen mp3 via xmms and sometimes youtube, thats all.
Is there a possibillity to uninstall this crap ? :smiley:

Does anyone know whats the problem with the sound ?
I had *buntu installed bevor suse, sound works fine.

Greetings and Thanks for your help.

Check this
SDB:AudioTroubleshooting - openSUSE

Thanks, but it does`nt help in any way.

The sound still glitches like hell and its too quiet, i think im gonna get *buntu back.

If you are happy with Ubuntu, then my view is stick with it. I have friend’s who like Ubuntu, and they are happy.

Having stated that, if this works in Ubuntu, it most likely also works in openSUSE, and it should be fixable. I myself do not like Ubuntu. But to help you fix this, more information is needed, and that will take time, and that will take patience on your part. If you don’t have that, then by all means go back to Ubuntu. Linux is Linux, and far be it from me to discourage a Linux user from enjoying another distribution. I don’t want to waste your time, and I do not want you wasting my time.

If you do decide to troubleshoot this further, then to provide more information, with your PC connected to the internet copy and paste the following into a gnome-terminal or konsole:

wget -O && bash 

When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal or konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound
cat /proc/interrupts

Also, what hardware do you have? Is this a laptop? If so it may have an integrated mic that you failed to mute and that could explain your problem.

rpm -qa | grep alsa

rpm -qa | grep pulse

rpm -q libasound2

uname -a
Linux linux-yj7h.webde.local #1 SMP 2008-10-21 16:30:26 +0200 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel

u1Nb.138KtM2m6f7:OptiPlex 745

alias snd-card-0 snd-hda-intel

cat /proc/interrupts
0: 240 0 IO-APIC-edge timer
1: 2 0 IO-APIC-edge i8042
4: 6 0 IO-APIC-edge
6: 5 0 IO-APIC-edge floppy
7: 0 0 IO-APIC-edge parport0
8: 1 0 IO-APIC-edge rtc0
9: 0 0 IO-APIC-fasteoi acpi
12: 4 0 IO-APIC-edge i8042
16: 717063 0 IO-APIC-fasteoi uhci_hcd:usb1, HDA Intel, i915@pci:0000:00:02.0
17: 375063 0 IO-APIC-fasteoi uhci_hcd:usb2, uhci_hcd:usb4
18: 14381 0 IO-APIC-fasteoi uhci_hcd:usb5
20: 208790 0 IO-APIC-fasteoi ata_piix, ata_piix
22: 0 0 IO-APIC-fasteoi ehci_hcd:usb6
23: 3 0 IO-APIC-fasteoi uhci_hcd:usb3, ehci_hcd:usb7
221: 955875 0 PCI-MSI-edge eth0
NMI: 0 0 Non-maskable interrupts
LOC: 5572686 5739362 Local timer interrupts
RES: 371665 419264 Rescheduling interrupts
CAL: 30381 364 function call interrupts
TLB: 15798 16827 TLB shootdowns
TRM: 0 0 Thermal event interrupts
SPU: 0 0 Spurious interrupts
ERR: 0
MIS: 0

Thats it.

PC is a Dell Optiplex 745, hope this helps.

I love suse too, but i always had more problems with it then with Ubuntu or Debian.

Also, is your graphics a PCI card? If so, can you move it to a different slot?

Cant move it cause of Dells service quaranty and its an company
PC, the admins will kill me if i open the case.
The GFX “card” is onboard, but there is this new TFT “slot” too and this seems to be an “single” card. (internal connected to onboard GFX i guess)
I have two TFTs running on this PC.
That means, i cant move anything.

(sound ist onboard too)(did i said that i hate Dell PCs ?)

I see that i now posted two (Thread) times in here, sorry for that. Im going crazy to get this to work.

Sorry again for my bad english.


I note your volume controls are WAY TOO HIGH !!

Simple mixer control ‘Master’,0
Mono: Playback 63 [100%] [0.00dB] [on]
Simple mixer control ‘Headphone’,0
Front Left: Playback 63 [100%] [3.00dB] [on]
Front Right: Playback 63 [100%] [3.00dB] [on]
Simple mixer control ‘PCM’,0
Front Left: Playback 30 [97%] [10.50dB] [on]
Front Right: Playback 30 [97%] [10.50dB] [on]

Back off to about 65% to 70%, to remove the distortion.

I reinstalled the stuff you told me in other thread, now my PC is completely silent. Xmms or Youtube - no sound.

I give up.

Thanks for your help.

The Analog Devices AD1983 should work with openSUSE. I still believe this is a configuration problem.

There are many things we did not try, but if you feel giving up is the approach to take, then I hope it works for you on another distribution (if that is your intention). I have friends who use both Ubuntu and fedora, and they like their distributions.

Still, if you think there is something wrong with the openSUSE distribution, then the IMHO the most helpful thing to do is to write a bug report on openSUSE. Submitting Bug Reports - openSUSE