sound problems with asus x56v

Hi,

the problem with my new notebook is that it doesn’t make those annoying sounds I love to play in overcrowed trains :wink:

What I figured out:

notebook:/ # cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xfdef8000 irq 22
1 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0xfdfec000 irq 17
notebook:/ # head -n 1 /proc/asound/card0/codec*
==> /proc/asound/card0/codec#0 <==
Codec: Realtek ID 663

==> /proc/asound/card0/codec#1 <==
Codec: Motorola Si3054

So I have a Intel ICH9 chipset and a HDMI outlet via my grafic adapter. The problem is that the codec isn’t listed in

/usr/src/linux-2.6.25.18-0.2/Documentation/sound/alsa/ALSA-Configuration.txt

Anyone who has an idea to get the sound working? Any settings?

Thanks

Erik

Is this an ALC663 ?

I would like to double check this …

Can you run a script and some commands for me to provide more information? With your PC connected to the internet copy and paste the following into a gnome-terminal or konsole:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh 

When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal or konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Also to test if your sound is working, I recommend you try copy and pasting the following into a gnome-terminal or a kde konsole:speaker-test -Dplug:front -c2 -l5 -twavyou should hear a lady’s voice saying “front-left”, “front-right” five times. Note Linux is case sensitive.

If that does not work, try a shorter form version:speaker-test -c2 -l5 -twavIf you hear sound (ie if you hear the lady’s voice), then please post here, let us know this fact, and explain more as to what your sound problem might be.

Hi,

Good question. :wink: I don’t know cause the manual is sooooo poor. I’m missing old manual style where the producers gave tech infos.

Perhaps the result of lspci -vv helps to identify it:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
Subsystem: ASUSTeK Computer Inc. Device 1878
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 32 bytes
Interrupt: pin A routed to IRQ 22
Region 0: Memory at fdef8000 (64-bit, non-prefetchable)
Capabilities: [50] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Address: 0000000000000000 Data: 0000
Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
ExtTag- RBE- FLReset+
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
MaxPayload 128 bytes, MaxReadReq 128 bytes
DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
ClockPM- Suprise- LLActRep- BwNot-
LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

Your ALSA information is located at http://www.alsa-project.org/db/?f=6be26ceb62b7091c0475635732eb9c4db4b30a6e

That’s a nice thing. :slight_smile:

erik@notebook:~> rpm -qa | grep alsa
alsa-oss-1.0.15-48.1
alsa-tools-1.0.16-47.1
alsa-firmware-1.0.16-24.1
alsa-utils-1.0.16-35.1
kalsatools-1.5.0-544.1
alsa-oss-32bit-1.0.15-48.1
alsa-1.0.16-39.1
alsa-plugins-32bit-1.0.16-57.1
alsamixergui-0.9.0rc1-705.1
alsa-docs-1.0.16-39.1
alsa-plugins-1.0.16-57.1
alsa-tools-gui-1.0.16-47.1

erik@notebook:~> rpm -qa | grep pulse
[empty line]
This is the network sound server, isn’t it? If it is so I think I don’t need it. I don’t share sound via network.

erik@notebook:~> rpm -q libasound2
libasound2-1.0.16-39.1

erik@notebook:~> uname -a
Linux notebook 2.6.25.18-0.2-default #1 SMP 2008-10-21 16:30:26 +0200 x86_64 x86_64 x86_64 GNU/Linux

erik@notebook:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel,snd-hda-intel

u1Nb.6JJNKMD7VIC:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

NXNs.3ADRSxPtexE:RV635 Audio device [Radeon HD 3600 Series]

alias snd-card-1 snd-hda-intel

That’s my ATI Radeon 3600 grafic adapter which has a HDMI slot. I deleted it with Yast and also with vi without result.

The empty line a the beginning of the file was not added by me. I deleted it once but didn’t hep. Also I did some experimental stuff with the model settings but none was helpful.

erik@notebook:~> speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.16

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 32 to 8192
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
0 - Front Left
1 - Front Right
Time per period = 2,732218
0 - Front Left
1 - Front Right
Time per period = 2,986697
0 - Front Left
1 - Front Right
Time per period = 2,986623
0 - Front Left
1 - Front Right
Time per period = 3,071799
0 - Front Left
1 - Front Right
Time per period = 2,986672

I heard nothing.

erik@notebook:~> speaker-test -c2 -l5 -twav

speaker-test 1.0.16

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 8192
Period size range from 1024 to 1024
Using max buffer size 8192
Periods = 4
was set period_size = 1024
was set buffer_size = 8192
0 - Front Left
1 - Front Right
Time per period = 2,856661
0 - Front Left
1 - Front Right
Time per period = 3,007921
0 - Front Left
1 - Front Right
Time per period = 3,008067
0 - Front Left
1 - Front Right
Time per period = 3,007951
0 - Front Left
1 - Front Right
Time per period = 3,007968

Also sound of silence. :wink:

Thanx for your help

Erik[/size]

Thanks that script output is useful. I am surprised you had no errors with the speaker-test, but still had no sound. That often suggests a mixer problem. Lets investigate that possibility.

I note this in your mixer:

!!-------Mixer controls for card 0 [Intel]

Card hw:0 'Intel'/'HDA Intel at 0xfdef8000 irq 22'
  Mixer name	: 'Realtek ID 663'
  Components	: 'HDA:10ec0663 HDA:10573055'
Simple mixer control 'Master',0
  Front Left: Playback 44 [69%] -20.00dB]
  Front Right: Playback 44 [69%] -20.00dB]
Simple mixer control 'PCM',0
  Front Left: Playback 0 [0%] -51.00dB]
  Front Right: Playback 0 [0%] -51.00dB] 

Your sound is muted by your PCM. Move PCM up to 95% for a test (and then back off to 70% or so to avoid distortion).

If moving PCM up in volume does not work, then I have 1/2 dozen zypper commands I can pass to you to update your alsa for better ALC663 compatibility (although I do not know if a Realtek ID 663 is the same as an ALC663).

Let me know how the mixer tuning works out so I that I know if I should pass the update commands.

Hi oldcpu,

Hmmm, I did it again. The first thing I checked was the
mixer. I’m using ALSA Mixer with the GUI under KDE 3.5. It says: Card HDA Intel and Chip Realtek 663. Should I try it again with the console?

So please pass the update commands. :slight_smile: Thanks.

Bye

Erik

OK, I note you are using openSUSE-11.0, with a 64-bit kernel: 2.6.25.18-0.2-default. Hence according to this page: Alsa-update - openSUSE you need to open a gnome-terminal or a konsole, type “su” to get root permissions (no quotes) and then with your PC connected to the internet, send the following 6 zypper commands in sequence, one after the other:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/ multimedia 
zypper install alsa alsa-oss alsa-oss-32bit alsa-plugins alsa-plugins-32bit alsa-utils alsa-tools alsa-tools-gui alsa-firmware alsa-docs libasound2
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.0_Update/ multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

then restart your PC and test your audio with the speaker-test that I recommended previous. Be certain to check your mixer.

If that does not work, then leave the updated alsa in place, and we can start looking at adding ALC663 specific changes to your /etc/modprobe.d/sound file.

Done but worse. Now the sound test hangs:

erik@notebook:~> speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.18

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 32 to 8192
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
0 - Front Left
^C

Well, I just started to download 11.1 hoping things become better. :wink:

[edit]
omg, 21kb/s Seems I’m not the only one who wants that file. :wink:
[/edit]

That hangs on my PC too, but my sound works. And that is why I also suggest:
speaker-test -c2 -l5 -twavThat works on my PC, and I know I recommended this if the first speaker-test does not work, and I looked in your recent post, and I can see no evidence you even tried that second test in your recent post, after the alsa update (apologies if I missed it).

The alsa that comes with 11.1 is newer than 1.0.18a (it has some custom openSUSE “tweaks” ). But still, we not even tried any model options, of which there are many for an ALC663 for an asus with 1.0.18a of alsa (from the ALSA-Configuration.txt file for 1.0.18a):

	ALC662/663
	  3stack-dig	3-stack (2-channel) with SPDIF
	  3stack-6ch	 3-stack (6-channel)
	  3stack-6ch-dig 3-stack (6-channel) with SPDIF
	  6stack-dig	 6-stack with SPDIF
	  lenovo-101e	 Lenovo laptop
	  eeepc-p701	ASUS Eeepc P701
	  eeepc-ep20	ASUS Eeepc EP20
	  ecs		ECS/Foxconn mobo
	  m51va		ASUS M51VA
	  g71v		ASUS G71V
	  h13		ASUS H13
	  g50v		ASUS G50V
	  asus-mode1	ASUS
	  asus-mode2	ASUS
	  asus-mode3	ASUS
	  asus-mode4	ASUS
	  asus-mode5	ASUS
	  asus-mode6	ASUS
	  auto		auto-config reading BIOS (default) 

So what is your plan? Stop support for this now with 11.0 ?

Hi oldcpu,

oic

I don’t remember if I did so. I think I didn’t after the first test failed. The second one runs fine first without sound.

Well, I had to update to solve problems with my Intel Wifi 5100 adapter which now works fine. Sound is also working now. I added to /etc/modprobe.d/sounds:


options snd-hda-intel model=asus-mode1

After restarting the alsasound I heard her saying left from left speaker and right from the right one. I love such problems making me learning more about Linux internals even more when they don’t appear on my clients machines. :wink:

Thank you very much for your very good support! That’s to make a FAQ of it. I read so many bad hints to solve the problem.

Greetings

Erik

Congratulations on sorting this. I also had to use 11.1 (with the 2.6.27 kernel) for the wireless on my new dell laptop (Intel WiFi Link 5300).

Also, well done in finding the correct code out of the ALSA-Configuration.txt file that works with your asus x56v.

Sorry that we had to beat around the bush a bit to find a solution. I try to tackle these things logically, but as luck would have it, often its the last thing that one suggests that finally works.

Hi oldcpu,

I was soooooo happy to read that it was detected correctly after updating to 11.1 after spending so many time to make it run. :wink:

That’s ok.

So do I. Analyzing the probs from button to top normally is the real successful way. I’m an admin and it trainer especially for networks. I’ve seen so many ppl wasting time searching a problem which I solved by just plug the cable in correctly. lol

Well, now the sound seems to work but I still don’t get system sounds. I normally switch the most of them off but I want them to appear first. :wink:

You were so kind. Would you like to have a look at the other thread I started (Fn-Keys problem)? I’m really lost with that. I don’t even know how to search this with google.

bye

Erik