Sound problems w/ hp dv4 again

Hi, I can’t seem to get my sound to work in openSUSE 11.1 64-bit. I had this problem before when I had 32-bit and was able to solve it with help from oldcpu, but can’t seem to get it to work. Any help would be much appreciated. Here is the output for everything:

/usr/sbin/alsa-info.sh
http://www.alsa-project.org/db/?f=e48e3bc1405241382b655f5ad39c8a1d17f550fc

rpm -qa|grep alsa
alsa-utils-1.0.18-6.4
alsa-driver-kmp-default-1.0.20.20090522_2.6.27.21_0.1-2.1
alsa-oss-1.0.17-1.43
alsa-plugins-1.0.18-6.13
alsa-tools-1.0.18-1.16
alsa-plugins-pulse-1.0.18-6.13
alsa-firmware-1.0.17-1.42
alsa-1.0.18-8.9

rpm -qa | grep pulse
libpulse0-0.9.12-9.5
libpulse-browse0-0.9.12-9.5
pulseaudio-utils-0.9.12-9.5
pulseaudio-module-x11-0.9.12-9.5
pulseaudio-module-lirc-0.9.12-9.5
pulseaudio-esound-compat-0.9.12-9.5
libpulse-mainloop-glib0-0.9.12-9.5
pulseaudio-0.9.12-9.5
pulseaudio-module-zeroconf-0.9.12-9.5
alsa-plugins-pulse-1.0.18-6.13
pulseaudio-module-jack-0.9.12-9.5
libpulsecore4-0.9.12-9.5
libxine1-pulse-1.1.15-20.8
pulseaudio-module-bluetooth-0.9.12-9.5

rpm -q libasound2
libasound2-1.0.18-8.9

uname -a
Linux linux-sflc 2.6.27.21-0.1-default #1 SMP 2009-03-31 14:50:44 +0200 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/sound
options snd-hda-intel model=hp-m4,
options snd slots=snd-hda-intel,snd-hda-intel

5Dex.oB+Yu+RuhF7:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel

l4dC.vfAxXUx5zd4:RS780 Azalia controller

alias snd-card-1 snd-hda-intel

The first thing that strikes me here is your PC has a mix of 1.0.18 and 1.0.20 rpms that could cause problems. I also do not see some apps I expected such as alsa-oss-32bit and alsa-plugins-32bit and alsa-plugins-pulse-32bit. I’m a bit surprised they were not installed by default. But I confess I am pretty new to 64-bit alsa.

I note this from the diagnostic script output:

!!ALSA Version
!!------------

Driver version:     1.0.20-git20090522
Library version:    
Utilities version:  1.0.18

I recommend you sort that mismatch, and once that is sorted, we can look in more detail. To sort that, please send the following six zypper commands. Its possible you will be told the apps are already installed. If so, just carry on and still send all six.

Do that by opening a konsole and type “su” to get root permissions (enter root password). Then with your PC connected to the internet, copy and paste and execute, in sequence, the following six zypper commands:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.1/ multimedia
zypper install alsa-utils alsa-tools alsa-plugins alsa-plugins-32bit alsa-plugins-pulse alsa-plugins-pulse-32bit alsa-oss alsa-oss-32bit alsa-firmware
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/ multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

then reboot, and test your sound. Pay careful attention to your mixer. Note that you may need to move PCM and Master up to 90% or so to get volume, as the volume scale may not be linear.

Edit - I’m kind of hoping that works. It takes time to type the above … and today I am struggling with a mild fever and not “firing on all 4 cylinders” :slight_smile:

Sorry you are not feeling well. I appreciate your help. I ran each of the scripts. After reboot, still no sound. Here is the output for:
rpm -qa|grep alsa
alsa-plugins-1.0.20-4.4
alsa-firmware-1.0.20-5.1
alsa-oss-32bit-1.0.17-1.37
alsa-utils-1.0.20-5.1
alsa-driver-kmp-default-1.0.20.20090523_2.6.27.21_0.1-1.1
alsa-plugins-32bit-1.0.20-4.4
alsa-tools-1.0.20-4.3
alsa-plugins-pulse-1.0.20-4.4
alsa-1.0.18-8.9
alsa-oss-1.0.17-2.6
alsa-plugins-pulse-32bit-1.0.20-4.4

and for:
/usr/sbin/alsa-info.sh
!!ALSA Version
!!------------

Driver version: 1.0.20-git20090523
Library version:
Utilities version: 1.0.20

Thanks, but can you give the output URL of running the script? Just the URL.

Can you also, after a fresh reboot, give the output of running:

dmesg > dmesg.txt && curl -F file=@dmesg.txt nopaste.com/a

Thanks for all of your help. Here are the outputs.

dmesg > dmesg.txt && curl -F file=@dmesg.txt nopaste.com/a
dmesg.txt - nopaste.com (beta)

/usr/sbin/alsa-info.sh
http://www.alsa-project.org/db/?f=40561f2361bfb12ea610964c778334c138be83de

From what I can see, your sound should be working.

I took a look at the dmesg, and there is nothing there that I know enough about to say its a blocking problem. I noted a problem with pcspkr

Error: Driver 'pcspkr' is already registered, aborting...
HDA Intel 0000:00:14.2: PCI INT A -> GSI 16 (level, low) -> IRQ 16
HDA Intel 0000:00:14.2: setting latency timer to 64
ALSA /usr/src/packages/BUILD/alsa-driver/pci/hda/../../alsa-kernel/pci/hda/hda_codec.c:3025: hda_codec: model 'hp-m4' is selected
ALSA /usr/src/packages/BUILD/alsa-driver/pci/hda/../../alsa-kernel/pci/hda/hda_codec.c:3845: autoconfig: line_outs=1 (0xa/0x0/0x0/0x0/0x0)
ALSA /usr/src/packages/BUILD/alsa-driver/pci/hda/../../alsa-kernel/pci/hda/hda_codec.c:3849:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA /usr/src/packages/BUILD/alsa-driver/pci/hda/../../alsa-kernel/pci/hda/hda_codec.c:3853:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA /usr/src/packages/BUILD/alsa-driver/pci/hda/../../alsa-kernel/pci/hda/hda_codec.c:3854:    mono: mono_out=0x0
ALSA /usr/src/packages/BUILD/alsa-driver/pci/hda/../../alsa-kernel/pci/hda/hda_codec.c:3865:    inputs: mic=0xb, fmic=0x0, line=0xe, fline=0x0, cd=0x0, aux=0x0
ALSA /usr/src/packages/BUILD/alsa-driver/pci/hda/../../alsa-kernel/pci/hda/patch_sigmatel.c:3098: stac92xx: dac_nids=1 (0x10/0x0/0x0/0x0/0x0)
input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:14.2/input/input11
input: HDA ATI SB Line In at Ext Rear Jack as /devices/pci0000:00/0000:00:14.2/input/input12
input: HDA ATI SB Mic at Ext Front Jack as /devices/pci0000:00/0000:00:14.2/input/input13
input: HDA ATI SB HP Out at Ext Front Jack as /devices/pci0000:00/0000:00:14.2/input/input14
vendor=103c device=9602
HDA Intel 0000:01:05.1: PCI INT B -> GSI 19 (level, low) -> IRQ 19
HDA Intel 0000:01:05.1: setting latency timer to 64

I note this for your /etc/modprobe.d/sound file:

options snd-hda-intel model=hp-m4**,**
options snd slots=snd-hda-intel,snd-hda-intel

5Dex.oB+Yu+RuhF7:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel

l4dC.vfAxXUx5zd4:RS780 Azalia controller

alias snd-card-1 snd-hda-intel

I see a syntax error in your /etc/modprobe.d/sound file. You have a comma after “model=hp-m4”. There should NOT be a comma. REMOVE that comma!! Restart your PC. Test your sound. I do not know if that makes a difference, but maybe it does.

Also, try a couple of other things. … test your sound with root permissions with each of the 3 speaker tests from the troubleshooting guide (ie the 2 in the guide and the one from the alsa web site):
SDB:AudioTroubleshooting - openSUSE

Also, after booting, in the remote chance this " Driver ‘pcspkr’ " error caused a problem, restart your alsa with su -c ‘rcalsasound restart’ enter root password when prompted start your mixer and test your sound.

Also try the traditional YaST > Hardware > Sound > Other > Volume to confirm settings there are ok (ie volume up to 95% for testing). Exit YaST. Check mixer.

You could also try putting “enable_msi=1” in your /etc/modprobe.d/sound file. I’ve read of some users who have applied " hp-m4 " using that. You can do that, by changing your /etc/modprobe.d/sound file to:

options snd-hda-intel model=hp-m4 enable_msi=1
options snd slots=snd-hda-intel,snd-hda-intel
# 5Dex.oB+Yu+RuhF7:SBx00 Azalia (Intel HDA)
alias snd-card-0 snd-hda-intel
# l4dC.vfAxXUx5zd4:RS780 Azalia controller
alias snd-card-1 snd-hda-intel

then restart your alsa sound driver with su -c ‘rcalsasound restart’ enter root password when prompted start your mixer and test.

If the above does not work, you are into bug reporting territory:
Submitting Bug Reports - openSUSE Ensure you select component “sound” when entering the bug report. That will get the attention of the SuSE-GmbH / alsa developer. If anyone can solve this, he can.

oldcpu adjusted his/her AFDB on Sunday 24 May 2009 08:36 to write:

Sorry to butt in here, just thought I would add that I have an Azalia
onboard card here on a Gigabyte mobo.

i had quite a bit of hassle to get it working to my liking, I updated all
the alsa as per oldcpu`s instructions and still had pulse crashes and other
peobs.

Now being from the old, old school and not bothered if I prew the scooch I
uninstalled all pulse jobbies, made sure anything pulse related was disabled
especially in the desktop config, multimedia and edited by hand my
modprobe.d/sound to:

options snd slots=snd-hda-intel

5Dex.9zCmC9gVD38:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel

i now have 7.1 which works fine, albeit my lfe and centre are one the same
channel because of my speaker amp setup.

I did try a few of the extra options when I had pulse but that just seemed
to confuse things even more. ( “enable_msi=1”…etc…)

I have got an ATI card in here but I did not configure the ATIHD so that it
does not get loaded and mess with the normal sound.

I realise you have a probably customised version “hp-4” just wondered if you
drop to all defaults with just the one card configured you get any different
results?

HTH

YMMV

and all other disclaimers :wink:


Mark

Nullus in verba
Nil illegitimi carborundum

Which hardware audio codec does your Azalia onboard card on the Gigabyte motherboard have?

These audio setups are typically highly dependent on the precise hardware audio codec.

oldcpu adjusted his/her AFDB on Sunday 24 May 2009 15:56 to write:

>
> baskitcaise;1990742 Wrote:
>> Sorry to butt in here, just thought I would add that I have an Azalia
>> onboard card here on a Gigabyte mobo.
> Which hardware audio codec does your Azalia onboard card on the
> Gigabyte motherboard have?
>
> These audio setups are typically highly dependent on the precise
> hardware audio codec.
>
>

Ummm… `tis Sunday and my brain on holiday.

I knew you were going to ask something teknikal like dat.

Will have to find the specs… brb when the cricket finishes, should not be
too long now :slight_smile:


Mark

Nullus in verba
Nil illegitimi carborundum

baskitcaise adjusted his/her AFDB on Sunday 24 May 2009 16:48 to write:

> Ummm… `tis Sunday and my brain on holiday.
>
> I knew you were going to ask something teknikal like dat.
>
> Will have to find the specs… brb when the cricket finishes, should not
> be too long now :slight_smile:
>
>
>

see told ya it would not be long,what a boring game.

Codecs for my board are:

Realtek ALC889A
High Definition Audio
2/4/5.1/7.1-channel
S/PDIF In/Out

Not lucky enough to have optical amp here yet so just using the normal jacks
for output, has the OP checked that the optical is disabled in the mixer?

I did have a prob with that enabled by default also which did stop output
initially but have come across that on a lot of installs so was an automatic
configure thing for me.

HTH

Mark

Nullus in verba
Nil illegitimi carborundum

Its possible amars1983 difficulty is due to pulse audio, but I’m not yet convinced of that. I note amars1983’s PC has a IDT 92HD71B7X audio codec, which is not the same as the ALC889A.

oldcpu adjusted his/her AFDB on Sunday 24 May 2009 17:46 to write:

>> Its possible amars1983 difficulty is due to pulse audio, but I’m not yet
> convinced of that. I note amars1983’s PC has a IDT 92HD71B7X audio
> codec, which is not the same as the ALC889A.
>
>

Ack!


Mark

Nullus in verba
Nil illegitimi carborundum