Sound problems snd-hda-intel 82801H (ICH8 Family)

hello, i’m having some trouble configuring my sound card…

i have no sound at all, i’ve read a couple of forums on this subject but still got nothing, please someone help me!

when i run alsaconf i get no pci\pnp cards detected
on YAST->Hardware->Hardware-information my sound card appears as snd-hda-intel 82801H (ICH8 Family)

Try working your way through:
SDB:AudioTroubleshooting - openSUSE

if that doesn’t help, then please, with your PC connected to the internet, copy and paste the following into an xterm/konsole:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa' 

when prompted for your password, enter your root password. Please try to answer the question on the number of jacks/plugs as accurate as possible (ie how many input/output jacks do you have ? ). It will give you a URL when complete, … please paste that URL here.

Also, please copy and paste and run the following one line at a time in an xterm/konsole:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound
dmesg > dmesg.txt

and then with a text editor open up dmesg.txt and paste output to general pastebin - simplified internet collaboration and paste url here.

no luck with the SDB tutorial =/

The URL : tsalsa.txt - nopaste.com (beta)

rpm -qa | grep alsa

alsa-tools-1.0.17.git20080715-1.6
alsa-oss-32bit-1.0.17.git20080715-2.4
alsa-plugins-1.0.17.git20080721-1.2
alsa-firmware-1.0.16.92.git20080617-3.1
alsa-driver-kmp-default-1.0.16.20080801_2.6.25.5_1.1-3.1
alsa-utils-1.0.17.git20080715-1.5
alsa-oss-1.0.17.git20080715-2.4
gmerlin-alsamixer-0.3.8-0.pm.1
alsa-1.0.17.git20080801-1.1

rpm -qa | grep pulse

pulseaudio-module-x11-0.9.10-26.3
libpulse0-0.9.10-26.3
pulseaudio-0.9.10-26.3
pulseaudio-module-bluetooth-0.9.10-26.3
libpulse-browse0-0.9.10-26.3
pulseaudio-esound-compat-0.9.10-26.3
libpulse0-32bit-0.9.10-26.3
libpulsecore4-0.9.10-26.3
pulseaudio-module-zeroconf-0.9.10-26.3
gstreamer-0_10-pulse-0.9.7-42.pm.1
libpulse-mainloop-glib0-0.9.10-26.3
pulseaudio-module-lirc-0.9.10-26.3
pulseaudio-utils-0.9.10-26.3
pulseaudio-module-gconf-0.9.10-26.3

rpm -q libasound2

libasound2-1.0.17.git20080801-1.1

uname -a

Linux linux-fobgn 2.6.25.11-0.1-default #1 SMP 2008-07-13 20:48:28 +0200 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/sound

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

dmesg > dmesg.txt

general pastebin - Something - post number 1090189

Thanks. An AususAm51Sn with an ALC660-VD hardware audio codec.

For the following, for a sound test, I recommend you copy the following into a Gnome-terminal/konsole:
speaker-test -Dplug:front -c2 -l5 -twav

From the dmesg I can see the auto-probe of your BIOS … not sure how well it succeeded:

# hda_codec: Unknown model for ALC660VD/ALC861VD, trying auto-probe from BIOS...
# ALSA sound/pci/hda/hda_codec.c:3021: autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0)
# ALSA sound/pci/hda/hda_codec.c:3025:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
# ALSA sound/pci/hda/hda_codec.c:3029:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
# ALSA sound/pci/hda/hda_codec.c:3030:    mono: mono_out=0x0
#  ALSA sound/pci/hda/hda_codec.c:3038:    inputs: mic=0x18, fmic=0x19, line=0x0, fline=0x0, cd=0x0, aux=0x0 

Lets try some edits to your /etc/modprobe.d/sound file:

According to the ALSA-Configuration.txt file, the options for an ALC660VD are:

	ALC861VD/660VD
	  3stack	3-jack
	  3stack-dig	3-jack with SPDIF OUT
	  6stack-dig	6-jack with SPDIF OUT
	  3stack-660	3-jack (for ALC660VD)
	  3stack-660-digout 3-jack with SPDIF OUT (for ALC660VD)
	  lenovo	Lenovo 3000 C200
	  dallas	Dallas laptops
	  hp		HP TX1000
	  auto		auto-config reading BIOS (default)

So lets try some of those and see if they help. Unfortunately you did not answer the number of plug questions in the diagnostic script, so you are making this more difficult. (sure you can count the number of input/output jacks on the back of your PC motherboard?).

So edit your /etc/modprobe.d/sound file, changing it to:

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto
alias sound-slot-0 snd-hda-intel

and save the change. Then restart your sound with rcalsasound restart and test your sound with the sound test (above). Please note any errors and advise.

If “auto” doesn’t work, try working your way through in your /etc/modprobe.d/sound file, instead of “auto” (one at time, saving, testing your sound) 3stack, 3stack-dig, 6stack-dig, 3stack-660, 3stack-660-digout, lenovo, dallas, hp

Note “3stack” normally corresponds to 3 i/o plugs, … “6stack” with 6 i/o plugs.

If that does not work, I recommend you take a hard look at your pulse audio applications, to see if they are causing a problem.

A question … are you using ndiswrapper for your wireless?

I really new to linux… how do i know if im using that wrapper?

Obs.: on my notebook there is 1 output jack for phones(and spdif) and 1 for mic… i dont know how many jacks inside. if any…

when i tried to restart i got a bunch of warnings like the one that follow:
WARNING: /etc/modprobe.d/dmesg.txt line 2: ignoring bad line starting with ‘Command’

i got 1 warning per line from line 2 to line 1142

then

WARNING: /etc/modprobe.d/tsalsa line 22: ignoring bad line starting with ‘vers=“2008-07-15”’

from line 22 to line 370

the test seems to work just fine, exept that no sounds come out

Some (perhaps most) of those model assignments will give errors. Just keep trying them. Can you post the output of one sample /etc/modprobe.d/sound file, so I can check your syntax and confirm you did not mess it up.

This is looking more and more like a pulseaudio hiccup.

i tried all of the models, the all had the same output, the test runs fine, but no soound, as for the restarts, all of them got the same warnings

i checked at YAST just now… i dodnt have the ndiswrapper package installed… its available though…

the output you asked for

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=3stack-660-digout
alias sound-slot-0 snd-hda-intel

thanks for repliing so quickly and for your effort =D

Unfortunately, its starting to look a bit gloomy. I found this:


and found further references that alsa sound drivers doesn’t work with this laptop (yet), … I saw one obscure reference of a user who stated audio worked with the oss sound drivers.

If you can’t get sound to work, I recommend you write a bug report:

OK! I wil report the bug. Thanks again for your time and effort =D

You could reference this thread in the bug report, as it illustrates the efforts you made to get this working.

i finally got it working… here what i put on the /etc/modprobe.d/sound to fix it…

options snd slots=snd-hda-intel

u1Nb.WwbOITG9v9B:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

and it just worked
=D

hope this helps someone =D

Thanks for sharing your solution.

Thats the standard output of YaST > Hardware > Sound on an openSUSE-11.0 PC.