Sound problems OpenSUSE 11.2 64bit

I’m running OpenSUSE 11.2 64bit on my media center computer. Video and audio both come from an ATI Radeon HD4550 via HDMI cable. Video works fine with everything, but audio is hit and miss.

If I play a file with Kaffeine, video and sound work great. Amarok plays audio fine as well. However, when I play the same file with VLC, I get video but no sound.

I also have FCEUX NES emulator as well as BSNES SNES emulator installed. Both play the roms with no sound.

Firefox will not play sound either. Youtube and such all play video but no sound.

Kaffeine, Amarok, and system sounds seem to work appropriately. Is there a common audio backend for the working applications that would indicate an easy fix?

I’ve opened Alsamixer and unmuted everything and turned all the volumes up. Same with Kmixer. I also went to YaST->Sound and made “R700 Audio Device (Radeon HD 4000 Series)” the primary card. Further, in Configure Desktop->Multimedia under each of the Audio Output categories, I moved HDA ATI HDMI (HDMI Audio Output) to the top of the list.

What is my problem? Let me know if you need any further information. Thank you.

kaffeine and amarok tend to use the xine sound engine, although they can both be tuned to use the gstreamer engine instead.

I never did get HDMI working on the occasion I had to connected to an HDMI capable tv, so I’m reluctant to say too much as I could be wrong.

I recommend you check the output audio mode in your multimedia players (under preferences or settings in each).

Also, if using KDE, look at the order of sound devices in YaST > Hardware > Sound and ensure that the device order/priority in KDE > Configure Desktop > Multimedia is consistent. Also check what backend you are using when there. Also check if you have phonon-backend-xine and/or
phonon-backend-gstreamer (dependent on whether you use gstreamer of xine).

I tried this, but didn’t have any luck. VLC and Kaffeine didn’t give any information that I could find. Amarok has a section in its settings under “playback” where you can press a button for sound system configuration. Pressing this button takes you to the same spot as Configure Desktop->Multimedia.

Everything seems to be consistent. Both areas have the HDMI video card as the primary device. I checked the backend and Xine has priority over Gstreamer.

I’m not sure how to check this. It seems I’m using Xine as the KDE default, but I know nothing of phonon.

Ok, I got VLC working by blindly messing around with the settings. Here’s what I did:

Tools Menu -> Preferences -> Select “All” radio button in lower-left corner. This shows a list of expandable options on the left side of the window. I expanded Audio to reveal Output Modules. This window has Audio output module with a drop-down menu saying Default. I changed this to ALSA audio output. Then, on the left side of the window, I expanded Output Modules and went to ALSA. This window has ALSA Device Name with a drop-down menu saying Default. I changed this to HDA ATI HDMI: ATI HDMI (hw:1,3). Once these settings were changed, I hit save and opened an AVI file which played video and sound!lol!

Now I just have to figure out Firefox, FCEUX, BSNES, and anything else that has no sound. I wish there was a global setting I could change to make everything work. I thought I did that with the things I outlined in my first post, but obviously it did not work.

One more thing; I just found the phonon-backend you spoke of. Both Xine and Gstreamer are using phonon. Xine is primary and Gstreamer is secondary.

I think you made a mistake here, and you did not intend to include VLC in this … because in VLC if you go to VLC > tools > preferences > audio > output > type you can select alsa, oss, default … many selections to try. That is rather obvious, and I am now wondering if you could miss that, what else could you miss ?

As I noted, Amaork and Kaffeine can use the Xine engine and if they are using the xine engine, then one can tune the xine engine. To tune the xine engine, one has to install the interface for xine, which is xine-ui.

zypper install xine-ui

Then one goes into xine’s preferences , select the control for max permissions (master of the known universe or something like that) , restart xine, and then go to xine settings and into its audio section. Try different ones (such as alsa, or oss … etc … ).

Simply query your rpm database which contains a list of all your rpm based software that is installed on your PC ! ie Type:

rpm -qa '*phonon*'

to see what you have

I installed Xine UI as you stated. Xine also plays videos with no sound. I went to the settings and changed alsa,oss,pulseaudio,etc under the Audio tab. Nothing made sound work in Xine when playing video files.

Querying the RPM database for phonon revealed:

phonon-4.3.1-3.3.x86_64
libphonon4-4.3.1-3.3.x86_64
phonon-backend-gstreamer-0_10-4.3.1-3.3.x86_64
phonon-backend-xine-4.3.1-3.3.x86_64

One thing I changed in VLC to get it working that I think made a difference is going to Tools Menu -> Preferences -> Audio -> Output Modules -> ALSA -> ALSA Device Name. I changed the drop-down menu entry to HDA ATI HDMI: ATI HDMI (hw:1,3). I don’t see anywhere in Xine or anywhere else (with the soundless applications) to specify what ALSA device to use like I could in VLC.

What audio codec is in the videos files and audio files where the audio is not playing with xine? How many different type of files (with exactly what codecs) did you try?

What is the output of:

rpm -qa '*xine*'
rpm -qa '*ffmpeg*'

One of the things I am checking in the above is confirmation that you have packman packaged versions.

***** oldcpu moderator mistaken edit ****

**** Grassman20 *** I had finger trouble … .sorry, … I mistakenly hit the “moderator edit” of your post, instead of the reply to your post.*********

But I think I know the problem (below)*

Thats all you got ?

Thats a problem then. You are missing libffmpeg0 as that should have shown up when you typed "rpm -qa ‘ffmpeg’.

Most of the codecs that you will want to use are provided as a dependency of libffmpeg0. Install libffmpeg0.

Out of curiousity, how many repositories do you have enabled? I hope only OSS, Non-OSS, Update and Packman, and no others. Only users with advanced familiarity with openSUSE should IMHO have more than those 4. Others should only add a 5th when needed for a specific application, install the application, and remove the 5th repository. Failure to do so will result in a new or average user having dependency or functionality problems that they can not sort.

**** Grassman20 *** I had finger trouble … .sorry, … I mistakenly hit the “moderator edit” of your post, instead of the reply to your post.*********

But I think I know the problem (above).

Grassman20,

To check the codec of a package, install these three apps from packman: libmediainfo0, mediainfo-gui, and mediainfo.

Ok I installed libffmpeg0. Here is the new output:

Grassman20@linux-pdjw:~$ rpm -qa '*ffmpeg*'
ffmpeg-0.5.22789svn-0.pm.1.1.x86_64
libffmpeg0-0.5.22789svn-0.pm.1.1.x86_64

After installing the package, I tried firefox again. Still no sound from either YouTube or Hulu. I also tried Xine again. No sound from AVI, MP3, or MKV. I didn’t mess with any sound settings, just played the files.

I did have others enabled:
ATI Video Drivers http://www2.ati.com/suse/11.2/
Emulators Index of /repositories/Emulators/openSUSE_11.2
Libdvdcss repository http://opensuse-guide.org/repo/11.2/
Packman Index of /suse/11.2
Packman Repository Index of /pub/packman/suse/11.2
Updates for openSUSE 11.2-0 Index of /update/11.2
openSUSE-11.2-Non-Oss Index of /distribution/11.2/repo/non-oss
openSUSE-11.2-Oss Index of /distribution/11.2/repo/oss

I’ve disabled all of the repos not on your list, however, I have two Packmans. Which one should I keep? Also, should I disable the CD repo?

Now that you have the codecs, you need to try my advice that I have given elsewhere.

  • start a video in Firefox and then check the mixer PCM level. That needs to be moved up in volume and it may have dynamically moved down to zero
    .
  • If KDE check YaST > Hardware > Sound and note the priority of audio devices. The device in which you wish to play audio from in Firefox should typically be chip-0. Then go to KDE kickoff application launcher > Configure Desktop > Multimedia and ensure the priority of audio devices there matches what you observed in YaST.
    .
    Often users with 2 sound devices will struggle a bit with Firefox and flash videos until they sort this.
    .
    • Go to Firefox > Edit > Preferences > Applications > Shockwave Flash file and change the selection to “use Flash Player (default)”. You may need to restart firefox afterward.

Please check the settings in xine. I gave that to you already !

Then one goes into xine’s preferences , select the control for max permissions (master of the known universe or something like that) , restart xine, and then go to xine settings and into its audio section. Try different ones (such as alsa, or oss … etc … ).

Skynet is Belgium. Unixheads is in the USA.

Take your pick.

I always disable the CD repos (but I do not delete). I find to be occasionally asked to insert the CD is an annoyance and disabling the CD gets rid of that request.

If following the above advice does not help in any way at all, then you could start working your way through post#1 in this guide: Check your multimedia problem in ten steps - openSUSE Forums

I enabled all channels in Kmix, unmuted and maxed them all on both tabs. I also unmuted and maxed everything in alsamixer. No sound from Firefox.
.

YaST shows the ATI Radeon card listed as chip-0. KDE Multimedia section seems to match. However I have two HDMI output devices in the list:

  • HDA ATI HDMI, ATI HDMI (HDMI Audio Output)
  • HDA ATI HDMI (ATI HDMI)
    They’re listed in the same order as above with the first one being at the top of the list. Does it matter which one is first? Both play sound when I hit the “Test” button.
    .

Did this and restarted Firefox. Still nothing.

I rechecked all of the settings in Xine with AVI, MKV, MP3. Nothing.

I’ll check out the multimedia guide you suggested. Hopefully I can get this thing working. This is becoming a big draw on my time.

I do not have HDMI audio setup.

For all I know, this could be a simple limitation that HDMI audio is not supported in all cases.

IMHO you may be beyond openSUSE implementation specifics and you may be better off going to the respective websites of the applications that are causing you difficulty here.

I’ll continue working on it and post my solution once it’s found. Thanks for your help.

I had exactly this problem and I think I’ve just got the bottom of it. I have sound now anyway. YMMV here of course(!)

Open the sound control on the toolbar and thump it in the “mixer” button. Now, on my setup I have two sliders there, one for “Master volume” and one for “PCM”. The latter was set to nothing. Slide this one up. That gave me sound from everything that had been silent up 'til that point (apart from VLC possibly, I’d already done what you did to get that working and I’m loath to undo that as it ain’t broke now, so not fixing it is the right approach).

If this works for you too, we may need the assembled experts here to explain what the “PCM” control is, why it’s seperate, why it has this effect and why it ignores the Master volume…