Sound problems on OpenSUSE 11.1 64 Bit


ACER TravelMAte 7730G
INTEL HDA ALC268Analog (Sounddevice, according to PulseAudio)
OpenSUSE 11.1 64bit

I’m experiencing some trouble controlling the sound input and outputs on my laptop.

I’m an amateur musician. I want to try out some opensource software for composing, editing, mixing, recording and producing music, to the extent that these programs are available.

To achieve this I downloaded and installed Tuxguitar and Traverso. This saturday I spend several hours trying to figure out why I couldn’t hear my guitar through the laptop. It was connected through my Behringer V-Amp2, that allows me to connect my guitar to my computer. I checked the outputs on the amp, they do work. After messing around with it for a couple of hours I finally got to hear the V-amp2 through the computer. However Traverso couldn’t find that input.

Here today all of a sudden Traverso worked. I didn’t do anything. I made a test recording. I could hear the guitar as I played and I could playback the recording afterwards. Then after I was done I launched Banshee to listen to music. No sound.
I tried finding out what was wrong. Checkin through all available PulseAudio application, without success. I muted and unmuted a couple of things and moved some sliders back and forth. Nothing. I could see the output meter was moving. And PulseAudio even detected what song was playing. But no sound. I rebooted, no sound. I gave up on it and decided to go for help on the tuxguitar forum, and while writing there the sounds returned! I open banshee and set it to play, and it worked again. I opened it to find out what window of pulseaudio supplied info on what song was playing.

OK…long story short: I don’t know how to control the sound devices/inputs/outputs and sound mixers that I have in OpenSUSE. Its a little bit frustrating. I’m reasonably sure its me being a totally incompetent. I need a little help figuring out how to set up my laptop so that I can easily hear the guitar, record, and playback (both banshee and my recordings).

Sorry about the long post…:shame:

Best regards,

You are trying things way beyond my experience level as I have no such hardware. BUT I do know that Banshee can be a bear to setup, and while I have it working (after some difficulty) on a Test PC, because of its setup difficult I simply ignore that application on my regular PCs.

Does Banshee work with ANY apps for you?

Did you try applications such as the Packman packaged version of smplayer, or vlc ?

I think I turned to Banshee because of stability issues with Amarok.I’ll try out that smplayer you’re talking about. I was a little disgruntled that I couldn’t easily set the buffersize in Banshee.

I’ll see if that helps.


Hmm…mplayer and smplayer seems to be movie players…I use Banshee for music. I got Songbird instead. Very nice program. But was it Banshee that messed up my sound system? Its not me bein a total n00b at controlling the mixers?


I can’t find any edit option, so I’ll have to write a new reply.

Windows 7 64bit finds two audio devices, a REALTEK and an nVidia:

REALTEK High Difinition Audio

nVidia HDMI/HDA or something like that.

As opposed to that OpenSUSE found an Intel HDA alc268 Analogue.Or 82801 (IHC9 family) I’m not sure where to find this info in OpenSUSE.

Isn’t it cause for concern that the two operating systems detect different hardware on the laptop? How do I know and make sure that OpenSuse detected the right hardware?


Another nice music program is Amarok.

There is good alsa driver support for the ALC268. I do not think you are encountering a driver problem.

Tonight, after playing with my guitar, through my laptop and playing along to gtklick (metronome) and recording a track in Traverso, Songbird and Tuxguitar did not play any sounds. I left the computer alone for like an hour and upon returning the sounds worked again.

Why does this happen? Does the driver need a few minutes ‘rest’ or something between switching between tasks like that?


Its more likely you had another application running that had seized the sound driver and refused to share it.