sound problems on Gateway M-6874h

Hello everyone,
I have recently installed openSUSE 11.1 with KDE 4.1.3. At first, my sound was working fine, even though I was always getting a message at startup saying that “The audio playback device HDA Intel (STAC92xx Analog) does not work. Falling back to HDA ATI HDMI, ATI HDMI (HDMI Audio Output).” However, after installing updates for OpenSUSE (using UpdaterApplet) and ksensors, sound got totally muted. I tried to configure sound card with YaST2,and it shows me two audio devices: RV630/M76 audio device [Radeon HD 2600 Series] and 82801H (ICH8 Family) HD Audio Controller. I tried to set each of them as the Primary Card, there is no effect. Tried to restart the computer a dozen of times - there is no effect either. Do you guys have any idea what the solution to this problem could be? This is like the second day I am using Linux, so I am really lost lol.

Thats usually a bug in openSUSE-11.1.

Second day with Linux. Well, welcome to Linux. … This could be fun trying to explain things … :slight_smile:

Perhaps reading up on some basics might help … First some openSUSE concepts: Concepts - openSUSE

Some openSUSE sound concepts (very theoretical): Sound-concepts - openSUSE

As you may have surmised, by reading the above two URLs, your sound is typically provided by a kernel module that comes with the alsa package …

For helping users with non-functioning sound, I typically recommend that they try working your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

However that assumes one has a basic knowledge of Linux … you may not yet be at that stage ?

Don’t forget to try YaST > Hardware > Sound to configure your sound card. Also, don’t forget to try ‘alsaconf’ in a konsole/terminal if YaST does not help you.

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Try those speaker-tests as both a regular user, and with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? If using openSUSE-11.1, you can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and typing “su” (no quotes - enter root password) and then and typing and executing twice :
/usr/sbin/alsa-info.shthe first time it will ask to update. Select YES for the update. The second time that will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a recommendation (as opposed to a guess).

Please advise if you do not know how to open a konsole or terminal.

Thanks a lot oldcpu :slight_smile: Those links are very useful for me right now, especially the basic openSUSE Concepts… Hopefully will finish reading it tonight, if not, then tomorrow. Anyways, I used AudioTroubles tutorial and did Steps 1 and 2. Step 1 did not do anything, but deleting the sound card from YaST and configuring the sound with alsaconf solved that issue. I should have probably searched the forum before asking you, so I am really sorry, I got too confused. But again, thanks a lot for help, really appreciate it.

Super ! Congratulations …

Some more sound stuff … (actually, some multimedia stuff) … As you have likely noted, openSUSE has the ascii sequence “open” in front of “SUSE”. This is because since version 10.1 of SuSE, the Linux distribution of SuSE was renamed to openSUSE. This went hand in hand with a philosophical shift, where greater emphasis was placed inside openSUSE to include open source free software. Open source free software is software that has the basic freedoms as defined by the free software movement: Free Software Philosophy - openSUSE
ie it means “free” in the sense that one is

  • “free to copy”,
  • one has “free access to the source code”,
  • one is “free to modify the code”,
  • one is “free to give away original version”, and
  • one is “free to give away their modified versions”.

This name change to “openSUSE” also meant openSUSE does NOT include proprietary software nor include proprietary drivers, nor include proprietary multimedia codecs. Since most multimedia requires proprietary codecs, it does mean that “as installed” openSUSE will not play most types of media that are circulating in the internet.

Fortunately, that is easy to fix to provide one’s openSUSE with superb multimedia capabilities.

The 1st thing that I recommend you do (assuming your PC has internet access) is set up your PC’s openSUSE Software Package Management. I recommend you select 4 repositories for your Software Package Management (where repositories are in essence file servers on the internet with applications, drivers, codecs) packaged for openSUSE. The 4 I recommend are OSS, Non-OSS, Update and Packman. Just those 4. No others. If you added others I recommend you remove them. The reason being there can be conflicts between applications in different repositories, and only once one acquires the knowledge as to how to identify and solve problems between multiple repositories, should one then add more than the basic 4 I recommend. There is guidance here for how to add those 4: Repositories/11.1 - openSUSE-Community You will probably find the 1st three OSS, Non-OSS, Update are already added, and you just need to add the 4th (Packman). Packman provides the 3rd party applications/codecs that you will need for multimedia. In particular, do NOT add videolan, as it is known to have applications incompatible with those packaged by Packman.

So, once those 4 are selected/enabled, then go to YaST > Software > Software Management and change the “filter” to “search” and then search for and install the 3rd party software you need to enhance your multimedia on your PC. I recommend you install the Packman packaged version of the following applications as a start (replacing any Novell/openSUSE versions which will be crippled): amarok, amarok-xine, amarok-packman, libxine1, xine-ui, smplayer, mplayerplug-in, vlc, w32codec-all, libffmpeg0, ffmpeg, libquicktime0, libxvidcore4, xvidcore.

Note you can tell the packman packaged versions by the “pm” in the version number.

Once you do that, you should have some reasonable multimedia capabilities to get you started.

You can read more on Packman Packaged applications here:
PackMan :: Website