sound problems (might be the driver)

alright let me explain what happened, first thing’s first, my computer’s chip fan failed, and to take it out I had to remove the motherboard due to the design of the fan…

so I got the fan out, vaccuumed it and put it back in and put the whole system back together, it worked for a little while, and during that time the sound would boot only on occasion, meaning I’d turn on my computer and the sound wouldn’t boot, then the next time it would boot and would work fine…

now it’s not working at all, I’ve tried working with all the sound controlls in the control center. both root and non root, andand I can’t seem to get it running…

when I run any program with sound in kaffiene, it say’s all audio drivers failed to initialize…

can someone help me figure out how to gett he sound working relyably again?

Please try working your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

In particular, pay attention to the recommendation to go to:
YaST > Hardware > Sound

well it wont setup with the control center options at all, not even after deleteing the sound card, it tells me it can’t configure it because the options arent correct.

so I went throught the terminal commands and found that theres still no sound, the “alsaconf” command shows me that it see’s my sound card (s) as: intell8x0 nVidia Corporation CK804 AC’97 Audio Controller (rev a2),

and a: legacy Probe legacy ISA (non-PnP) chips

both of which are odd, as it shows up as a K8N5X in controlcenter…

it configures with the first option, but theres no sound out of it, the second option has no drivers…

whats silly is when I put in; “cat /proc/asound/cards” it tells me:…well it had told me that no sound cards were detected, but now it’s telling me, that there is no such file or directory… probably because I installed the lagacy driver thing…

an additional piece of information:

I don’t recall the troubleshooting guide mentioning the control center.

Please, can you with your PC connected to the internet copy and paste the following into a konsole:

wget && su -c 'bash ./tsalsa' 

when prompted for a password, enter your root password, and when it completes it will give you a URL. Please post the URL here.

Please also post the output of copy and pasting the following lines, one a time, into a konsole (and paste the output they give here):
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

under rpm -qa | grep alsa:

under rpm -qa | grep pulse:

under rpm -q libasound2:
package libasound2 is not installed

under uname -a:
Linux (none) 2.6.13-15-default #1 Tue Sep 13 14:56:15 UTC 2005 x86_64 x86_64 x86_64 GNU/Linux

under cat /etc/modprobe.d/sound:
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0

and the troubleshooting guide does mention the control center, after all thats where “YaST > Hardware > Sound” is an option…

honestly though something reset it self or deleted it self when I took the motherboard out…

also I checked my log of available files to install through softawre management, and libasound2 isn’t even there, there isn’t libasound even…

as the sound worked without it before, it must be alright… so it’s not the issue…

alsa 1.0.9 ? Thats SuSE-10.0, or some SLED/SLES version.

I really NEED you to run this script with your PC connected to the internet:

wget && su -c 'bash ./tsalsa' 

simply cut and paste it into a gnome-terminal or konsole. When prompted for a password enter the root password. When it completes it will give you a URL. Please post that URL here.

If you are missing the program “wget” and can not run the script, then simply follow the instructions here for running the script:
SDB:AudioTroubleshooting - openSUSE
(ie download it to your hard drive and run with su -c ‘bash tsalsa’ )

Thats because you are using such an old opensuse version (and an old alsa). You do know that SuSE-10.0 is NO LONGER SUPPORTED?

ok, then its a terminology issue. If I speak Thai and you speak English, we won’t communicate well. :rolleyes: It was referred to as “YaST” in the audio troubleshooting guide. … I think so we understand what each other is typing, we need to try to adopt a common terminology. :slight_smile:

Did you change any jumpers? Did you plug the audio jacks back in the correct place and not inappropriately reverse them?

One thing you could do is download and burn a liveCD that is good for troubleshooting. For example, I recommend “kanotix” and also “sidux” liveCDs for troubleshooting one’s audio hardware.

Not a certain thing IMHO. Static could have zapped the motherboard. You have changed a jumper by mistake, or put the audio plugs back in the wrong jacks.

I am running 10.0

and the sound was working without the newest versions of alsa before.

and my audio “card” actually just a box on the board… it is possible that the board was shocked statically, as I just found a hair in there (darned my staticy hair!)

is there some way I can completely delete all programs associated with the system’s sound, then reinstall it all?

especially Kmix, as the mixer of that cannot be found as the picture I showed you mentioned…

and as I am using 10.0, I don’t think it’s a good Idea to install 10.3 or above programs just yet as it might just confuse my system, also I have limited space on my hard drive for new software as I partitioned it to only be double what I needed for a base install…

additional the outcome of the shell script you gave; tsalsa.txt - (beta)

Great! Then lets try to get it running without.

Yes, which is why I recommended “sidux” or “kanotix” (or even both):

sidux: :: debian based live cd development
kanotix: :: GNU Linux Live system based on Debian, optimized for HD-install and high performance

IMHO thats not the logical way to solve this. The logical way is to get more information, like I asked here:

My mothers PC was purchased in 2001. It has the latest BIOS (year 2001) and it has a 60GByte hard drive, 1.1GHz Intel processor, with 512MB of RAM, and it triboots to WinME, WinXP, and openSUSE-10.2. So one can do amazing things with an old PC. I WILL update her PC to 11.0 or 11.1 in Jan-2009 because 10.2 support stops in Oct/Nov-2008. Its risky to run an old PC on the web where support has stopped. One no longer gets the security fixes. The security fixes are VERY important. EVEN for Linux users.

But getting back to the script, I have helped 100’s of users with their sound, and failed in a couple dozen or so attempts (but succeeded in the vast majority). Obtaining results from that diagnostic script is important to me to make this go quicker, and to decrease the time that I have to spend. But if you do not want to run it, then thats your call. Its your PC. … Hopefully in that case, many of the other very qualified users on this forum (and we have a number who know much much more than I about sound, but who tend to lurk a lot) will chime in.

Good luck.

but I did run the script! : tsalsa.txt - (beta)

The script confirms your sound is not recognized by the alsa sound driver:

Alsa driver:         
dpkg path:           
Alsa utils: 1.0.9a        

Alsa modules:        
Alsa cards:         
Lsof output:         
raw amixer output:        
Module Parameters: 

That is IMHO either because:
a. your hardware is misconfigured in your BIOS, or
b. your hardware has failed, or
c. you have somehow lost the alsa driver.

Again, you can likely confirm item (c) (alsa driver) by downloading, burning, and booting from the “sidux” or the “kanotix” live CD.

Be certain you go into your BIOS and confirm it is still configured correctly.

The more I re-read this thead, the more I think you have a hardware problem.

Still, in case there is software involved, you could to this old archive (archive because 10.0 is no longer supported) http site:
Index of /suse/10.0/x86_64
and download and install:

  • 04-Sep-2007 23:03 3.4M
  • 04-Sep-2007 23:03 1.0M
  • 25-Jun-2007 17:39 384K

and go here:
Index of /suse/10.0/noarch
and install

  • 23-Jun-2007 15:43 2.8M

Then reboot, go into YaST > Hardware > Sound and try to configure your sound device.

you’re probably right, I was hoping it wasn’t a hardware issue… that’s why I posted under software in hopes it could get resolved, and I’ve tried booting whilst changing all the sound related options in the bios… and it doesn’t work…

it must have been that hair I found near the sound card, it must have created a static zap on the board…

odd that the rest of it works!

then again the chip fan might be the problem, it’s on the other side of the board , but it has a “report” to the board and as the chip fan is not working mabey it’s told the bios to not let certain parts of the board operate to avoid overheating…

and if worst comes to worst it’s only like $88.00 to replace the motherboard…thats still alot as I’m quite poor, so I’ll hope thats not it…

as for the bios, going back to that, I only have two sound related option “instant music” which relates to the CD reader, and “audio” which is enabled… maybe I should disable it…?

just thinking

if it’s a harware problem, I could probably fix it by buying a PCIE soundcard, I just have to make sure it’s supported under my distro…

do you think that would work?

A PCI sound card will likely work. Why not try those liveCDs (specifically Sidux and Kanotix)?

not enough space to install them, believe me I’ve tried, I’d have to repartition my hard drive, I mean I have plenty of free space, but it’s not under “/home/” it’s under “/usr/” GB’s worth…

but I don’t know how to repartition with out corrupting data that’s already there…

oh well I’ll get a PCIE soundcard. unless theres some way to unstatically shock the “sound box”…

Not sure if you understand. Live CDs are downloaded, and then burned to a CD, … they are not “installed” per se. But one does need 700 MBytes or so of free space to download them, and then more space for a successfulburn.

Based on my 15 yrs as a PC hardware tech and system builder w/ over 10,000 hardware repairs under my belt, I was pretty sure you toasted the sound chip on the MB when I read your original post. I used to see this all the time when folks “vacuumed” the dust off their motherboards. NOT a good idea. Every single particle of dust on that board is holding a static charge. When they all get violently disturbed simultaneously by the stream of air going into the vacuum…
If you simply have to get the dust off do so gently, while you and the surface you’re working on are both grounded.
I also made sure I always worked in a humid environment too. less Static that way.

Now, let’s look again at your original post.
The software worked before you disturbed the hardware.
Then, the very same (unaltered) software didn’t work after you disturbed and reinstalled the very same hardware.
Conclusion: the problem is not software.

Ok… somethings not right…

and it is a software problem possibly as well as a harware one…

the sound card is showing up in yast now, but when I go to configure it it tells me:

An error occurred during the installation of

K8N4-E Mainboard

The kernel module snd-intel8x0 for sound support could not be loaded. this can be caused by incorrect module parameters, including invalid IO or IRQ parameters.

this coupled with the fact that “kmix” although present, has lost it’s mixer and can’t find it.

heres additional sound information from yast:

description: AC’97 codec clock (0 = auto-detect). option:
ac97_clock value: 0 (possible value unknown)

description: AC’97 workaround for strange harware. option: ac97_quirk value: -1 (possible value -1 through +7)

description: Enable work-around for buggy interrupts on some motherboards option: buggy_irq value: 0 (possible value 0 or 1)

and heres the hardware information from “sound”:


K8N4-E Mainboard
Class (spec):Multimedia audio controller
Class:multimedia controller
Device (spec):K8N4-E Mainboard
Device Identifier(spec):98602
Device Identifier:65625
Device:CK804 AC’97 Audio Controller

modprobe snd_intel8x0

Model:ASUSTeK K8N4-E Mainboard
Old Unique Key:7zs+.OtT5SLVvnv3







Slot ID:4
Subvendor Identifier:69699
Subvendor:ASUSTeK Computer Inc.
Unique Key:8otl.OtT5SLVvnv3
Vendor Identifier:69854
Vendor:nVidia Corporation

I’m posting this because I think theres some thing other than the definate hardware problem, most likely when the sound card got zapped and no longer was registered, sound applications continued to run and encountered erros causing them to close out “permanently” applications such as kmix’s mixer… and possibly the snd_intel8x0 driver! the sound card it self seems to have recovered from the shock, but the software is gone…

I had a heck of a time getting sound working once. Turned out that my cmos battery was bad, and it reverted to factory settings, and onboard sound wasn’t disabled in BIOS, so it didn’t see my sound card.