Sound problems, Mic / Youtube

Hi, I’m totally new here, and I’m a totally new user for suse aswell. After windows, I’m sitting here like an idiot before the new OS. :smiley:
So, I’ve got a problem, I’m certain, that someone made a topic like this before - and I’m sorry about this really, but I just can fix my sound options here in suse 11.2 KDE. I tried Gnome, but as for I started with kde and as I saw that the software installation is better there, I’d like to stay at KDE. My problem is: My sound works correctly, everywhere, but at youtube - so the flash - and at skype the mic input is either not working or is hardly distorted. I’m at end nerves as I was searching in the internet and try hundreds of methods and solutions, and installing the hole system again about 20 times - no joke :D. So I’d like to ask you, being desperate, whether you can help me. :slight_smile: - a bitter laugh.
I was thinking that the problem may be that I have 2 installed sound-cards. I’m not using one of them, but as it is build in the ati-vga card I can’t get rid of it completely, even if I de-install it at the yast hardware section.

I again say that I’m a total newbie and I have no idea of not even the easiest parts of opensuse… So please keep it simple please. :slight_smile:

Thanks in advance!

First, reference your mic, the problem could be due to your having two sound cards. It could also be due to other reasons :slight_smile: One negative aspect to Linux offering so much choice to the user, means sometimes things are hard to get working (as the default choice does not guess the correct configuration).

First, is this an INTERNAL mic or an EXTERNAL mic ? I assume an EXTERNALbecause you talk about 2 sound cards) but I am not sure. On what sound card did you plug in the jack on the PC ? In fact, what can you tell us about the sound card (s) ?

I do NOT use Skype, so if this problem has ANYTHING to do with Skype then I can not help you.

Note when testing your mic, I recommend you use a terminal with this command:

  arecord -vv -fdat foo.wav

“foo.wav” is an arbitrary name I made up. Instead you could call it mydell.wav or thewindblows.wav or anything …

Then assuming mic does not work, please provide the information recommended to be provided here:

  • set up your mixer such that it is correct for your mic to record (best you can) and then with your PC connected to the internet, run the script below, and provide the website page/URL (of a summary webpage) that are created by running the diagnostic script:

Note you must select the SHARE/UPLOAD option.

If for some reason that does not give you a web site URL/address, then please run that diagnostic again with the no-upload option to create an alsa-info.txt file by:

/usr/sbin/ --no-upload

and it will create /tmp/alsa-info.txt. Open alsa-info.txt with a text editor, copy it, and paste it into a paste bin site such as - #1 paste tool since 2002! or pastebin - Type, paste, share. or New - Pastie and then after submitting/pasting it on one of those sites, the site will update and you can copy the website address/url from that site, and post here the URL. Just post the URL. Do not post the entire content of the diagnostic script here. Just the URL.

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

That will provide more information that can help in figuring out your mic problem.

Reference the youtube hiccup for sound, this could be because you have 2 sound cards.

First, check that flash-player is installed. Something like:

rpm -qa '*flash*'

should give you that answer.

Then check the order of sound devices in YaST > Hardware > Sound and after making note of that, go to KDE’s Menu > Configure Desktop > Multimedia and ensure the order of sound devices there, match the same order of sound devices that you saw in YaST.

Also, when one starts a youtube video, there is a chance that the PCM audio control could jump dynamically to zero, muting audio. So please check that your PCM volume control is up to some reasonbly high level. Try 95% and then backoff the level once volume is established.

I bought a headset last week and when I did the mic test with Skype I got very distorted sound. I was able to fix it with alsamixer. Open up the terminal and type


Then hit “F4” to go to ‘Capture’ and make sure none of the bars are in the red. Lowering these to below 80 solved my mic problems.

For your flash problem, you can try creating a file called /etc/asound.conf and paste this in there:

pcm.!default {
      type plug
      slave.pcm {
              type hw
              card 0
              device 3

You can find your correct card and device with:

arecord -l

Hello, thanks for the swift answers :slight_smile:

To the things, you asked for:
I’ve got an external mic.

Here is the (

and here is the code you asked for:

rpm -qa '*alsa*'
rpm -qa '*pulse*'   
rpm -q libasound2   
uname -a            
Linux linux-l3ra #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux
cat /etc/modprobe.d/50-sound.conf                         

options snd slots=snd-hda-intel,snd-hda-intel
# UTtW.PfnGitoKusE:VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller)
alias snd-card-1 snd-hda-intel                                                  
# 2Oa+.RnSVKGdkzq7:RV630/M76 audio device [Radeon HD 2600 Series]               
alias snd-card-0 snd-hda-intel                                                  
norbert@linux-l3ra:~> /usr/sbin/                

well, tried the other methods, but I could not make a file in the /etc folder, when I understand right, I should be doing this as root, but have no idea how to be logged in as root :slight_smile: can do it on the konsole though.

I hope I posted everything you needed.


I do not know what other methods you talking about.

Never log in as root. Never.

You can do this via a konsole by typing "su - " to switch users to root/admininstrator.

You stated you have 2 sound cards. Are you certain the mic is plugged in to the correct sound card ? This is not a USB mic, correct ?

Did you try the “arecord” command like I asked?

Did you match the settings in KDE > Configure Desktop > Multimedia to those in YaST > Hardware > Sound ?

arecord -vv -fdat foo.wav
ALSA lib pcm_dsnoop.c:593:(snd_pcm_dsnoop_open) unable to open slave
arecord: main:608: Fehler beim Öffnen des Gerätes: Datei oder Verzeichnis nicht gefunden

  • Error while opening the device: File or Dir not found.

Probably I made something wrong. I’ll may look stupid now. :S

Well “methods” was no good word, the other two things to do - I meant, so the Multimedia and the sound options - at KDE and YaST
I played around with that often but, and it’s set correctly now. But it were correct all along, I tried other settings but nothing changed.

That command should work. That tells me the application arecord, which defaults to sound card 0, can not find a mic on that card.

So when I look at the /etc/modprobe.d/50-sound.conf file, I note this:

options snd slots=snd-hda-intel,snd-hda-intel
# UTtW.PfnGitoKusE:VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller)
alias snd-card-1 snd-hda-intel                                                  
# 2Oa+.RnSVKGdkzq7:RV630/M76 audio device [Radeon HD 2600 Series]               
alias snd-card-0 snd-hda-intel   

which is a bit confusing, but it suggests yoiur HDMI is sound card 0.

Then when I look at the script output I see:

!!Soundcards recognised by ALSA

 0 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfbefc000 irq 25
 1 [VT82xx         ]: HDA-Intel - HDA VIA VT82xx
                      HDA VIA VT82xx at 0xfbffc000 irq 17

again, HDMI as sound card 0.

IMHO those are reversed. If you want to use your mic without specifying to go to the 2nd sound device in your application, then you will need to reverse the order of the HDMI and the ALC662 (which is your HDA VIA VT822).

I could not make a file in the /etc folder

You can create that file from konsole with

sudo nano /etc/asound.conf

The nano text editor will open up within the konsole. Hit Ctrl+X to exit nano.

I made a mistake with my first post but you can find your card and device with

aplay -l

Find the card and device you want to use and place it in that asound.conf file.

I think that should work if your problem isn’t just a muted audio.

Hi, the last days I spent hours on trying different solutions also those found elsewhere on the internet. But, then I saw, you reply now, and I did like you wrote. I ought to install the text editor though but afterwards it worked! Youtube is actually giving sound. Thanks really! All of you, and that you took time for replying me! The mic is not working still but, I’ve got windows installed still so I think when I’ll be using it then I just switch the OS.

Thanks again, you all were a big help, not just for the tips, I now know much more about linux:)

Btw. I deinstalled pulse audio and now everything works, corretly, and even skype… :slight_smile:

Thanks again!