Sound problems in Opensuse 12.2!!!!

This week I installed opensuse 12.2 and everything seemed to work fine. It seemed to be more stable than any previous versions.
However I noticed what seemed to be minor problems until they got more complicated.
I was watching videos from youtube in firefox and tried to close firefox with the video still playing and instead of closing firefox froze. It happened several times. There were a few times when I watched youtube videos on firefox and after closing the application no other application could play any sound, nor amarok, nor smplayer, nor wine apps.
But things really got worse when I tried to write music using rosegarden connected to timidity via jack. I used exactly the same config file for timidity that worked for me in the previous version of opensuse and the same jack connection i was used to. But I got no sound at all.
Worst, is that after closing rosegarden, jack and timidity, my sound system didn’t work again. The same way i mentioned above. Neither amarok, nor smplayer, nor anything else could play any sound. Videos in smplayer didn’t even run and mp3’s in amarok got frozen. The progress bar didn’t even move.
I tried to connect rosegarden to qsynth via jack and it worked. (It may be a temporary workaround but I need timidity because qsynth don’t recognize some commands i use for microtonal music and timidity does.)
I even tried to start jack, qsynth, timidity and rosegarden at the same time. When i routed rosegarden to qsynth it worked but not with timidity. And worst of all is that after every failed attempt with timidity my sound system stops and i have to restart the whole system.
I also tried to add the line <modprobe snd-seq-midi> to the file </etc/boot.local>, what worked in opensuse 12.1 but in 12.2 it didn’t solve anything.
Can you help me please? I’m going mad at this and nothing I try seem to succeed. If you can help me I’ll be very grateful.
Thanks.

First check in the KDE system settings > Multimedia > Phonon
Make sure your preferred device is set correctly in all areas

Ok. I did.
In the tab Device preference the only option available in all areas is Internal Audio Analog Stereo. The only exception is in the tree Audio Recording where there are two options: Internal Audio Analog Stereo and CX23880/1/2/3 PCI (that’s probably my tv card that I didn’t installed on linux). So in this area I clicked in Internal Audio Analog Stereo and confirmed in Apply option below.
In audio hardware tab there are these both options too. The selected one again is internal audio. And in the backend the only option available is gstreamer.
Have done that what is the next step?
(Let me mention two more details that I don’t know if they are relevant. I also launched timidity -ig and even with a GUI timidity is not able to play midi files. When i get the problem that all applications cannot not play audio i found out that in musescore the audio still plays without problems.)

Ok.
I found out that creating a file named snd-seq-midi with the same line as its content in the modprobe.d folder makes loads sequence at boot and timidity work as a server.
I still have had some confusion among audio softwares but I’m trying to workaround them.

Hi there!
I’m running openSUSE 12.2 x 64… And this tutorial was (and still is) very helpful when I configured my lap for the very first time (february with 12.1 version)

                [Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums](http://forums.opensuse.org/blogs/oldcpu/pulseaudio-basics-opensuse-pavucontrol-96/)

I do not think you need to pre-load the oss module (modprobe snd-seq-midi) if you run Timidty with Jack. How do you proceed when starting your audio apps?

Btw, Pulseaudio and Jack have been known for causing trouble when running on the same system, if that should be relevant.

That’s why I despise pulse audio,it always breaks everything sound related!

I tried to disable pulseaudio in yast but all my audio was gone!
And before pre-loading the module for the sequencer I could run qsynth through jack, using qjackctl, but when I tried to run timidity through jack I got no sound.
So the only way I found was pre-loading the sequencer module. This way I haven’t had problems anymore. After all these months since I started this thread everything seems to be working.
The only thing I think I must mention and it’s not relaed to timidity or jack only, but to ALL audio applications is: I CANNOT LISTEN TO THE SOUND OF TWO DIFFERENT APPLICATIONS AT THE SAME TIME.
When I’m runing one application that emits any sound and I try to use the sound of any other, I just hear the sound of the first one I loaded. But I have learned to live with this.

Just wondering: did you know that you can configure qsynth to work with pulseaudio (or alsa for that matter), without Jack? I use Rosegarden that way.

The only thing I think I must mention and it’s not relaed to timidity or jack only, but to ALL audio applications is: I CANNOT LISTEN TO THE SOUND OF TWO DIFFERENT APPLICATIONS AT THE SAME TIME.
When I’m runing one application that emits any sound and I try to use the sound of any other, I just hear the sound of the first one I loaded. But I have learned to live with this.

Perhaps you should use qjackctl to fiddle with the connections. You should never live with imperfections, when not necessary. :wink:

On 2012-11-16 18:56, fernando a martin wrote:

> The only thing I think I must mention and it’s not relaed to timidity
> or jack only, but to ALL audio applications is: I CANNOT LISTEN TO THE
> SOUND OF TWO DIFFERENT APPLICATIONS AT THE SAME TIME.

That’s because you disabled pulseaudio sound server. One of the things
it does is precisely allow several apps access to audio.

Of course, pulseaudio is not compatible with jack, which is another
sound server.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))