Sound problems after updating the Kernel

Hi all,
just updated to the recent kernel (2.6.37.6-0.9-desktop) (Open suse 11.4 x 64, on an Asus N53J) - and my sound is gone -
I had this problem with the original installation, so I had to recompile Alsa with the kernel I was using - and that worked (not sure how I just followed the how to posted here) - I redid these steps and still no sound -
if I use the headphone jack then I have sound but not from my speakers -
I believe the problems comes with the HDMI port/card my system has - I disable it but still the same problem
the 2 sounds cards my system recognize are:

  1. 5 Series/3400 Series Chipset High Definition Audio (Driver snd-hda-intel)
  2. nVidia Corporation (Driver snd-hda-intel)

any ideas how to proceed further?

here is the alsa-info details if they can be of any help:
link

Its common that a kernel update will break a custom compiled alsa driver.

If you wait a few days to a week, it is likely the SuSE-GmbH packager will package updated rpms so that you can update alsa via an rpm update (with guidance here: SDB:Alsa-update - openSUSE ) … The updated rpms are not in place yet, but I if the past is any indication I anticipate there will be some updates soon available via the update method described in that linked alsa update guide.

Thanks for the info, I hope that happens sooner than later