Sound-problems after last update

Im running OpenSUSE11.1 32bits on Dell Latitude D830 with Inter HDA driver. It has been working great for a long time until last updates. I guess it has something with the new kernel.

Its not that the sound doesnt work because if i run alsacong and then configure Sound in Yast then the sound start to work. But after reboot its gone again.

I checked out the SDB:AudioTroubleshooting - openSUSE and it fails on the first sound test; #> speaker-test -Dplug:front -c2 -l5 -twav
but the second soundtest works: #> speaker-test -c2 -l5 -twav

Everytime i reboot the sound is disabled (Speaker with a red cross over). When i run the soundtest it get enabled and now the sound is back again. New reboot and its disabled again.

And YES OF COURSE my user is member of group Audio!

I see several have similar problems after last kernel update, so it must be some kind of bug related to this problem.

Have you tried playing with the mixer settings?
If you are using gnome, go to Control Centre and set it up there as well as setting the mixer settings.

PLease take one of the answers old_cpu gave. He’s the audio guru. Basically you’d have to add 2 repos, and update the files in them, reboot and that’s it.