Sound Problem

I added those variables obtained for my chipset from the documentation while going through the troubleshooting guide in the wiki. I’ve re-run alsaconf and overwritten the configuration files and that error appears to have disappeared.

Here is the new paste
general pastebin - Roundhouse - post number 1211271

I tried speaker-test before and after running alsaconf, as a normal user and as root without any luck. :frowning:

I thought that soundrc file was worth a shot but unfortunately it didn’t come through.


As you noted, running alsaconf will wipe the custom settings in the /etc/modprobe.d/sound file. Can you add the following line to the end of that file:

options snd-hda-intel model=6stack-dig enable=1 index=0

and see if it makes any difference? Reboot and test your sound after making the change.

Also, can you run the diagnostic script again (as without the previous error maybe it will provide more information than it did last time wrt your audio codec).

wget && su -c 'bash ./tsalsa'

I didn’t login as root, but launched yast2 users as root and added my user to the audio group (and pulse among others). The option for my USB headeset then showed up under my sound prefs and I changed my input/output to it. This worked for me. Thank you.