SOUND Problem on Ac`97


Yesterday I installed Linux Open Suse 11 on my computer. Very happy that it works, I now have the problem that the tone isn’t working. I hear the “starting sound” but that the sound depends on. What can I do?

Thank you for your help and maybe you can write in German:)

My apologies … I do not speak German … maybe some one can translate for you. You could try copying and pasting the text from my reply into babel fish to translate… Yahoo! Babel Fish - Text Translation and Web Page Translation

You could try working your way through the openSUSE audio troubleshooting guide - Deutsche Sprache ist hier: SDB:AudioTroubleshooting - openSUSE - Deutsche

English here: SDB:AudioTroubleshooting - openSUSE - English

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the gnome terminal has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Try those speaker-tests as both a regular user, and with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming still no sound, can you provide more very detailed information so a good recommendation can be given? You can do that, with your laptop connected to the internet, by opening a terminal or konsole and copying and pasting the following into the terminal or konsole:

wget -O && bash

This will run a diagnostic script on your PC and it will post the output to a web site on the Internet. It will give you the URL of the web site. Please post the URL of that web site here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a recommendation.

This is the URL:

And this are the other command lines :

From rpm -qa | grep pulse the Terminal does not give me inforamtions.


Linux linux-skzy #1 SMP 2008-12-12 20:30:38 +0100 i686 i686 i386 GNU/Linux

options snd slots=snd-atiixp

hB6S.QpKNaLjiIwD:IXP150 AC’97 Audio Controller

alias snd-card-0 snd-atiixp

So, that are all inforamtion you would like to have.
I hope you can help me now. The guide on doesnt help me…

Thank you for spending time on my problems.

ok … I see a 32-bit openSUSE-11.1with the kernel, running a mix of 1.0.15/1.0.16 alsa sound driver/kernel-module. Your PC’s sound card is not detected. The /etc/modprobe.d/sound file suggests your PC has a IXP150 and should be loading a snd-atiixp kernel module.

Searching the alsa site for the atiixp kernel module, I obtain the following, which suggests there are many updates since the 1.0.15/1.0.16 version:
Search results for atiixp - AlsaProject

Hence my recommendation is to:

  • first boot to your BIOS and confirm sound is switched ON in the BIOS, and
  • second update your alsa to version 1.0.20 as described below:

To update to 1.0.20 of alsa for your specific specifications:

To update alsa to 1.0.20, with your PC connected to the Internet, please open a terminal/konsole and type “su” (use no quotes and enter root password when prompted for a password) to get root permissions, and then copy and paste and execute the following one line at a time in that terminal/konsole :

zypper ar multimedia
zypper install alsa-oss alsa-plugins alsa-utils alsa-tools alsa-firmware 
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

and then when complete, restart your PC and test your sound.

Please use the sound test from: SDB:AudioTroubleshooting - Wie_man_Ihren_Sound_testet - openSUSE

Does not work. I first get a tone like “dadadada” this 10 seconds and than “didididi” and I can only disable it by pressing the mute button. Also I think the graphic is very low. A video from youtube is jerkjing. It doesnt work properly.

What are you doing when you get the tone you described? Did you try all 3 audio checks? Do you get the same tone from each ? Note the 3rd one has you run a custom .wav file of your choice. I’m not in front of your PC and I can not see what you are typing when you get those errors. I know it is intuitively obvious to you, but it is not to me since I can not see what you are doing.

Can you also provide me the output, with this new alsa update, of:
Just post the URL. Only the URL

rpm -qa | grep alsa
uname -a
cat /etc/modprobe.d/sound

I get these informations of the terminal:

Linux linux-skzy #1 SMP 2008-12-12 20:30:38 +0100 i686 i686 i386 GNU/Linux

options snd slots=snd-atiixp

hB6S.QpKNaLjiIwD:IXP150 AC’97 Audio Controller

alias snd-card-0 snd-atiixp

But the File you wanted does not exist.

The Problem is that I get a sound but the sound is still the same. It repeats always the same sound “bababababababa” I can only deactivate it by pressing the mute button. But if I want to play a movie in youtube I get no sound. Always “bababababab”.

If you have more questions pls contact me.

Thank you for your help.

I forgot, you are running an old openSUSE version. Try this with your PC connected to the internet :

wget -O && bash

paste here the output url that is provided.

I recommend you write a bug report and get direct help from the SuSE-GmbH alsa packagers, who is also an alsa developer: Submitting Bug Reports - openSUSE

Thats the URL :

Ok, thanks. As noted above, I recommend you write a bug report and get direct help from the SuSE-GmbH alsa packagers, who is also an alsa developer: Submitting Bug Reports - openSUSE

Its possible the alsa dev will have you tune one of these parameters:
!!Loaded sound module options
!!Module: snd_atiixp
ac97_clock : 48000
ac97_codec : -1
ac97_quirk : <NULL>
enable : N
id : <NULL>
index : -1
spdif_aclink : Y

!!Module: snd_atiixp_modem
ac97_clock : 48000
enable : N
id : <NULL>
index : -2
He also may have you blacklist the atiixp_modem, as I think it can cause problems in some cases. One doe that by adding a line to the end of the /etc/modprobe.d/blacklist file:blacklist snd_atiixp_modem and then restart and test.

But I’m not sure of that, and I could be wrong, and I don’t want to waste your time by recommending such things which are wild speculation on my part.