sound problem on 11.1

Hi people i was wondering if you could help me with this mess.:\ Iv been going at it for about an hour now and still no luck with the sound. i went through this guide SDB:AudioTroubleshooting - openSUSE , and had a look through this thread ati sound card doesn’t work on opensuse 11.1 - openSUSE Forums but still i couldnt get any sound out of comp.

here is some info:

rpm -qa | grep alsa

alsa-utils-1.0.19.git20090319-1.2
alsa-oss-32bit-1.0.17-1.37
alsa-firmware-1.0.19.git20090317-1.1
alsa-plugins-pulse-1.0.18-6.13
alsa-1.0.19.git20090304-3.1
alsa-plugins-1.0.18-6.13
alsa-oss-1.0.17-1.43
alsa-tools-1.0.19.git20090320-1.2
alsa-driver-kmp-default-1.0.19.20090406_2.6.27.7_9.1-1.1

rpm -qa | grep pulse

pulseaudio-utils-0.9.12-9.5
pulseaudio-esound-compat-0.9.12-9.5
pulseaudio-module-x11-0.9.12-9.5
libpulse0-0.9.12-9.5
pulseaudio-0.9.12-9.5
pulseaudio-module-lirc-0.9.12-9.5
vlc-aout-pulse-0.9.9-1.3
libpulse-browse0-0.9.12-9.5
libpulse-mainloop-glib0-0.9.12-9.5
alsa-plugins-pulse-1.0.18-6.13
pulseaudio-module-bluetooth-0.9.12-9.5
libpulsecore4-0.9.12-9.5
pulseaudio-module-zeroconf-0.9.12-9.5
pulseaudio-module-jack-0.9.12-9.5
libxine1-pulse-1.1.15-20.8

rpm -q libasound2

libasound2-1.0.19.git20090304-3.1

uname -a

Linux linux-q3b0 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/sound
alias snd-card-0 snd-atiixp
alias sound-slot-0 snd-atiixp

http://www.alsa-project.org/db/?f=df37c05aadaacd4e6399a2c16164a872f97d0fc6

I have checked the kmix multiple times when iv been changin setting still nothing, even though the speaker tests arent getting any errors. Any help with this would be greatly appreciated as iv kinda lost what im doing lol .
:frowning:

BTW im not a complete noob at opensuse but im not a wizz at it either so please don’t get too complicated.

Okay,
just relax look in there *(http://forums.opensuse.org/applications/multimedia/411795-i-lost-my-sound.html) it may help you out;)

Good luck

Mike*

From what I can see, your sound SHOULD be working. Check your cables. …Also, did you restart your PC after updating the alsa apps.

I highlighted some areas in your mixer you could consider tuning, but I don’t think that will matter. First go to YaST > Hardware > Sound > Other > Volume and move your PCM and Master volume up to 95%. Exit YaST. Start your mixer. Then try tuning it . … I highlighted in orange some aspects to play with. Start with 95% volume, and once established, back off.

Also, test your sound with root permissions. This could be a permissions problem. In fact, its more likely to be permissions related than mixer related as you mixer looks reasonable.

Also, plug in your headset and test your sound with a headset.

!!Amixer output
!!-------------
!!-------Mixer controls for card 0 [IXP]
Card hw:0 ‘IXP’/‘ATI IXP rev 0 with ALC658D at 0xfe029000, irq 17’
Mixer name : ‘Realtek ALC658D’
Simple mixer control ‘Master’,0
Front Left: Playback 55 87%] -12.00dB] [on]
Front Right: Playback 55 87%] -12.00dB] [on]
Simple mixer control ‘PCM’,0
Front Left: Playback 23 74%] [0.00dB] [on]
Front Right: Playback 23 74%] [0.00dB] on]
Simple mixer control ‘Surround’,0
Front Left: Playback 63 [100%] [0.00dB] [on]
Front Right: Playback 63 [100%] [0.00dB] on]
Simple mixer control ‘Center’,0
Mono: Playback 63 [100%] [0.00dB] [on]
Simple mixer control ‘LFE’,0
Mono: Playback 63 [100%] [0.00dB] [on]
Simple mixer control ‘IEC958’,0
Mono: Playback off] Capture [off]
Simple mixer control ‘IEC958 Playback AC97-SPSA’,0
Mono: 3 [100%]
Simple mixer control ‘IEC958 Playback Source’,0
Items: ‘PCM’ ‘Analog1 In’ ‘Analog2 In’ ‘IEC958 In’
Item0: ‘PCM’
Simple mixer control ‘Channel Mode’,0
Items: ‘2ch’ ‘4ch’ ‘6ch’
Item0: ‘2ch’
Simple mixer control ‘Duplicate Front’,0
Mono: Playback off]
Simple mixer control ‘External Amplifier’,0
Mono: Playback on]
In truth, I think your mixer is ok …

If this is permissions related, then there are some work arounds that can be applied.

And don’t let a bad cable connection stop you. :slight_smile:

Its very strange this when i ran the computer today it said something like atiixp not working switching back to default.Then i checked

/usr/sbin/alsa-info.sh

http://www.alsa-project.org/db/?f=3f2f6be4b37acd276637577abe12a47f1ca97d82

Its saying it cant even sense a soundcard. I tried to run alsaconf again but the same /usr/sbin/alsa-info.sh came up with the same. Any ideas ??

my wires seem fine. The speakers i have been using do work as i switched them out to test on another computer. I tried a headset as well with no luck.

ALSO

speaker-test -c2 -l5 -twav

speaker-test 1.0.19

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib confmisc.c:768:(parse_card) cannot find card ‘0’
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings

ALSA lib pcm.c:2205:(snd_pcm_open_noupdate) Unknown PCM default
Playback open error: -2,No such file or directory

Well, your driver is clearly messed up. You have rolled back to 1.0.17 for some reason.

!!ALSA Version
!!------------

Driver version:     1.0.17
Library version:    
Utilities version:  1.0.19

Clearly you have taken some steps backward: …

I need to see again the output of:
rpm -qa | grep alsa
rpm -q libasound2
cat /etc/modprobe.d/sound
and also after reboot, the output URL from running the following (with your PC connected to the internet):
dmesg > dmesg.txt && curl -F file=@dmesg.txt nopaste.com/a
just post the URL.

Is your sound switched ON in your PC’s BIOS?

rpm -qa | grep alsa

alsa-utils-1.0.19.git20090319-1.2
alsa-oss-32bit-1.0.17-1.37
alsa-firmware-1.0.19.git20090317-1.1
alsa-plugins-pulse-1.0.18-6.13
alsa-1.0.19.git20090304-3.1
alsa-plugins-1.0.18-6.13
alsa-oss-1.0.17-1.43
alsa-tools-1.0.19.git20090320-1.2
alsa-driver-kmp-default-1.0.19.20090406_2.6.27.7_9.1-1.1

rpm -q libasound2

libasound2-1.0.19.git20090304-3.1

cat /etc/modprobe.d/sound

alias snd-card-0 snd-atiixp
alias sound-slot-0 snd-atiixp

dmesg.txt - nopaste.com (beta)

i had a look in the bios there wasnt really much on sound but from what i did find, it seemed all on.

Thanks for ya help

When you try ALSACONF. did you got sound it should give you sound

Your alsa-driver-kmp-default has a much newer version than your other apps.

that gives the following:

snd_ac97_codec: disagrees about version of symbol ac97_bus_type
snd_ac97_codec: Unknown symbol ac97_bus_type
snd_atiixp: Unknown symbol snd_ac97_pcm_close
snd_atiixp: Unknown symbol snd_ac97_resume
snd_atiixp: Unknown symbol snd_ac97_pcm_open
snd_atiixp: Unknown symbol snd_ac97_update_bits
snd_atiixp: Unknown symbol snd_ac97_mixer
snd_atiixp: Unknown symbol snd_ac97_bus
snd_atiixp: Unknown symbol snd_ac97_suspend
snd_atiixp: Unknown symbol snd_ac97_get_short_name
snd_atiixp: Unknown symbol snd_ac97_pcm_assign
snd_atiixp: Unknown symbol snd_ac97_tune_hardware

Did you adjust any settings that could have caused this?

Its clear from the diagnostic script output in the previous post that the 1.0.17 driver from the kernel is being loaded, instead of the alsa-driver-kmp rpm. Try re-installing alsa-driver-kmp-default and also the other alsa versions (and libasoudn2) as well (to the latest 1.0.19 version).

Guidance for that is here:
Alsa-update - openSUSE

If his card is not recognized then IMHO it is highly unlikely that alsaconf will work.

i have been setting up samba on the computer , and i do update opensuse often but thats it really.

rpm -qa | grep alsa

alsa-1.0.19.git20090410-1.1
alsa-oss-32bit-1.0.17-1.37
alsa-firmware-1.0.19.git20090317-1.1
alsa-tools-1.0.19.git20090320-1.4
alsa-plugins-pulse-1.0.18-6.13
alsa-plugins-1.0.18-6.13
alsa-utils-1.0.19.git20090410-1.1
alsa-oss-1.0.17-1.43
alsa-driver-kmp-default-1.0.19.20090406_2.6.27.19_3.2-1.

rpm -q libasound2

libasound2-1.0.19.git20090410-1.1

cat /etc/modprobe.d/sound

alias snd-card-0 snd-atiixp
alias sound-slot-0 snd-atiixp

/usr/sbin/alsa-info.sh

http://www.alsa-project.org/db/?f=03e31b9060f12176ae4c65ae8bf0ad2656260793

sorry for the late reply btw, i had a few other things to fix as well

I see you have changed things since your last post. You now have a mix (that is confusing to me) of alsa rpms with 1.0.19, and 1.0.17. Why not update them all to 1.0.19?

I also note this:
**alsa-driver-kmp-default-1.0.19.20090406_2.6.27.19_3.2-1.
**

But according to the diagnostic script /usr/sbin/alsa-info.sh

http://www.alsa-project.org/db/?f=03e31b9060f12176ae4c65ae8bf0ad2656260793

you have:

!!Kernel Information
!!------------------

Kernel release: 2.6.27.21-0.1-default
Operating System: GNU/Linux
Architecture: x86_64
Processor: x86_64
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version: 1.0.17
Library version:
Utilities version: 1.0.19
which shows the 1.0.19 alsa-driver-kmp-default for the 2.6.27.19 kernel is not being loaded because you have the 2.6.27.21 kernel (which has a 1.0.17 alsa module compiled inside).

You probably need to be patient and wait a week or two, until alsa for the 2.6.27.21 kernel is released. Then look at this again.

OK, if you still have the 2.6.27.21 kernel, I see the alsa rpms are now available for that kernel. Hence you could try updating alsa. Accordingly I updated the wiki: Alsa-update - openSUSE