Sound problem hmmmm

95% is working excellent I may have few more problem and it is

#1 I have sound if I shut it down and start up,but if I like playing Music no sound at all.
My sound card is Audigy 1 ,please can one of you help me.

Thank you you`r be so kind to me.


Go to Yast - Hardware - Sound

Your device should be in there
Go the ‘other’ button and select Volume.
Configure and test there

Please copy paste the following sound test into a gnome-terminal or a kde konsole (they look like a small dos window) : speaker-test -c2 -l5 -twav You should hear a ladies voice saying ‘Front left’, ‘Front right’ … 5 times.

If you do NOT hear any sound, please STOP and post here saying you have NO sound. Go no further in this post.

If you do hear the ladies voice, then we know your sound functions, and you probably have a codec problem. So assuming you have a codec problem, we need to update your software package manager repositories so that we can easily update your media players and your codecs.

So please add the following 4 repositories to your software package manager: OSS, Non-OSS, Update and Packman. Just those 4. No others. None. You can add others ONLY after you understand the risks, and know how to fix dependency problems when they occur. There is guidance for adding these 4 repositories here: Repositories/11.1 - openSUSE-Community Again, just OSS, Non-OSS, Update and Packman.

Now, with those 4 added, please go to YaST > Software > Software Management and change the filter to search and then add the packman packaged smplayer, mplayerplug-in, libxine1, amarok, amarok-xine, kaffeine, vlc, and libffmpeg0. The package libffmpeg0 will bring in a number of dependencies which will provide you needed codecs.

Note you should install the packman packaged versions of those apps and not the Novell/SuSE packaged versions. For a number of legal reasons the Novell/SuSE packaged versions are crippled for proprietary codecs.

Ther it is no sound only that:

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 16 to 16384
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
0 - Front Left
1 - Front Right
Time per period = 2.782852
0 - Front Left
1 - Front Right
Time per period = 3.071513
0 - Front Left
1 - Front Right
Time per period = 2.901338
0 - Front Left
1 - Front Right
Time per period = 3.071750
0 - Front Left
1 - Front Right
Time per period = 3.071403

What openSUSE version are you using?

OK, so the speaker test gave no sound (with your current mixer settings).

Yet you state you have system startup and shut down sounds:

If that is correct, I believe you have a problem with your mixer being set inappropriately. In which case my previous post is still applicable, and in addition to following the recommendation there, you will also need to tune your mixer.

The most common mistake is to fail to turn up BOTH master volume and turn up PCM volume.

I would like to get a more detailed look at your settings. To provide more information, with your PC connected to the internet copy and paste the following into a gnome-terminal or konsole:

wget -O && bash 

When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal or konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound
Based on that, I will have a better indication as to what your pc’s sound problem might be.


I follow your instruction u right its so easy. Suse is far easyer then win xp. At that time I write its download and installing.
Installation was successful
Now I restart it from beginning.

1)–2008-12-24 07:36:09--
Resolving Main Page - AlsaProject…
Connecting to||:80… connected.
HTTP request sent, awaiting response… 302 Found
Location:;a=blob_plain;f=utils/ [following]
–2008-12-24 07:36:10--;a=blob_plain;f=utils/
Reusing existing connection to Main Page - AlsaProject.
HTTP request sent, awaiting response… 200 OK
Length: unspecified [text/plain]
Saving to:' Saving to:’

   <=>                                 ] 23,283      42.8K/s   in 0.5s    

2008-12-24 07:36:11 (42.8 KB/s) - `’ saved [23283]

ALSA-Info v 0.4.52

┌────────────────────────ALSA-Info script v 0.4.52──────────────────────────┐
│ │
│ This script will collect information about your ALSA installation and │
│ sound related hardware, to help diagnose your problem │
│ │
│ By default, this script will AUTOMATICALLY UPLOAD your information to a │
Main Page - AlsaProject site. │
│ │
│ See --help for options │
│ │
│ Do you want to run this script? │
│ < Yes > < No > │

ALSA-Info v 0.4.52

│ Uploading information to [Main Page - AlsaProject]( ...                  │      
│  ┌──────────────────────────────────────────────────────────────┐  │      
│  │                               0%                        

Part a)

Part b)

ALSA-Info v 0.4.52

┌───────────────────────────Information uploaded─────────────────────────────┐
│ Would you like to see the uploaded information? │
│ │
│ < Yes > < No > │

│ upload=true&script=true&cardinfo= │─
│ !!################################ │
│ !!ALSA Information Script v 0.4.52 │
│ !!################################ │
│ │
│ !!Script ran on: Wed Dec 24 07:36:18 PST 2008 │
│ │
│ │
│ !!Linux Distribution │
│ !!------------------ │
│ │
│ Welcome to openSUSE 11.1 - Kernel \r (\l). LSB_VERSION="core-2.0-noarch:co │
│ │
│ │
│ !!Kernel Information │
│ !!------------------ │
│ │
│ Kernel release: │
│ Operating System: GNU/Linux │
│ Architecture: i686 │
│ Processor: i686 │
│ SMP Enabled: Yes │
│ │
│ │
│ !!ALSA Version │
│ !!------------ │
│ │
│ Driver version: 1.0.17 │
│ Library version: │
│ Utilities version: 1.0.18 │
│ │
│ < EXIT > │
Your ALSA information is located at

Please inform the person helping you.

That is part b I hope it will help you

Michel, thanks for the script output. If there ever is a “Next time”, please only pass the URL. I’m not interested in the remainder of those two posts.

I note this from your PC’s mixer:Simple mixer control ‘Audigy Analog/Digital Output Jack’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback off]
Simple mixer control ‘External Amplifier’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Please check your 'Audigy Analog/Digital Output Jack and ‘External Amplifier’ settings against the guidance given here: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA - openSUSE Forums](
and adjust those settings to see if you can get sound that way.

I just get home from 1 day trip, I will try it later Merry Christmas to you oldcpu and caf4926.


I copy and past

rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

gelbeseuche@papa-opa2311:~> rpm -qa | grep pulse
gelbeseuche@papa-opa2311:~> rpm -q libasound2
gelbeseuche@papa-opa2311:~> uname -a
Linux papa-opa2311 #1 SMP 2008-12-04 18:10:04 +01006 GNU/Linux
and when I plug in my motherboard comes with
HDA VIA VT82xx sound card I switch to that I can listen my music
Audigy1 I plug into that no sound at all.


I note your sound devices are sharing the same IRQ. What happens when you move your audigy to a difference PCI slot?

Before I do that,I went win xp I got sound ,so do still I change PCI slot?Change Pci slot is so easy to change.
I just open yast patch download and install all those patches,shouldn`t download?


Its up to you. If your motherboard sound works, then you could stick with that.

I don’t understand your post.

Well I have a talk to my friend and there was other solution :wink:
and thank you for your big,big assistance rotfl!rotfl!

Solved the problem.
Tnx to every one how give me big hand.