sound problem after after upgrade to 12.1

Hi there;

After every reboot or log-out, Mixer goes to mute. Also sometimes I’ve got message saying that audio device has been removed. It is built-in audio on Asus M3N78-HDMI mother board.



I encounter a similar issue: no sound from any player (banshee, smplayer) - the test sound within yast (hardware-sound) works

Any ideas?

Here too, I have the same problem. Asus M2N-DH motherboard, x86_64 system.

My MCP61 Intel sound chip is detected and sounds within Yast.
Gnome uses a “factice” device, and don’t detect the MCP61 sound card.
I done an upgrade of my 11.4 system.
Removing gnome various configurations files (gconf*, .local, .gnome*) from my user’s directory did not change the problem.

Sound works when computer is launched from my USB disk drive, fitted with 32 bit system (also an upgrade of 11.4).
(I first try this solution, to test if I can upgrade my main computer without risk :frowning: )

So, if someone have solution… or other tryouts to test, thanks !


@Dickfell - what does say Mixer? Is it muted as in my case? It is strange because Mplayer and Banshee has a mp3 support… I “by default” install all possible codecs, to be sure I’ll be able to play my music and movies.


tomekania, which program do you mean by mixer?

I went through all volume adjusting opportunities I could think of and set them to 95%.
I also tried in the smplayer settings: oss or alsa or pulse but none got loud.

I used to listen radio in banshee - it feels lonely without.

From my side, “pavucontrol” does not show any “hardware device”, while “yast2” found it and makes sounds with it.
I’ll try “esound”.

No more success with esound.

Hi guys,
I had the same problem as Dickfell - yast test sound is ok, but otherwise no sound at all. What solved the problem for me is:

  1. Go to “su” mode
  2. Edit your /etc/group file so the “audio” group contains your user. Do not remove other users in the group :slight_smile:
  3. Reboot

Please let me know if this has worked as it would make really happy if it does (I’m new to openSUSE and want to be a happy community contributor)

Uhh. If only I had this idea. It may be really logical, and easy to correct.

From my side, I completely reinstall openSuse, after formatting. Sound works (but my only groups are video,users).

Now, I have to get back to set all my older parameters, and software.

Does somebody else try to add the group “audio” ?



Adding the group “audio” didn’t work for me. KMix is still muted after reboots.


Mixer == KMix :slight_smile: Sorry, my fault. BTW, moving a slider up and down doesn’t do much if the whole thing is muted; look at the little speaker icon below the slider.

Radio; I use Amarok to listen to the radio. You can make a long list of different stations. To add a stream from drop down menu: Playlist -> Add Stream and for ex.



Had the same problem, after upgrade to 12.1: no sound anymore on my laptop. I used following steps to get around the problem

  • (re-)install pulseaudio: alsa-plugins-pulse, libpulse0, libpulse0-32bit, libpulse-mainloop-glib0, libxine1-pulse, pulseaudio, pulseaudio-module-x11, pulseaudio-utils
  • add my user to the audio group
  • reboot - just to make sure I’m using the new configuration

Have fun,

Adding my user to the audio group helped - thanks.
It’s nice to have sound again.

tomekania, its not your fault, luckily we have a few desktops to choose from.
I started using openSUSE in 2006 with GNOME, I changed to LXDE just before Gnome3.

thanks a lot, Ralf