sound or ati drivers problem??

hi…i’m new to linux (3 months now). [please forgive me for my English if they are not good.]

i used opensuse 10.3 and i installed with format opensuse 11…everything fine…i install ati drivers and then every 15 sec i hear a “tic tic tic” from the speakers… my vga is HD3650. i hear the noise even if all channels are muted… only when i close the speakers tha sound stops beeping…
can u help me plz…i do not want to go back to opensuse 10.3 or windoze…

urs Nick

I have been using the May ati driver for some time now and all my sound problems were due to pulse audio. I don’t know that the ati driver would affect sound in any way, but you can uninstall it and test.

Im having a problem with my ATI driver currently installed. Its what i believe to be the most recent one??
problem: Everything seems to work great in the new Suse 11.0 w/ KDE 4.0 accept the ATI driver the one i installed is loading at 1920 X1080 all the time, and is very glitchy. I have tried other settings ex…1024 x768 but that when tested is way to big. I know it has to be the driver or some of my settings…can anyone help? Im somewhat a noob to Suse…well Linux for that matter but understand technical talking real well.tell me what text or config files you want cut and pasted and ill put them here. any suggestions? Did i do a wrong step? Please Help me fix it. Im trying to go to a complete Linux solution and be rid of Win forever, all that is left is my games.

anyone???

Do you also have a sound problem? How about starting a new thread, with an appropriate title, as opposed to tagging on to someone else’s thread.

What happened when you tried coomac’s suggestion?

Also, did you check your interrupts to confirm the sound and graphics device are not sharing the same interrupt? i.e. to check, in a konsole/xterm/terminal type:
cat /proc/interrupts

cat /proc/interrupts
CPU0 CPU1
0: 117 1 IO-APIC-edge timer
1: 2 2 IO-APIC-edge i8042
4: 3 3 IO-APIC-edge
6: 3 2 IO-APIC-edge floppy
8: 1 0 IO-APIC-edge rtc0
9: 0 0 IO-APIC-fasteoi acpi
16: 268418 914 IO-APIC-fasteoi ahci, uhci_hcd:usb1, eth1, fglrx[0]@PCI:1:0:0
17: 33311 5005 IO-APIC-fasteoi pata_sil680, pata_jmicron, HDA Intel
18: 428175 9588 IO-APIC-fasteoi uhci_hcd:usb3, uhci_hcd:usb6, ehci_hcd:usb7, saa7130[0]
19: 2 0 IO-APIC-fasteoi uhci_hcd:usb5, ohci1394
21: 4 4 IO-APIC-fasteoi uhci_hcd:usb2
22: 1702 3237 IO-APIC-fasteoi ata_piix, ata_piix, HDA Intel
23: 63697 70259 IO-APIC-fasteoi uhci_hcd:usb4, ehci_hcd:usb8
219: 0 1 PCI-MSI-edge eth0
NMI: 0 0 Non-maskable interrupts
LOC: 214273 124083 Local timer interrupts
RES: 6031 4964 Rescheduling interrupts
CAL: 1120 211 function call interrupts
TLB: 2808 2740 TLB shootdowns
TRM: 0 0 Thermal event interrupts
SPU: 0 0 Spurious interrupts
ERR: 0
MIS: 0

I believe HDA Intel is your sound card.

What is pata_sil680? Is that a hard drive (or raid) bus controller? Could it be hard drive activity (with associated interrupts) is causing this problem? and not your graphic card?

sil680 is a pci card with 2 ide controlers on it…my opensuse is on that drive…if u can see there are 2 HDA intel…my grafic card sound is using HDA intel driver…i do not know why…can i disable or delete the grafic card sound driver?

What happened when you tried coomac’s suggestion?

i canot install 8.5 catalyst…do not why

How is related to coomac’s suggestion to remove pulse audio?

i thought he was saying about the drivers… how can i remove pulse audio???

{edit} i do not have pulse audio.should i install it?

Type the following to check if you have any pulse audio related libraries/files:
rpm -qa | grep pulse

No.

did that…anything else to do to may fix the problem?

My apologies. As i said new to this.