Sound only works on one channel

My embedded sound is only working on the right channel.

My Motherboard is a Gigabyte AM2+ with PhenomII X4 Black.
The video is the nVidea GeForce 9500gt with HDMA out.

From Hardware Information.

SBx00 Azlea (intel HDA)
Driver: HDA Intel
Hxcfg Bus: pci
Subvendor: Giga-byte Technology
Sysfs ID:/devices/pci0000:00/0000:14.2
UDI: /org/freedesktop/Hal/devices/pci_1002_4383

I just typed them in.

In Desktop Confguration -> Sound and Video configuration I got rid of everything exept for Pulse Audio Sound Server by un-installing ALSA.

Then I just got done following the guidelines set by oldcpu here:

Multi-media and Restricted Format Installation Guide

And now all is OK but, I still only have one channel. I have two outputs hooked up and it’s the same on both.

My guess is that the kernel module is wrong so I’m about to try to manually enter info into Kernel Settings->PCI ID Setup.
I don’t know if this will correct this, but I’m guessing not.

In the mean time I thought I may get some advice about checking kernel modules and installing them if I need to.

I also get confused about changing kernel flavors. I only need one for this home based machine, but I wonder if I should use the Default or the Desktop it would be nice if someone knew a good explanation to find out what is the difference.

Anyway, thanks,
AARON

What test are you using to confirm only one channel? Please try each of these speaker tests (some of them may not work on your PC):

  • first:
 speaker-test -Dplug:front -c2 -l5 -twav
  • second, try again:
speaker-test -c2 -l5 -twav
  • third:
speaker-test -c2 -D hw:0,0 -t wav -l3
  • fourth, this next command has a volume meter at the bottom of its output with a changing number of #'s and %'s to show volume levels so run this command and tell me if the number of #'s and %'s are changing:
aplay -vv /usr/share/sounds/alsa/Front_*
  • fifth: and also:
aplay -vv /usr/share/sounds/alsa/test.wav

Do any of those give an indication of sound on more than one channel?

… Have you double checked cabling? Speakers?

Can you provide more information ? Please provide the information recommended to be provided in the 2nd half of our multimedia stickie:

… please post … providing in your post the following information:

  • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
    SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script /usr/sbin/alsa-info.sh and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL. Just the URL. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.1 or earlier, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/sound #and post output here
  • for openSUSE-11.2 or later, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

:~> rpm -qa ‘alsa
alsa-oss-32bit-1.0.17-25.2.x86_64
alsa-plugins-jack-1.0.21-3.3.x86_64
alsa-plugins-1.0.21-3.3.x86_64
alsa-plugins-32bit-1.0.21-3.3.x86_64
alsa-plugins-pulse-1.0.21-3.3.x86_64
alsa-firmware-1.0.20-3.2.noarch
alsa-plugins-jack-32bit-1.0.21-3.3.x86_64
alsa-plugins-pulse-32bit-1.0.21-3.3.x86_64
alsa-oss-1.0.17-25.2.x86_64

:~> rpm -qa ‘pulse
vlc-aout-pulse-debuginfo-1.0.5-1.pm.3.20.x86_64
libpulse0-0.9.21-1.2.1.x86_64
libpulse-mainloop-glib0-0.9.21-1.2.1.x86_64
pulseaudio-0.9.21-1.2.1.x86_64
alsa-plugins-pulse-1.0.21-3.3.x86_64
libpulse0-32bit-0.9.21-1.2.1.x86_64
libxine1-pulse-1.1.18.1-1.pm.37.2.x86_64
alsa-plugins-pulse-32bit-1.0.21-3.3.x86_64
pulseaudio-lang-0.9.21-1.2.1.noarch

:~> rpm -q libasound2
libasound2-1.0.21-3.2.x86_64

:~> uname -a
Linux linux-f1tx 2.6.31.12-0.2-default #1 SMP 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux

:~> cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel

5Dex.9zCmC9gVD38:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel

:~> /usr/sbin/alsa-info.sh
bash: /usr/sbin/alsa-info.sh: No such file or directory

incedentally, the sound tests didn’t work, but for the record I am listening to Pandora right now.
It’s just on the right side.

I might suspect cables/connectors if not for the fact that this is happening on two outputs going to two different devices.

You won’t see ALSA in these because I removed it.
It seemed to be interfering with the sound from flash plugin and something else.

I’m using KDE 4.4.1

You removed alsa ???

lol ! That was funny. rotfl!

Sorry, I could not help myself, and I appreciate this single channel problem must be frustrating.

The package “alsa” is an integral part of having properly functioning sound. I recommend you re-install it.

I haven’t laughed so hard in a while.

Yeah,
I’ll put it back, but it is funny because removing it seemed to solve a few quirks.
It made skype work too.

Anyway, I’ve been trying to remember what all happened when things started getting weird.

First there was a printer cue problem that sucked up my entire /tmp dir and loaded my root partition. That caused a neat little crash.

I used the opportunity to make myself an excuse to spend $70 on that cool vid card. Which was definitely a good idea.
I was using ATI before and the drivers are really not satisfactory.

At the same time I wanted to upgrade KDE because I love upgrading KDE. I went to FACTORY 4.4.1

Actually, now that I think about it, I reinstalled CD1 11.2 before only to find that the sound was only working on one channel.

Then I said what the hell, I’ll switch to FACTORY and maybe there’s been a resolution to this. I have run FACTORY for a couple of years now and found that patience seems to be a key.

At any rate, I wonder if there’s a hardware conflict with the vid card and the sound card.

Good stuff, huh?
I’m not great on the CLI but I’m not afraid of it either. I thought I may just compile ALSA myself.

You are definitely adventurous. :slight_smile: I prefer to stay at KDE-4.3.5. Over the years (since SuSE in 2001) I’ve learned that updating KDE beyond the official release can cause various difficult to diagnose problems. Sound in particular is often impacted by updating KDE to unofficial releases. Various users have reported sound hiccups with KDE-4.4.x (and others say no problems) so I confine my support to only the “official” Novell releases, hence I won’t provide support for KDE versions in openSUSE-11.2 > KDE-4.3.5.

Reference alsa, … no need to compile your self. … there is a guide I wrote here (which is not very good because most users can’t update per the guide as they typically update/install packages they should not, remove packages they should not, and do not update/install new packages they should): Alsa-update - openSUSE

Good luck with KDE-4.4.x

Since this is NOT an official KDE version for openSUSE, this thread really belongs in our pre-release/beta software area : Pre-Release/Beta - openSUSE Forums

Ok, cool I just took a quick look and I can be happy with that tutorial.

I’ve been suspecting a module problem. Mostly, because I looked in Yast and never did see an alsa-kmp of any sort.

You do a lot of good work around here. I gotta say thanks. I’ve used many of your tutorials in the past too.

If you want to move this thread I’ll post my results and maybe someone else can get some good from it too.

Naw,
Still mono.

Good resource though.
I’m just thinking the vid card and the sound card won’t get along.
It could be because of the sound processor on the vid card for the HDMI.

I may jerk around in the BIOS and see if I can force an IRQ.

The alsa-driver-kmp rpms referenced on the “alsa update” wiki page are only for updates that go a step beyound the official Novell alsa versions. An alsa developer who works for SuSE-GmbH creates those alsa-kmp rpms, and I believe those are intended to replace the alsa apps that come with the kernel.

Well, it looks like it’ll be like this for a while yet.
It sure did look like I had all that stuff back together. According to Yast, but now when I look at System Settings -> Sound and video Configuration I still only see pulse.
Anyway, pulse is handling everything as well as ALSA was. At least at this point.

Which still means only sound in one channel ?

Did you ever run the diagnostic script to see if it might give a hint as to the problem ?

ie as noted above, provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here: SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information.

On openSUSE-11.1 and newer that will ask you to run the script /usr/sbin/alsa-info.sh and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL. Just the URL. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).

… ie type with pc connected to internet:

/usr/sbin/alsa-info.sh

and if you can’t see the URL, then instead type:

/usr/sbin/alsa-info.sh --no-upload

and look in /tmp/alsa-info.txt

I had to quit for a while then I did the alsa-info thing.

git.alsa-project.org Git - alsa-driver.git/history - utils/alsa-info.sh

is the link. I looked at it. doesn’t mean much to me.

So it said to rerun this: /tmp/alsa-info.6NhNufuJgD updated script, but Permission Denied from # and >

sorry did that wrong,

Here is the correct thing

http://www.alsa-project.org/db/?f=a4213f2fac79a84bda17c61ee12469dddb121c6d

Ahh … thats not the link. You read to be a bit PC challenged here.

Run this command:

/usr/sbin/alsa-info.sh --no-upload

that will create the file /tmp/alsa-info.txt. Open that file alsa-info.txt with a text editor and copy and paste it here: PasteBin.be and press “dump” on that web site . The web site will give you a URL. Post the URL here. Do NOT post the alsa-info.txt here. ONLY post the URL here .

I just looked at the second one. It worked for you didn’t it?

I read through it and understand it superficially, but I can’t analyze it.

I jsut realized I have this all wrong. By mixer I’ve found that it is the front left and the surround right that is working.
I guess I wasn’t fully clear myself, but there must be pin assignment weirdness. So I have right coming from one output and left coming from the other output.
Two devices together and I have stereo. HaHa take that.

It looks like you posted the 2nd one at th same time as I posted, hence I never saw you post.

I took a look now, and this is wierd:

!!ALSA Version
!!------------

Driver version:     1.0.20
Library version:    
Utilities version:  1.0.22


That tells me you have installed some alsa applications OTHER than the baseline and it does NOT match your previous output. So I need to AGAIN also now see the output of:

rpm -qa '*alsa*'
rpm -qa '*pulse*'
rpm -q libasound2
uname -a
cat /etc/modprobe.d/50-sound.conf

OK:

~> rpm -qa ‘alsa
alsa-utils-1.0.21-23.1.x86_64
alsa-oss-32bit-1.0.17-25.2.x86_64
alsa-plugins-jack-1.0.21-3.3.x86_64
alsa-plugins-1.0.21-3.3.x86_64
alsa-plugins-32bit-1.0.21-3.3.x86_64
alsa-plugins-pulse-1.0.21-3.3.x86_64
alsa-driver-kmp-default-1.0.22.1.20100330_2.6.31.5_0.1-1.1.x86_64
alsa-firmware-1.0.20-3.2.noarch
alsa-1.0.22-57.1.x86_64
alsa-plugins-jack-32bit-1.0.21-3.3.x86_64
alsa-plugins-pulse-32bit-1.0.21-3.3.x86_64
alsa-oss-1.0.17-25.2.x86_64

~> rpm -qa ‘pulse
vlc-aout-pulse-debuginfo-1.0.5-1.pm.3.20.x86_64
libpulse0-0.9.21-1.2.1.x86_64
libpulse-mainloop-glib0-0.9.21-1.2.1.x86_64
pulseaudio-0.9.21-1.2.1.x86_64
alsa-plugins-pulse-1.0.21-3.3.x86_64
libpulse0-32bit-0.9.21-1.2.1.x86_64
libxine1-pulse-1.1.18.1-1.pm.37.2.x86_64
alsa-plugins-pulse-32bit-1.0.21-3.3.x86_64
pulseaudio-lang-0.9.21-1.2.1.noarch

~> rpm -q libasound2
libasound2-1.0.21-3.2.x86_64

~> uname -a
Linux linux-f1tx 2.6.31.12-0.2-default #1 SMP 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux

~> cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel

5Dex.9zCmC9gVD38:SBx00 Azalia (Intel HDA)

alias snd-card-0 snd-hda-intel

~> rpm -qa ‘jack
libxine1-jack-1.1.18.1-1.pm.37.2.x86_64
alsa-plugins-jack-1.0.21-3.3.x86_64
libjack0-0.116.2-5.1.x86_64
jack-0.116.2-5.1.x86_64
alsa-plugins-jack-32bit-1.0.21-3.3.x86_64
libjack0-32bit-0.116.2-5.1.x86_64

I threw a jack in there too cause I’m wondering if the software is just confusing the inputs, As in which pins are connected where.

This seems like a strange occurance