Sound only works for root

Just ditched Ubuntu for openSUSE 11.2. I really like it so far but there are several glitches. One that is most annoying at the moment is that my sound card only works as root.

Using SoundBlaster Audigy SE.

Any ideas?


When you say only works for root, how are you testing this? Are you logging in to X as root (ie running the entire desktop as root) or do you note this when you log in as a regular user and run a multimedia application (or speaker test) as root.

The Audigy can be tricky to setup in one’s mixer. Please double check your mixer settings. Take a look at this thread: [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA - openSUSE Forums](
… its old, but the advice still good.

One thing you could try, is add your regular user to group audio and then reboot. Please see the step#6 guidance here: SDB:AudioTroubleshooting - openSUSE - how to fix a permissions problem

I was actually making a new one but I forgot I had X-Fi in the test box, I’ll have to switch it for an Audigy and re-do all those images.

Thanks oldcpu, the second thread you linked worked using usermod -A audio [username], and yes I was logging into X as root rather than running multimedia apps as root from my normal user X session.

Still having some other quirky issues, but not related to sound so I’ll post new threads accordingly.

Thanks again! :wink: