Sound only within yast sound module

I updated from 12.1 to 13.2.

In 12.1, my soundcard worked fine, but now I have the following problem:

When I open the sound module within yast as root, it finds two sound cards: BeaverCreek HDMI Audio and FZH Azalia Controller, both are ‘not configured’.

Thus, I select the first one (BeaverCreek), click on edit - Normal setup - next - test, but I don’t hear any sound. Nevertheless, I click on next to be able to select the FZH-controller. There again, edit - Normal setup - next - test, and I can hear the test sound. When I click next, both sound cards have a card number and snd-hda-intel is mentioned as driver.

When I click on other - play test sound, I only can hear sound for card#1, even if I change the order of the cards, such that BeaverCreek is now #1. Sound is only played for card#1.

When I close yast, I cannot hear any sound at all (testing with Amarok). Even reopening of the yast sound module and running other - play test sound, leaves my speakers silent. It again works, when deleting both sound cards and starting with the above procedure again.

I have searched through different threads, but did not find any solution for this problem.

Thanks a lot!


I have an update to this problem.

When reopening the sound module in yast with both soundcards having a soundcardID, I can hear sound from #1.


If sound works in YaST but not elsewhere, that ‘may’ be a symptom of a permissions problem, which can sometimes be solved by adding group ‘audio’ to one’s user. After such a group change, its easiest to reboot and then test.

Its possible sound is being sent to a not-desired device by pulse audio, and that can sometimes be addressed by installing pauvcontrol and use that to redirect one’s sound to the appropriate device. There are a couple of blogs here providing advice on how to use ‘pavucontrol’ :

Its possible the problem you have encountered is deep at the mixer or alsa driver level, but to see if that is the case I would need much more information, such that can only be obtained by having a diagnostic script run and the information from that shared … ie with PC connected to the Internet in a konsole/xterm send the command:


and do NOT update if asked, and select the SHARE/UPLOAD option and when the script has completed, in the terminal/xterm will be the URL/web-address where the information was uploaded. Post that URL/web-address here for examination.

Good luck.

Thank you, oldcpu,

but I found out myself what was wrong. I reported that it was always only sndcard#1 playing correctly. This gave me the idea to search for setting #1 as the default one. This was not possible within yast.

I found the answer for my problem in which describes how to set card#1 as default.


Glad to read its working for you now. Thank you for sharing your solution.