Sound on Dell Latitude Rugged 14

I have just aquired a Dell Latitude 14 rugged and setup LEAP 15 on it. Almost everything has worked out of the box, but I am having problems with the ALSA setup. Initially the onboard speakers simply did not work. However I established that the hardware was fine because the YAST>SOUND module would play a test signal.

After spending a few hours messing around I have boiled it down to the following behaviour;
-the sound is Intel HD on a ALC3226 chipset for analogue. The HDMI output is setup as card 0 and the ALC3226 is setup as card 1
-the headphone jack works fine when you plug in headphones
-However after a bit off messing around I have gotten the speakers to work, but only if I go into ALSAMIXER and enable the headphone volume slider. This works OK, but has two residual issues :
1-when you plug in the headphones the speaker remains on (making the headphones unusable for private listening)
2-when you unplug the headphones the speaker is muted and needs to by brought back up using the ALSA headphones slider.

So ALSA seems confused and treats headphones and speakers as one.
I came across another thread where someone described exactly the same behaviour with the extra rugged DELL latitude on Ubuntu - so it seems to be a general miss configuration of ALSA across distributions. He never got any assistance.

I could just about live with this level of functionality - but the laptop is a present for my daughter and it will not work if she has to launch ALSAMIXER every time she wants to play media or cannot listen with headphones on public transport. If I cannot get a fix for this I will probably have to restore WIN7 onto the Laptop.

i have tried all of the suse help tutorials which have helped me to get so far, but I am now just going round in circles and do not have enough technical knowledge to go deeper.


This thread provides a partial solution:

Its dealing with the same hardware as mine and it solves almost all of the issues. After running the Pulseaudio setup script I now have control of the headphones via PUVAUDIO. Selecting Headphones brings the speaker online, plugging in the headphone mutes the speaker and enables the Headphones, pulling the headphones switches back to the speaker output but doesn’t enable the speaker since it is still associated with the Headphones. Selecting Headphones via PUVaudio brings back the speaker. If I can get this to work with a gnome extension off the top line then I can live with it.