sound not working

hey guys

there is a new problem for me in linux…

i have installed opensuse 11.2, and i downloaded the latest driver of realtek audio from realtek site…
(reason sound wasnt working)

ALSA lib confmisc.c : 392 : (snd_func_concat) error evaluating strings
ALSA lib conf.c:4154: (_snd_config_evaluate) function snd_func_concat returned error: No such device
ALSA lib confmisc.c:1251: (snd_func_refer) error evaluating name
ALSA lib conf.c:4154: (_snd_config_evaluate) function snd_func_refer returned error: No such device
ALSA lib conf.c:4633: (snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2211: (snd_pcm_open_noupdate) Unknown PCM default

so i decided to install realtek driver…
so i downloaded the packed, and started to install it with ./install command

but then i am getting this error in the setup
“No Legacy Device Are Available”

can u please help me, i have no sound at all

PS:- the above error which i posted i get when i run any audio related utility through console

incase this info helps.

in yast administration (control center)

when i click on sound, i can see that it uses this card for me
“SBx00 Azalia (Intel HDA)
Configured as sound card number 0
Driver snd-hda-intel”

when i go to add a card, i cant see realtek anywhere in the list

Invariably that REALLY messes up your sound.

If your Linux knowledge is weak, its probably quicker for you to just re-install. You could try following the audio troubleshooting guide SDB:AudioTroubleshooting - openSUSE , and the alsa update page Alsa-update - openSUSE (where one will need install the rpms via rpm command or download to desktop and install via zypper if the repos method in that guide fails), but my experience is new users simply mess that up, and it takes 10x longer for them to learn linux basics and implement the updates, when a re-install will be faster for them.

Your call.

reinstall what??

OS or just drivers

Its up to you. Just re-installing the alsa rpms may not help if the realtek drivers deleted the kernel module files.

If I understand what OldCPU is saying he basically means the OS (if your unsure what the drivers did).

The problem is when you install driver’s in linux, it’s not like window’s the driver’s are sorta modular, normally they have a component that loads with the kernel. These can cause hell if your unsure of exactly what was replaced and leave you with a dead system. I know that sound’s kinda scary, it is at first. But it’s not so bad once you get used to thing’s.

Also your card wont show up as a “Realtek” as all the HDA chipsets use the snd_intel_hda driver (i think that’s the right name, it may be the other way around im going from memory lol). It should show up in the sound preferences as “HDA <Whatever the name of the manufacturer is> Analog (Chipset)”, for me this is “HDA Nvidia (ALC888Analog)”.

If you installed driver’s from an RPM you may be able to get OS 11.2 to remove it for you from YaST, Software Management. Do a search on Realtek. Remove what it finds.

For the sound not working at the start, it depends on lot on how and what you were trying to play, a lot of the HDA cards for weird reasons use the PCM output much like “wave output” which isn’t a big deal, but the prob come’s that on install PCM is normally muted :stuck_out_tongue:

i have planned to re-install my windows today…

i will be formating my boot partition and root partition…

if the problem persists i will come back here :slight_smile:

or let u know if its solved or now

I’m not a believer that an MS-Windows re-install will help with Linux sound. But if you re-install Linux, and still have the problem, please in Linux do not install the drivers provided by RealTek, but instead post here and we will try to help.