Sound not working (Card: HDA intel, codec: Conexant CX20551 (Waikiki))

Hello everyone.

My most recent BSoD experience has finally made me throw Windows out the door, and I couldn’t be happier.
I tried a few distro’s and ended up with openSUSE.
Everything is great, I just can’t seem to get my sound working. Nothing happens.
I tried for about a week to fix this using the internet as my guide but I can’t seem to get it done.
I generally don’t like to turn to fora, but here I am. This is my first Linux experience ever, so bear with my newbie-ness.

Now to the point:
I saw a thread where someone had a similar problem, and he was asked to run alsa-info. So that’s what I did.
Here’s the link:
http://www.alsa-project.org/db/?f=4ba8c1360d6ce283197723b45d8f30101e972a73

To me, this information is pretty useless. I hope some of you might be able to help me based on that file, and I hope that one day, maybe, I will be able to help others with problems like this.

Thanks in advance for your time, and my best wishes all those who help develop and test openSUSE or help out other users on fora like this one.

S. Whiteley

From the diagnostic file I note a 32-bit openSUSE-11.4 on a Toshiba P100 laptop. That laptop is notorious for sound not working well under GNU/Linux, due to ACPI/DSDT problems.

I note in older alsa versions the boot code:


acpi_osi=!Linux

was used.

Some users have reported testing the following boot codes

acpi=off: sound plays, but quietly
pci=noacpi: silence
acpi_irq_balance: silence
acpi_irq_nobalance: silence
acpi=oldboot: silence
acpi=ht: sound plays, but quietly

Note also, the CX20551 is also known as the CX5047.

A Patch was applied by some: https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2485 (which I don’t know anything about).

The main recommendation appears to be a complex update of the DSDT, with a thread here where others updated the DSDT: Gentoo Forums :: View topic - Solved (was: snd-hda-intel works only with acpi=off)