Sound not working after installation

Hi, I have recently installed Leap 15.3 on my new laptop computer and unfortunately the sound doesn’t work at all. Installing the 15.2 version solved the problem, but I probably need to stick with 15.3 for cuda with my graphics card which I use for my projects. I have installed the alsa-firmware and sof-firmware package as well as pulseaudio with pavucontrol.

 lspci | grep audio 

gives

[FONT=monospace]00:1f.3 Multimedia **audio** controller: Intel Corporation Tiger Lake-H HD Audio Controller (rev 11)
hwinfo --sound 

shows

 17: PCI 1f.3: 0401 Multimedia audio controller                   
  [Created at pci.386] 
  Unique ID: nS1_.YVryd_Q0X_6 
  SysFS ID: /devices/pci0000:00/0000:00:1f.3 
  SysFS BusID: 0000:00:1f.3 
  Hardware Class: sound 
  Device Name: "Onboard - Sound" 
  Model: "Intel Multimedia audio controller" 
  Vendor: pci 0x8086 "Intel Corporation" 
  Device: pci 0x43c8  
  SubVendor: pci 0x1028 "Dell" 
  SubDevice: pci 0x0a8d  
  Revision: 0x11 
  Driver: "sof-audio-pci" 
  Driver Modules: "snd_sof_pci" 
  Memory Range: 0x6233198000-0x623319bfff (rw,non-prefetchable) 
  Memory Range: 0x6233000000-0x62330fffff (rw,non-prefetchable) 
  IRQ: 164 (2232 events) 
  Module Alias: "pci:v00008086d000043C8sv00001028sd00000A8Dbc04sc01i00" 
  Driver Info #0: 
    Driver Status: snd_hda_intel is active 
    Driver Activation Cmd: "modprobe snd_hda_intel" 
  Driver Info #1: 
    Driver Status: snd_sof_pci is active 
    Driver Activation Cmd: "modprobe snd_sof_pci" 
  Config Status: cfg=yes, avail=yes, need=no, active=unknown

The configuration of the sound card in Yast is possible, but nevertheless in pavucontrol no audio devices are detected (except the dummy). I have also tried some recommended changes in the 50-sound.conf from the official openSUSE sound-troubleshooting, but it also didn’t resolve the issue. I am using openSUSE since a while, but I am definitely not an expert.

Thanks in advance

[/FONT]

I would recommend running the alsa-info.sh diagnostic script to start with as outlined in the troubleshooting guide. It will take care of uploading the output to an online server. You can share the link that it provides here.

FWIW, we had a recent thread concerning the same audio chipset. There it was found that a newer kernel was required (refer post #38 on-wards). It is interesting that you mention that sound works with the older kernel that openSUSE Leap 15.2 uses. Anyway, you could try testing with kernel 5.15 from Kernel:stable:backport perhaps. However, you would need be aware that if you have proprietary graphics drivers installed, you’d need to build manually against the running kernel.

https://forums.opensuse.org/showthread.php/561168-Which-Newer-Kernel-Version-to-Use?p=3075351#post3075351
https://download.opensuse.org/repositories/Kernel:/stable:/Backport/standard/

As deano_ferrai recommended, please do run the diagnostic script alsa-info.sh to provide more information. You can do that by opening a konsole or xterm (ie a bash shell) and as a regular user with your PC connected to the internet type:


/usr/sbin/alsa-info.sh

and select the share/upload option. Let the script run to completion. Then look in the konsole/xterm and you will see mentioned a URL/address where the script output was uploaded. Please post that URL/address here.

I have a TigerLake CPU on my new Lenovo X1 Carbon gen9 (X1C9), its running LEAP-15.3 and sound works great on it (worked with the supplied 5.3.18 kernel and also with a newer 5.14.11 kernel), so this should be solvable. Of course sof-firmware is needed, and you mentioned you have that installed.

.

ILL problems with Pipewire.
Update Pipewire from Experimental repo or install pipewire-pulseaudio or uninstall Pinewire with installation of PulseAudio.

I got the following link

http://alsa-project.org/db/?f=67fc91be772842cd805bad901c2035e181fe249f

Your sound device is detected, and it can be seen in the aplay and arecord as card-0. Assuming you are trying to play sound via analog sound that device would be hw:0,0. If playing via the laptop’s digital sound, it would be hw:0,1.

Your volume levels are relatively low (52% for Master, and 45% for Speaker). On my TigerLake, with those volume levels, I would pretty much hear nothing. Higher level adjustments may be needed. Maybe increase those volume control levels a bit (try 90% with both) to see if that allows you to hear something? Also, run pavucontrol (pulse audio volume control - you may need to install it) and use it to select your audio device and increase the volume levels.

If the above fails to give you audio, could you do the following tests in a bash shell (ie xterm/konsole) as a regular user, and if that fails, then with root permissions.

Test analog sound at alsa level

aplay -D hw:0,0 -vv /usr/share/sounds/alsa/test.wav

Test digital sound at alsa level

aplay -D hw:0,1 -vv /usr/share/sounds/alsa/test.wav

Test analog sound at alsa level (suspending pulse audio for this command only)

pasuspender -- aplay -D hw:0,0 -vv /usr/share/sounds/alsa/test.wav

Test digital sound at alsa level (suspending pulse audio for this command only)

pasuspender -- aplay -D hw:0,1 -vv /usr/share/sounds/alsa/test.wav

if no success there, I note that the diagnostic script you ran gave no dmesg, as you have not setup your PC to give permissions for a regular user to access dmesg. So perhaps, strictly so I can see the dmesg, can you try:


sudo /usr/sbin/alsa-info.sh

and post the link to where the diagnostic script was uploaded. I want to see the dmesg, which is why in this case I am asking it run with root permissions.

First of all, thanks a lot for your help! Unfortunately I cannot even find my sound card in pavucontrol to adjust the volume control levels, it doesn’t seem to be detected correctly there.

The first test shows no error message, but I cannot here any sound though. I obtain error messages only from all other tests, e.g. something like “connection refused/failed”.

Here is the new alsa-link: http://alsa-project.org/db/?f=cd3b855cc7e470c863057489ab9d15dac190eb81

One speculative possibility is that you have installed an sof-firmware that is too new for your kernel.

I note you have " sof-firmware-1.8-lp153.33.1.noarch "

Further I note this in the dmesg:


    9.862286] sof-audio-pci 0000:00:1f.3: Firmware info: version 1:8:0-9e7a8
    9.862287] sof-audio-pci 0000:00:1f.3: Firmware: ABI 3:18:1 Kernel ABI 3:18:0
    9.862287] sof-audio-pci 0000:00:1f.3: warn: FW ABI is more recent than kernel
...
[59977.483109] sof-audio-pci 0000:00:1f.3: warn: FW ABI is more recent than kernel 

I think LEAP-15.3 comes with an older sof-firmware than 1.8 (I believe 1.6 ?? ).

Edit - I note: I note from http://download.opensuse.org/distribution/openSUSE-current/repo/oss/noarch/ that LEAP-15.3 comes with sof-firmware-1.6.1-2.9.

Could you downgrade to the older 1.6 sof-firmware, then reboot and test ?

I don’t know for certain this is the issue, but I am puzzled over the massive errors in the dmesg.
.