Sound not work - change permissions?

Sound is not working on my openSUSE 11.2 x64 desktop. It works as root, which means it is likely a permissions problem. I looked at SDB:AudioTroubleshooting STEP-6: How To Fix a Permissions Problem. The problem is that I am using windows kerberos authentication, which means users do not appear in my users list so I can’t add anyone to the audio group (or any other group for that matter, at least that I have been able to find). So the workaround in the link does not help me. Is there a way to change the permissions on the other end? That is, can I force the sound card to accept input from ordinary users who are not part of the audio group?


usermod -A audio yourusername

did not help, then neither can I. I know nothing about windows kerberos authentication. I assume you can not disable that? Then change permissions? Then re-enable it?

Note when changing permissions, one needs to restart afterward to test to see if it worked.

I’ve got a similar problem with my sound card. About every 2-3 reboots, the system “forgets” the settings. I have to go into YAST, reset the values for the card, save that, then reboot again to once again get sound.

Any ideas?

rlayten wrote:
> I’ve got a similar problem with my sound card. About every 2-3 reboots,
> the system “forgets” the settings.

in the session just before the reboot where you see it has ‘forgotten’
the sound setting, what did you do that also was done in the session
before the last time it ‘forgot’?

i mean, like did you:

  • run YaST online update?
  • run YaST software management?
  • run Konqueror or Dolphine as root?
  • log into KDE/GNOME or other desktop environment as root?
  • run any sound system controlling or using application as root?
    (like, do you have anything which doesn’t have good sound unless you
    are running as root?)
  • have any sound controlling or using programs crash
  • have a shutdown which was not via software, and smooth? (like maybe
    someone pulled the plug, did a Ctrl+Alt+something exit, did a suspend
    or hibernate that didn’t wake up again…or or or)
  • if you usually log into KDE but during the day you logged into
    GNOME/XFCE/OTHER, or vice versa?
  • at any time during the session run Pulse Audio?

if you don’t know what might have occurred in the session preceeding
the forgotten sound settings, then it might be helpful to start
recording any of those things and then you might see the same thing
being done by you, or occurring by accident once “About every 2-3
reboots” …and, thereby learn the cause of the ‘forgetting’ (for,
i’m pretty darn sure it is not a ghost causing the
forgetting…[because for it to forget, the configuration files MUST be
changed…and, ghost without the root password can’t do that…]


usermod does not work, changes forgotten on reboot. And the users, although they have a home directory, do not appear to be stored as part of the normal user list, so disabling and re-enabling it would not work. Further, it would need to be done for each user, part of the reason I am using kerberos in the first place is so anyone can use the computer (actually, computers).

There isn’t some way to change the permissions for the audio device?