Sound level problem with opensuse 12.1 64bit

Hi Folks,

I’ve recently preformed a fresh install of Opensuse 12.1 64bit, selecting Gnome 3.2 as my desktop environment (although the problem is the same with a KDE 4.7 Opensuse installation). Now I am having a weird problem with my headphone sound level (The headphones are branded as Trust 5.1 and work fine with LinuxMint Debian Edition 64 bit).

Basically, if I move the volume control in gnome3 (or kde4) below 100% I get no sound, I was wondering if anyone has come across this problem before and could provide me with there solution.

Included below is the information that was suggested as required, in another sound issue thread; If there is anything else that will prove useful please just leave a comment and I will update the thread with the required information.

patrickd@linux-ns8j:~> lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 0d8c:0006 C-Media Electronics, Inc. Storm HP-USB500 5.1 Headset
Bus 002 Device 003: ID 045e:00dd Microsoft Corp. Comfort Curve Keyboard 2000 V1.0
Bus 002 Device 004: ID 046d:c51b Logitech, Inc. V220 Cordless Optical Mouse for Notebooks

Your ALSA information is located at http://www.alsa-project.org/db/?f=18ce6ba285e0c8e2df4bf78cfbbbdc5c956589b7

patrickd@linux-ns8j:~> rpm -qa ‘alsa
alsa-utils-1.0.24.2-12.8.1.x86_64
alsa-plugins-1.0.24-18.1.2.x86_64
alsa-plugins-pulse-32bit-1.0.24-18.1.2.x86_64
alsa-plugins-pulse-1.0.24-18.1.2.x86_64
alsa-1.0.24.1-23.1.2.x86_64
alsa-plugins-32bit-1.0.24-18.1.2.x86_64
alsa-oss-32bit-1.0.17-37.1.2.x86_64
alsa-oss-1.0.17-37.1.2.x86_64
patrickd@linux-ns8j:~> rpm -qa ‘pulse
pulseaudio-module-gconf-1.1-1.2.x86_64
pulseaudio-utils-1.1-1.2.x86_64
pulseaudio-module-x11-1.1-1.2.x86_64
alsa-plugins-pulse-32bit-1.0.24-18.1.2.x86_64
pulseaudio-module-zeroconf-1.1-1.2.x86_64
alsa-plugins-pulse-1.0.24-18.1.2.x86_64
libpulse-mainloop-glib0-1.1-1.2.x86_64
pulseaudio-module-bluetooth-1.1-1.2.x86_64
libpulse0-32bit-1.1-1.2.x86_64
pulseaudio-1.1-1.2.x86_64
libpulse0-1.1-1.2.x86_64
pulseaudio-module-lirc-1.1-1.2.x86_64
patrickd@linux-ns8j:~> rpm -q libasound2
libasound2-1.0.24.1-23.1.2.x86_64
patrickd@linux-ns8j:~> uname -a
Linux linux-ns8j 3.1.0-1.2-desktop #1 SMP PREEMPT Thu Nov 3 14:45:45 UTC 2011 (187dde0) x86_64 x86_64 x86_64 GNU/Linux
patrickd@linux-ns8j:~> cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel,snd-usb-audio

CvwD.ogeivhqvAEA:MCP61 High Definition Audio

alias snd-card-0 snd-hda-intel

FKGF.o93xMCYmqfD:USB Audio

alias snd-card-1 snd-usb-audio

Thanks for taking the time to read this post and I hope someone can point me towards a solution.
Best regards,
P.

What does that diagnostic script mean ? ie what configuration is that ? Is that a configuration with sound or with no sound. Please don’t force us to guess and possibly draw wrong conclusions … I assume its a configuration with no sound ?

Note I don’t have USB speakers nor headset, so I have not encountered this. I know next to nothing (other than basic practical theory) about such USB devices.

I note this from the script:


!!-------Mixer controls for card 1 [Audio]

**Card hw:1 'Audio'/'USB Audio at usb-0000:00:02.0-1, full speed'**
  Mixer name	: 'USB Mixer'
  Components	: 'USB0d8c:0006'
  Controls      : 12
  Simple ctrls  : 7
**Simple mixer control 'Speaker',0**
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 37
  Mono: Playback 34 **[92%]** [0.12dB] [on]
**Simple mixer control 'PCM',0**
  Capabilities: cvolume penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 16
  Front Left: Capture 8** [50%]** [7.99dB]
  Front Right: Capture 8 **[50%]** [7.99dB]
**Simple mixer control 'Line',0**
  Capabilities: pvolume cvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 8191 Capture 0 - 16
  Front Left: **Playback** 2048 **[25%]** [7.99dB] [off] Capture 0 [0%] [0.00dB]
  Front Right: **Playback** 2048 **[25%]** [7.99dB] [off] Capture 0 [0%] [0.00dB]
**Simple mixer control 'Mic',0**
  Capabilities: pvolume cvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 32 Capture 0 - 16
  Front Left: **Playback** 8 **[25%]** [7.99dB] [off] Capture 10 [62%] [9.99dB]
  Front Right: **Playback** 8 **[25%]** [7.99dB] [off] Capture 10 [62%] [9.99dB]

ie everywhere I look the volume setting is very low.

You can try YaST > Hardware > Sound and select the USB device and confirm under Other (lower right corner) that the volume levels are appropriate. Also you can still use alsamixer in KDE.

I’m away on business for the next 2 days and my personal life is currently complicated so it may be some time before I can reply to this thread. Hopefully someone else will pitch in and help. Good luck.